Opened 15 years ago

Closed 13 years ago

Last modified 13 years ago

#43 closed defect (wontfix)

rtsp:// files should default to a lower cache than 8 Mbytes!

Reported by: mplayer@… Owned by: alex@…
Priority: normal Component: core
Version: 1.0pre5 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

When loading a realaudio stream via:

mplayer rtsp://rmv8.bbc.net.uk/worldservice/offtheshelf5_v8.ra

The cache size defaults to 8192 kBytes. This is somewhat oversize! The result is
that the playback takes *ages* to start, even on a fast connection, especially
if the server is throttling the stream (as the BBC do).
100 kByte might be a more reasonable size.

Change History (5)

comment:1 Changed 15 years ago by reimar

Read the manual!
Have a look at the -cache -cache-prefill and -cache-min options!
Well, the last two seem to be undocumented at the moment, they (more or less)
specify how much percent of the cache must be filled before starting playback.

comment:2 Changed 15 years ago by mplayer@…

Thanks for your reply. I did read the manual, and I know about the -cache
option. But I think that mplayer could be smarter by default. Also, that manual
is so complex that it confuses me sometimes: a relative newbie would never find
the option!

Richard

comment:3 Changed 15 years ago by r_togni@…

There is no easy way to do it.
As you can see looking at MPlayer console messages (use -v to get more), cache
is filled before file is parsed by demuxer, so MPlayer knows nothing about the
file until cache is not filled enough to start playback.
Cache is started automatically for network streams (else you have to use
-cache), and size depends on stream type. Real rtsp demuxer have quite a big
cache because it's needed for video streams, and MPlayer has no way to tell that
stream is audio only before playback starts.

comment:4 Changed 15 years ago by mplayer@…

Thanks for your comment. If it can't be done. I guess that's fair enough.
How about the following though:

if ((the cache is not nearly full within 20 seconds) AND (no cache size has been
specified on the command line)); then start playing anyway.

That should catch the problem of things like the BBC radio on demand service
which is seriously throttled, and will only load at a slow rate (i.e. it's not
friendly to downloading lots of it in advance).

But otherwise, I guess that this is a wontfix (although perhaps an error message
would be helpful.)

comment:5 Changed 13 years ago by reimar

  • Resolution set to wontfix
  • Status changed from new to closed

This is wontfix, second-guessing the user is not an option to me, and a really
low value for -cache-min works out well enough for me.

Note: See TracTickets for help on using tickets.