Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#430 closed defect (wontfix)

[PATCH] CPU detection code disables SSE on MinGW platform

Reported by: ranma57@… Owned by: saschasommer@…
Priority: unimportant Component: core
Version: HEAD Severity: minor
Keywords: Cc: diego@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Added MINGW32 to the list of OS with SSE support.

Index: cpudetect.c
===================================================================
RCS file: /cvsroot/mplayer/main/cpudetect.c,v
retrieving revision 1.42
diff -u -r1.42 cpudetect.c
--- cpudetect.c 7 Nov 2005 16:16:14 -0000 1.42
+++ cpudetect.c 4 Jan 2006 16:17:37 -0000
@@ -172,7 +172,7 @@

#endif


/* FIXME: Does SSE2 need more OS support, too? */

-#if defined(linux) defined(FreeBSD) defined(NetBSD)

defined(CYGWIN) +#if defined(linux) defined(MINGW32)
defined(OpenBSD) defined(DragonFly)
defined(FreeBSD) defined(NetBSD)
defined(CYGWIN) defined(OpenBSD)

defined(DragonFly)

if (caps->hasSSE)

check_os_katmai_support();

if (!caps->hasSSE)

Attachments (1)

mingw32_cpuid.diff (759 bytes) - added by ranma57@… 13 years ago.
Patch

Download all attachments as: .zip

Change History (5)

Changed 13 years ago by ranma57@…

Patch

comment:1 Changed 13 years ago by ranma57@…

comment:2 Changed 13 years ago by diego@…

  • Owner changed from alex@… to saschasommer@…

comment:3 Changed 13 years ago by diego@…

  • Resolution set to wontfix
  • Status changed from new to closed

I believe SSE was disabled because of recurring crashes. Sascha, reopen the
patch if I am mistaken.

comment:4 Changed 13 years ago by diego@…

  • Cc diego@… added
Note: See TracTickets for help on using tickets.