Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#431 closed defect (invalid)

Compile error in libdha

Reported by: mplayerbugs@… Owned by: diego@…
Priority: normal Component: build system
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

The error in the pastebin link in the URL field occurs on my Powerbook G3
(pismo) running Linux 2.6.11.7 (not entirely sure the /usr/include/linux is from
that version). The distribution is Debian. MPlayer code is CVS from about an
hour ago as of this writing.

Change History (4)

comment:1 Changed 14 years ago by mplayerbugs@…

The following is the contents of the paste, in case it expires:

make -C libdha
make[1]: Entering directory `/home/bhv1/src/main/libdha'
cc -c -I../libvo -I../../libvo -I/usr/X11R6/include -O4 -mcpu=740 -mtune=740
-pipe -ffast-math -fomit-frame-pointer -D_REENTRANT -D_LARGEFILE_SOURCE
-D_FILE_OFFSET_BITS=64 -fPIC -I. -I.. -o pci.o pci.c
In file included from /usr/include/linux/pci.h:20,

from sysdep/pci_linux.c:134,
from pci.c:64:

/usr/include/linux/mod_devicetable.h:18: error: syntax error before "u32"
/usr/include/linux/mod_devicetable.h:20: error: syntax error before "class"
/usr/include/linux/mod_devicetable.h:21: error: syntax error before "driver_data"
/usr/include/linux/mod_devicetable.h:31: error: syntax error before "u32"
/usr/include/linux/mod_devicetable.h:33: error: syntax error before "model_id"
/usr/include/linux/mod_devicetable.h:34: error: syntax error before "specifier_id"
/usr/include/linux/mod_devicetable.h:35: error: syntax error before "version"
/usr/include/linux/mod_devicetable.h:36: error: syntax error before "driver_data"
/usr/include/linux/mod_devicetable.h:99: error: syntax error before "
u16"
/usr/include/linux/mod_devicetable.h:103: error: syntax error before "idProduct"
/usr/include/linux/mod_devicetable.h:104: error: syntax error before "bcdDevice_lo"
/usr/include/linux/mod_devicetable.h:105: error: syntax error before "bcdDevice_hi"
/usr/include/linux/mod_devicetable.h:108: error: syntax error before "bDeviceClass"
/usr/include/linux/mod_devicetable.h:109: error: syntax error before
"bDeviceSubClass"
/usr/include/linux/mod_devicetable.h:110: error: syntax error before
"bDeviceProtocol"
/usr/include/linux/mod_devicetable.h:113: error: syntax error before
"bInterfaceClass"
/usr/include/linux/mod_devicetable.h:114: error: syntax error before
"bInterfaceSubClass"
/usr/include/linux/mod_devicetable.h:115: error: syntax error before
"bInterfaceProtocol"
/usr/include/linux/mod_devicetable.h:118: error: syntax error before "driver_info"
/usr/include/linux/mod_devicetable.h:135: error: syntax error before "u16"
/usr/include/linux/mod_devicetable.h:138: error: syntax error before "dev_type"
/usr/include/linux/mod_devicetable.h:139: error: syntax error before "cu_model"
/usr/include/linux/mod_devicetable.h:140: error: syntax error before "dev_model"
/usr/include/linux/mod_devicetable.h:142: error: syntax error before "driver_info"
make[1]: * [pci.o] Error 1
make[1]: Leaving directory `/home/bhv1/src/main/libdha'
make:
* [libdha/libdha.so] Error 2

comment:2 Changed 14 years ago by diego@…

  • Status changed from new to assigned

Looks like your kernel headers are broken or mismatched with the kernel you run.

It compiles fine for me on Debian unstable. What Debian version do you run,

which kernel and kernel-headers package do you have installed?

comment:3 Changed 14 years ago by mplayerbugs@…

I'm tracking unstable. The kernel is a self-compiled 2.6.11.7. I just copied
/usr/src/linux-2.6.11.7/include/linux/ to /usr/include/ and the same error is
produced.

comment:4 Changed 14 years ago by diego@…

  • Resolution set to invalid
  • Status changed from assigned to closed

Try building a proper kernel kernel-headers package with kernel-package and
install the linux-kernel-headers package. I'm convinced this is a problem on
your side, resolving as INVALID for now. REOPEN the bug if you still have problems.

Note: See TracTickets for help on using tickets.