Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#447 closed defect (duplicate)

bad search path for ldconfig at $sudo make install

Reported by: stranche@… Owned by: diego@…
Priority: normal Component: build system
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

When building MPlayer from CVS, the "sudo make install" command gives a
"ldconfig: Command not found"

$ sudo make install
Password:
make[1]: Entering directory `/home/stranche/test/main/libdha'
mkdir -p /usr/local/lib
install -m 755 -p libdha.so.1.0 /usr/local/lib/libdha.so.1.0
rm -f /usr/local/lib/libdha.so
ln -sf libdha.so.1.0 /usr/local/lib/libdha.so.1
ldconfig
make[1]: ldconfig: Command not found
make[1]: * [install] Error 127
make[1]: Leaving directory `/home/stranche/test/main/libdha'
make[1]: Entering directory `/home/stranche/test/main/vidix'
make[2]: Entering directory `/home/stranche/test/main/vidix/drivers'
mkdir -p /usr/local/lib/mplayer/vidix
install -m 755 -p *.so /usr/local/lib/mplayer/vidix
make[2]: Leaving directory `/home/stranche/test/main/vidix/drivers'
make[1]: Leaving directory `/home/stranche/test/main/vidix'
if test ! -d /usr/local/bin ; then mkdir -p /usr/local/bin ; fi
install -m 755 -s mplayer /usr/local/bin/mplayer
if test ! -d /usr/local/man/man1 ; then mkdir -p /usr/local/man/man1; fi
for i in en; do \

if test "$i" = en ; then \

install -c -m 644 DOCS/man/en/mplayer.1

/usr/local/man/man1/mplayer.1 ; \

else \

mkdir -p /usr/local/man/$i/man1 ; \
install -c -m 644 DOCS/man/$i/mplayer.1

/usr/local/man/$i/man1/mplayer.1 ; \

fi ; \

done
install -m 755 -s mencoder /usr/local/bin/mencoder
for i in en; do \

if test "$i" = en ; then \

ln -sf mplayer.1 /usr/local/man/man1/mencoder.1 ; \

else \

ln -sf mplayer.1 /usr/local/man/$i/man1/mencoder.1 ; \

fi ; \

done

system is running Linux Fedora core 4 on Opteron system (x86_64)

ldconfig is in /sbin/, this path should be searched and included in the
generated Makefile since we're generaly not working in root (dangerous, bad,
gaaaaah) but doing sudo at the necessary time.

Change History (1)

comment:1 Changed 13 years ago by stranche@…

  • Resolution set to duplicate
  • Status changed from new to closed

* This bug has been marked as a duplicate of 446 *

Note: See TracTickets for help on using tickets.