Opened 13 years ago

Closed 12 years ago

#448 closed defect (fixed)

dts hwac3

Reported by: luzik@… Owned by: alex@…
Priority: normal Component: ao
Version: 1.0pre7 Severity: normal
Keywords: Cc: dominik@…, ulion2002@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I can't play dts wav files using -ac hwdts
..there are:
"a52: CRC check failed! %
DTS: Only 48kHz supported, REPORT BUG
DTS: Termination frames not handled, REPORT BUG"
-error messages

[luzik@tratwa main]$ mplayer ../../../DC/new/DireStraits/01\ so\ far\ away.wav
-v -ac hwdts
MPlayer 1.0pre7try2-3.3.6 (C) 2000-2005 MPlayer Team
CPU: Intel (Family: 8, Stepping: 1)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetection.

85 audio & 196 video codecs
CommandLine?: '../../../DC/new/DireStraits/01 so far away.wav' '-v' '-ac' 'hwdts'
init_freetype
get_path('font/font.desc') -> '/home/users/luzik/.mplayer/font/font.desc'
font: can't open file: /home/users/luzik/.mplayer/font/font.desc
Font /usr/share/mplayer/font/font.desc loaded successfully! (210 chars)
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay?
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup
scripts.
Using nanosleep() timing
get_path('input.conf') -> '/home/users/luzik/.mplayer/input.conf'
Can't open input config file /home/users/luzik/.mplayer/input.conf: No such file
or directory
Parsing input config file /etc/mplayer/input.conf
Input config file /etc/mplayer/input.conf parsed: 59 binds
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : No such file or directory
Can't init input joystick
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support.
You will not be able to use your remote control.
get_path('01 so far away.wav.conf') -> '/home/users/luzik/.mplayer/01 so far
away.wav.conf'
Playing ../../../DC/new/DireStraits/01 so far away.wav.
[file] File size is 55033900 bytes
STREAM: [file] ../../../DC/new/DireStraits/01 so far away.wav
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
CACHE_PRE_INIT: 0 [0] 0 pre:0 eof:1327104
Cache fill: 16.21% (1359872 bytes) Checking for YUV4MPEG2
ASF_check: not ASF guid!
Checking for Nullsoft Streaming Video
Checking for NuppelVideo?
Checking for REAL
Checking for SMJPEG
Searching demuxer type for filename ../../../DC/new/DireStraits/01 so far
away.wav ext: .wav
Trying demuxer 17 based on filename extension
==> Found audio stream: 0
======= WAVE Format =======
Format Tag: 1 (0x1)
Channels: 2
Samplerate: 44100
avg byte/sec: 176400
Block align: 4
bits/sample: 16
cbSize: 0
===========================
[demux_audio] DTS audio in wav, 14 bit, LE
demux_audio: audio data 0x2C - 0x347C02C
Audio file detected.
==========================================================================
Forced audio codec: hwdts
Opening audio decoder: [hwac3] AC3/DTS pass-through S/PDIF
dec_audio: Allocating 8192 bytes for input buffer.
dec_audio: Allocating 16384 + 65536 = 81920 bytes for output buffer.
No accelerated IMDCT transform found
hwac3: switched to AC3, 320000 bps, 48000 Hz
a52: CRC check failed!
AUDIO: 48000 Hz, 2 ch, ac3, 320.0 kbit/20.83% (ratio: 40000->192000)
Selected audio codec: [hwdts] afm:hwac3 (DTS through S/PDIF)
==========================================================================
Checking audio filter chain for 48000Hz/2ch/ac3 -> 48000Hz/2ch/ac3...
[libaf] Adding filter dummy
[dummy] Was reinitialized: 48000Hz/2ch/ac3
AF_pre: 48000Hz/2ch/ac3
ao2: 48000 Hz 2 chans ac3
audio_setup: using '/dev/dsp' dsp device
audio_setup: using '/dev/mixer' mixer device
audio_setup: using 'pcm' mixer device
[AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or directory
alsa-init: requested format: 48000 Hz, 2 channels, 100
alsa-init: compiled for ALSA-1.0.10rc3
alsa-spdif-init: playing AC3, 2 channels
alsa-init: 1 soundcard found, using: iec958:{CARD 0 AES0 0x02 AES1 0x82 AES2
0x00 AES3 0x02}
alsa-init: pcm opend in block-mode
alsa-init: chunksize set to 1024
alsa-init: fragcount=16
alsa-init: got buffersize=65536
alsa: 48000 Hz/2 channels/4 bpf/65536 bytes buffer/Signed 16 bit Little Endian
AO: [alsa] 48000Hz 2ch ac3 (1 bps)
AO: Description: ALSA-0.9.x-1.x audio output
AO: Author: Alex Beregszaszi, Zsolt Barat <joy@…>
AO: Comment: under developement
Building audio filter chain for 48000Hz/2ch/ac3 -> 48000Hz/2ch/ac3...
[dummy] Was reinitialized: 48000Hz/2ch/ac3
[dummy] Was reinitialized: 48000Hz/2ch/ac3
Video: no video
Freeing 0 unused video chunks.
Starting playback...
alsa-space: free space = 65536, prepared --
a52: CRC check failed!
a52: CRC check failed!
a52: CRC check failed!
a52: CRC check failed!
a52: CRC check failed!
a52: CRC check failed!
a52: CRC check failed!
a52: CRC check failed!
a52: CRC check failed!
a52: CRC check failed!
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
DTS: Only 48kHz supported, REPORT BUG
a52: CRC check failed!
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
DTS: Termination frames not handled, REPORT BUG
a52: CRC check failed!
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
a52: CRC check failed! %
A: 4.3 (04.3) 19.3% 45%

MPlayer interrupted by signal 2 in module: play_audio
Uninit audio filters...
[libaf] Removing filter dummy
uninit audio: hwac3

MPlayer interrupted by signal 2 in module: enable_cache
alsa-uninit: pcm closed
vo: x11 uninit called but X11 not inited..
[luzik@tratwa main]$

also have problems with recognition dts from cdaudio.

if you want this dts wav file please give me some ftp upload site

Change History (6)

comment:1 Changed 13 years ago by luzik@…

using ffdts for the same file working just fine fine,and my hardware cd player
forwarding dts stream to hardware decoder/amplifier without any problems. I have
over 40 CD's with DTS and AC3 audio tracks so only this bug stoping me to build
mplayer based HTPC.
Using hwdts with moves working fine, the only problem is with wav/audiocd.

comment:2 Changed 13 years ago by dominik@…

  • Cc dominik@… added

Please retry with current CVS. If the problem persists, please upload a sample
to ftp://www.mplayerhq.hu/MPlayer/incoming/ along with a text file containing a
detailed description of the problem (for example dts_unsupported.wav and
dts_unsupported.txt).

comment:3 Changed 13 years ago by luzik@…

(In reply to comment #2)

Please retry with current CVS. If the problem persists, please upload a sample
to ftp://www.mplayerhq.hu/MPlayer/incoming/ along with a text file containing a
detailed description of the problem (for example dts_unsupported.wav and
dts_unsupported.txt).

current version doesn't work for me too.

while this upload dir doesn't exist use this location for downloading sample
http://wpad.ds.pg.gda.pl/~luzik/dts/.

comment:4 Changed 12 years ago by ulion2002@…

  • Cc ulion2002@… added

Yes, hwac3 does only support passthrough 48kHz DTS audio. Most DTS wav is 44.1kHz and 14bits format, to passthrough them, try put '-ac +pcm' to your mplayer commandline, if it still not decoded by external decoder, try add '-format s16le' or '-format s16be' to commandline, that works for me and my dts wav samples.

comment:5 Changed 12 years ago by ulion2002@…

I made a patch to make hwdts support dts wav (14bits) stream.
http://lists.mplayerhq.hu/pipermail/mplayer-dev-eng/2007-November/054881.html

I think it could be applied in 1 to 2 weeks. So the dts wav problem will be resolved.

comment:6 Changed 12 years ago by ulion2002@…

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in svn r25152, now you can passthrough dts wav with -afm hwac3 or -ac hwdts.
For DTS CD, you can also passthrough it by -rawaudio format=0x2001 additional with -afm hwac3 or -ac hwdts.

Note: See TracTickets for help on using tickets.