Opened 15 years ago

Closed 14 years ago

Last modified 14 years ago

#45 closed defect (fixed)

playing audio ASX files no more working in the version 1.0

Reported by: friseb2004@… Owned by: r_togni@…
Priority: important Component: core
Version: 1.0pre5 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Using mplayer to play ASX online radio does no more work in the version 1.0pre.
The version 0.93 is working without any problems.

I use the following command line for my tests:
mplayer 'http://cache.yacast.fr/V4/franceculture/fculture.asx'

I use a script (see below) to generate mplayer and if I select the veriosn
1.0pre (variable MPLAYER_VERSION), I have the regression.

Regards.
Sebastien

To build MPLAYER I use the following script (answer Y to all questions):
#!/bin/bash
CVS=no
MPLAYERDIR=/usr/src/MPLAYER
LIVEMEDIA_VERSION=live.2004.07.27
#MPLAYER_VERSION=MPlayer-1.0pre5
MPLAYER_VERSION=MPlayer-0.93
CODECS=all-20040706
FFMPEG_VERSION=ffmpeg-0.4.8
FONT_VERSION=font-arial-iso-8859-1
#export CC=gcc-2.95
#export CXX=g++-2.95

echo "LIVE?(Y/N)"
read -n 1 -s LIVE
if [ "$GUI_YES" = "Y" ]
then

MPLAYER_OPT=$MPLAYER_OPT" --enable-live --with-livelibdir=/usr/lib/live "

fi

echo "WIN32 Codecs?(Y/N)"
read -n 1 -s WIN32_CODECS
if [ "$WIN32_CODECS" = "Y" ]
then

MPLAYER_OPT=$MPLAYER_OPT" --with-win32libdir=/usr/local/lib/win32 "

else

MPLAYER_OPT=$MPLAYER_OPT" --disable-win32 "

fi

echo "STATIC?(Y/N)"
read -n 1 -s STATIC_YES
if [ "$STATIC_YES" = "Y" ]
then

MPLAYER_OPT=$MPLAYER_OPT" --enable-static"

fi

echo "GUI?(Y/N)"
read -n 1 -s GUI_YES
if [ "$GUI_YES" = "Y" ]
then

MPLAYER_OPT=$MPLAYER_OPT" --enable-gui"

fi

echo "Read packages?(Y/N)"
read -n 1 -s READPACKAGES

echo "Delete the $MPLAYERDIR directory?(Y/N)"
read -n 1 -s DELMPLAYERDIR
if [ "$DELMPLAYERDIR" = "Y" ]
then

rm -rf $MPLAYERDIR

fi
apt-get install libpng3-dev libcaca-dev
#
# Downloding the packages
#
if [ "$CVS" = "yes" ]
then

if [ ! -d "$MPLAYERDIR" ]
then

mkdir $MPLAYERDIR
cd $MPLAYERDIR
cvs -d:pserver:anonymous:@mplayerhq.hu:/cvsroot/mplayer login
cvs -z3 -d:pserver:anonymous:@mplayerhq.hu:/cvsroot/mplayer co -P main
cvs -z9 -d:pserver:anonymous:@mplayerhq.hu:/cvsroot/ffmpeg co ffmpeg

else

cd $MPLAYERDIR/main
cvs -z3 update -dPA
cd $MPLAYERDIR/ffmpeg
cvs -z3 update -dPA

fi

else

if [ "$READPACKAGES" = "Y" ]
then

mkdir $MPLAYERDIR
cd $MPLAYERDIR
wget --timeout=60 --tries=1 -N

http://www2.mplayerhq.hu/MPlayer/releases/$MPLAYER_VERSION.tar.bz2

wget --timeout=60 --tries=1 -N

http://www1.mplayerhq.hu/MPlayer/releases/$MPLAYER_VERSION.tar.bz2

wget -N

http://heanet.dl.sourceforge.net/sourceforge/ffmpeg/$FFMPEG_VERSION.tar.gz

if [ ! -e "$MPLAYERDIR/$MPLAYER_VERSION.tar.bz2" ]
then

echo "Package missing: $MPLAYER_VERSION"
exit

fi
echo "Uncompressing MPlayer..."
tar xfj $MPLAYER_VERSION.tar.bz2
echo "Uncompressing ffmpeg..."
tar xfz $FFMPEG_VERSION.tar.gz

ln -s $MPLAYER_VERSION main
ln -s $FFMPEG_VERSION ffmpeg

fi

fi
if [ "$READPACKAGES" = "Y" ]
then

mkdir $MPLAYERDIR
cd $MPLAYERDIR

#wget -N -r -l 1 http://ftp.lug.udel.edu/MPlayer/releases/codecs/

wget -N --timeout=60 --tries=1

http://www1.mplayerhq.hu/MPlayer/releases/codecs/$CODECS.tar.bz2

wget -N --timeout=60 --tries=1

http://www2.mplayerhq.hu/MPlayer/releases/codecs/$CODECS.tar.bz2

wget -N http://ftp.lug.udel.edu/MPlayer/releases/fonts/$FONT_VERSION.tar.bz2
wget -N --timeout=60 --tries=1

http://www.live.com/liveMedia/public/$LIVEMEDIA_VERSION.tar.gz

wget -N --timeout=60 --tries=1

http://mirrors.wamug.org.au/videolan/testing/contrib/$LIVEMEDIA_VERSION.tar.gz

wget -N -r -l 1 http://ftp3.mplayerhq.hu/MPlayer/Skin/

fi

#
# test if the packages are present
#
if [ ! -e "$MPLAYERDIR/$LIVEMEDIA_VERSION.tar.gz" ]
then

echo "Package missing: $LIVEMEDIA_VERSION"
exit

fi
if [ ! -e "$MPLAYERDIR/$CODECS.tar.bz2" ]
then

echo "Package missing: $CODECS"
exit

fi
if [ ! -e "$MPLAYERDIR/$FONT_VERSION.tar.bz2" ]
then

echo "Package missing: $FONT_VERSION"

#exit
fi

# live support
echo "Live support..."
cd $MPLAYERDIR/
tar xfz $LIVEMEDIA_VERSION.tar.gz
cd live
./genMakefiles linux

make
exit

cd $MPLAYERDIR/
rm -rf /usr/lib/live ; cp -r live /usr/lib

#installing the codecs
mkdir -p /usr/local/lib/win32

cd $MPLAYERDIR/
tar xfj $CODECS.tar.bz2
cd $MPLAYERDIR/$CODECS
echo "Copying codecs"
cp -v * /usr/local/lib/win32

# installing fonts
mkdir -p /usr/local/share/mplayer/font
cd /usr/local/share/mplayer/font
tar -xjvf $MPLAYERDIR/$FONT_VERSION.tar.bz2
mkdir -p $MPLAYERDIR/font
cp -p font-arial-14-iso-8859-1/* $MPLAYERDIR/font/

#building ffmpeg
mkdir -p $MPLAYERDIR/main/ffmpeg/
cd $MPLAYERDIR/main
#ln -s $MPLAYERDIR/ffmpeg/libavformat libavformat
cd $MPLAYERDIR/ffmpeg
cp -r . $MPLAYERDIR/main/ffmpeg/
cd $MPLAYERDIR/main/ffmpeg

./configure
exit

#cp -r $MPLAYERDIR/main/ffmpeg/libavformat $MPLAYERDIR/main/libavformat
cp -r $MPLAYERDIR/main/ffmpeg/libavcodec $MPLAYERDIR/main/libavcodec

#make #make install
exit
exit

#skins
mkdir -p /usr/local/share/mplayer/Skin
cd /usr/local/share/mplayer/Skin
if [ "$READPACKAGES" = "Y" ]
then

for I in $MPLAYERDIR/ftp3.mplayerhq.hu/MPlayer/Skin/*
do

echo "Uncompressing skin $I..."
tar -xjvf "$I"

done

fi
# On startup, it looks for a default skin. Link default to Blue
ln -s xine-lcd default

#building mplayer
cd $MPLAYERDIR/main
./configure --confdir=/etc/mplayer --enable-largefiles --enable-shared-pp

--enable-menu $MPLAYER_OPT make make install
exit
exit
exit

mkdir -p /etc/mplayer
if [ "$GUI_YES" = "Y" ]
then
cat > /etc/mplayer/mplayer.conf << "EOF"
gui = yes
skin = default
EOF
else
touch /etc/mplayer/mplayer.conf
fi

echo The end

Change History (5)

comment:1 Changed 15 years ago by r_togni@…

  • Resolution set to worksforme
  • Status changed from new to closed

Works for me with cvs, pre5 and pre4

Use "mplayer -playlist http://cache.yacast.fr/V4/franceculture/fculture.asx" to
play it

comment:2 Changed 15 years ago by friseb2004@…

I can confirm the option -playlist need to be used for the 1.0 version.
Thanks.
Sebastien

comment:3 Changed 15 years ago by friseb2004@…

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I reopen the bug because I found a regressing concerning playing asx online
radio streams:
'mplayer -playlist http://cache.yacast.fr/V4/franceculture/fculture.asx' is
working on the version 0.93 and 1.0pre (for 0.93 -playlist is removed from the
command line)
But, 'mplayer -playlist http://cache.yacast.fr/V4/franceinter/franceinter.asx'
works only on the version 0.93
mplayer seams not to be able to fill the cache.
Regards.
Sebastien

comment:4 Changed 15 years ago by r_togni@…

  • Owner changed from alex@… to r_togni@…
  • Status changed from reopened to new

playlist in playlist: :(
if you play the url with playlist, get the new url that it's shown (
mms://viptvr2.yacast.net/encoderfranceinter ), and play it again with -playlist
it works.

I'm looking at it.

comment:5 Changed 14 years ago by r_togni@…

  • Resolution set to fixed
  • Status changed from new to closed

Both links are working with -playlist in CVS

Note: See TracTickets for help on using tickets.