Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#484 closed defect (invalid)

MPlayer fails to build from Darwin Ports on Intel Mac

Reported by: technoweenie@… Owned by: alex@…
Priority: normal Component: core
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I found an identical bug filed on the OpenDarwin? Bugzilla:

http://bugzilla.opendarwin.org/show_bug.cgi?id=8230

Using the cvs version:

---> Building MPlayer with target all
Error: Target com.apple.build returned: shell command "cd
"/opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_multimedia_MPlayer/work/MPlayer-cvs-20060408"
&& LD=c++ make all" returned error 2
Command output: In file included from mplayer.c:163:
get_path.c: In function 'get_path':
get_path.c:77: warning: pointer targets in passing argument 3 of
'CFURLGetFileSystemRepresentation' differ in signedness
get_path.c:83: warning: pointer targets in passing argument 3 of
'CFURLGetFileSystemRepresentation' differ in signedness
mplayer.c: In function 'main':
mplayer.c:2713: warning: pointer targets in passing argument 2 of
'vobsub_set_from_lang' differ in signedness
mplayer.c:2777: warning: pointer targets in passing argument 2 of 'stream_read'
differ in signedness
mplayer.c:2796: warning: pointer targets in passing argument 2 of
'dvd_aid_from_lang' differ in signedness
mplayer.c:2798: warning: pointer targets in passing argument 2 of
'dvd_sid_from_lang' differ in signedness
mplayer.c:2841: warning: pointer targets in passing argument 1 of 'strrchr'
differ in signedness
mplayer.c:2841: warning: pointer targets in passing argument 1 of 'strrchr'
differ in signedness
mplayer.c:2841: warning: pointer targets in passing argument 1 of 'strrchr'
differ in signedness
mplayer.c:2841: warning: pointer targets in passing argument 1 of 'strrchr'
differ in signedness
mplayer.c:2850: warning: pointer targets in passing argument 1 of 'strrchr'
differ in signedness
mplayer.c:2850: warning: pointer targets in passing argument 1 of 'strrchr'
differ in signedness
mplayer.c:2850: warning: pointer targets in passing argument 1 of 'strrchr'
differ in signedness
mplayer.c:2850: warning: pointer targets in passing argument 1 of 'strrchr'
differ in signedness
mplayer.c:2850: warning: pointer targets in passing argument 2 of 'strcmp'
differ in signedness
mplayer.c:2852: warning: pointer targets in passing argument 1 of 'strlen'
differ in signedness
mplayer.c:2857: warning: pointer targets in passing argument 2 of 'strcat'
differ in signedness
mplayer.c:2864: warning: pointer targets in passing argument 2 of
'play_tree_add_file' differ in signedness
mplayer.c:3475: warning: pointer targets in passing argument 2 of
'decode_audio' differ in signedness
{standard input}:6244:operands given don't match any known 386 instruction
{standard input}:7156:operands given don't match any known 386 instruction
{standard input}:7688:operands given don't match any known 386 instruction
{standard input}:9512:operands given don't match any known 386 instruction
{standard input}:9573:operands given don't match any known 386 instruction
{standard input}:12629:operands given don't match any known 386 instruction
{standard input}:14314:operands given don't match any known 386 instruction
make: * [mplayer.o] Error 1

Error: /opt/local/bin/port: Status 1 encountered during processing.

Change History (3)

comment:1 Changed 13 years ago by reimar

Please use a CVS checkout and compile with the normal ./configure && make, this
doesn't even contain the command itself that failed, so I don't even know which
file it tries to compile and with which options.
But for what it's worth, for now it looks like broken binutils.

comment:2 Changed 13 years ago by technoweenie@…

Here's the debug input.

% sudo port -d install mplayer
DEBUG: Found port in
file:///opt/local/var/db/dports/sources/rsync.rsync.darwinports.org_dpupdate_dports/multimedia/MPlayer
DEBUG: Changing to port directory:
/opt/local/var/db/dports/sources/rsync.rsync.darwinports.org_dpupdate_dports/multimedia/MPlayer
DEBUG: Requested variant i386 is not provided by port MPlayer.
DEBUG: Executing variant macosx provides macosx
DEBUG: Executing variant darwin provides darwin
DEBUG: Executing variant darwin_8 provides darwin_8
DEBUG: Found port in
file:///opt/local/var/db/dports/sources/rsync.rsync.darwinports.org_dpupdate_dports/graphics/libpng
DEBUG: Changing to port directory:
/opt/local/var/db/dports/sources/rsync.rsync.darwinports.org_dpupdate_dports/graphics/libpng
DEBUG: Searching for dependency: libpng
DEBUG: Found Dependency: receipt exists for libpng
DEBUG: Found port in
file:///opt/local/var/db/dports/sources/rsync.rsync.darwinports.org_dpupdate_dports/graphics/jpeg
DEBUG: Changing to port directory:
/opt/local/var/db/dports/sources/rsync.rsync.darwinports.org_dpupdate_dports/graphics/jpeg
DEBUG: Searching for dependency: jpeg
DEBUG: Found Dependency: receipt exists for jpeg
DEBUG: Found port in
file:///opt/local/var/db/dports/sources/rsync.rsync.darwinports.org_dpupdate_dports/devel/lzo
DEBUG: Changing to port directory:
/opt/local/var/db/dports/sources/rsync.rsync.darwinports.org_dpupdate_dports/devel/lzo
DEBUG: Searching for dependency: lzo
DEBUG: Found Dependency: receipt exists for lzo
DEBUG: Found port in
file:///opt/local/var/db/dports/sources/rsync.rsync.darwinports.org_dpupdate_dports/audio/libvorbis
DEBUG: Changing to port directory:
/opt/local/var/db/dports/sources/rsync.rsync.darwinports.org_dpupdate_dports/audio/libvorbis
DEBUG: Searching for dependency: libvorbis
DEBUG: Found Dependency: receipt exists for libvorbis
DEBUG: Found port in
file:///opt/local/var/db/dports/sources/rsync.rsync.darwinports.org_dpupdate_dports/audio/libmad
DEBUG: Changing to port directory:
/opt/local/var/db/dports/sources/rsync.rsync.darwinports.org_dpupdate_dports/audio/libmad
DEBUG: Searching for dependency: libmad
DEBUG: Found Dependency: receipt exists for libmad
DEBUG: Found port in
file:///opt/local/var/db/dports/sources/rsync.rsync.darwinports.org_dpupdate_dports/audio/lame
DEBUG: Changing to port directory:
/opt/local/var/db/dports/sources/rsync.rsync.darwinports.org_dpupdate_dports/audio/lame
DEBUG: Searching for dependency: lame
DEBUG: Found Dependency: receipt exists for lame
DEBUG: Skipping completed com.apple.main (MPlayer)
DEBUG: Skipping completed com.apple.unarchive (MPlayer)
DEBUG: Skipping completed com.apple.fetch (MPlayer)
DEBUG: Skipping completed com.apple.checksum (MPlayer)
DEBUG: setting option extract.cmd to /opt/local/bin/bzip2
DEBUG: Skipping completed com.apple.extract (MPlayer)
DEBUG: Skipping completed com.apple.patch (MPlayer)
DEBUG: Skipping completed com.apple.configure (MPlayer)
---> Building MPlayer with target all
DEBUG: Executing com.apple.build (MPlayer)
DEBUG: Assembled command: 'cd
"/opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_multimedia_MPlayer/work/MPlayer-cvs-20060408"
&& LD=c++ make all'
cc -c -I../libvo -I../../libvo -fno-PIC -O4 -march=pentium3 -mtune=pentium3
-pipe -ffast-math -fomit-frame-pointer -mdynamic-no-pic -falign-loops=16
-DSYS_DARWIN -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/opt/local/include -I.

-I/opt/local/include -I./libavutil -I./libavcodec -o mplayer.o mplayer.c

In file included from mplayer.c:163:

comment:3 Changed 13 years ago by reimar

  • Resolution set to invalid
  • Status changed from new to closed

Since mplayer.c does not contain any assembler code, this line:

{standard input}:6244:operands given don't match any known 386 instruction

means that your assembler can not parse the output of your compiler.
Removing "-O4 -march=pentium3 -mtune=pentium3" from the CFLAGS might help, but
it is just a workaround around a bug in yout toolchain (incompatible versions of
gcc and binutils).
So not a MPlayer bug.

Note: See TracTickets for help on using tickets.