Opened 13 years ago

Closed 10 years ago

#486 closed defect (invalid)

file:// URLs - escaping not handled properly

Reported by: jkarp@… Owned by: alex@…
Priority: normal Component: core
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I have no trouble running:
mplayer file:///home/johnkarp/video/name\ with\ spaces.mpeg
or
mplayer "file:///home/johnkarp/video/name with spaces.mpeg"

Note the spaces; according to RFC 1738, all spaces must be percent-escaped.

Now, when I give mplayer a file:// URL with properly-escaped spaces, for
example:
mplayer "file:///home/johnkarp/video/name%20with%20spaces.mpeg"
it does not work:
Playing file:///home/johnkarp/video/name%20with%20spaces.mpeg.
File not found: '/home/johnkarp/video/name%20with%20spaces.mpeg'
Failed to open file:///home/johnkarp/video/name%20with%20spaces.mpeg

I think it represents a bug in mplayer if it cannot handle
correctly-formed file:// URLs. As far as I can tell, the only
workaround is to use badly-formed file:// URLs.

I have tried mplayer snapshots 1.0.20060217 and 1.0.20060408, and both have the
problem.

Change History (1)

comment:1 Changed 10 years ago by compn

  • Resolution set to invalid
  • Status changed from new to closed

file:// is not a url , that rfc has no business with it.

local filenames can have percents
e.g.

compn@saracen ~/mplayer $ ./mplayer file://name%20with%20spaces.mpg
MPlayer SVN-r29079-4.2.4 (C) 2000-2009 MPlayer Team

Playing file://name%20with%20spaces.mpg.
Seek failed

Exiting... (End of file)

(it says seek failed because it was a file i created with touch)

Note: See TracTickets for help on using tickets.