Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#488 closed defect (worksforme)

mp3 decoder not working when using 3DNow!Ex and 3DNow!

Reported by: narmo@… Owned by: diego@…
Priority: important Component: ad
Version: HEAD Severity: normal
Keywords: Cc: dominik@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

When I installed rpm from greysector.net (1.0pre8-0.7.20060418) sound in mkv/
dts was too fast and mp3 sound in movies and audio files was broken - it was
only noise and scratches. After I compiled CVS snapshot first problem
disapeared but second didn't. I tried with few -ao options and also pcm
generetad broken wav. In mplayer.spec file I added flags --disable-3dnow --
disable-3dnowext and compiled again. Now it works correctly.
My /proc/cpuinfo:
processor : 0
vendor_id : AuthenticAMD
cpu family : 6
model : 8
model name : AMD Athlon(TM) XP 2000+
stepping : 1
cpu MHz : 1658.880
cache size : 256 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat
pse36 mmx fxsr sse syscall mmxext 3dnowext 3dnow ts
bogomips : 3322.20

Mainboard: Asus A7V8X-X
Distro: Fedora Core 5
Kernel: 2.6.16-1.2096_FC5

Attachments (1)

mplayer_test.tar.bz2 (142.4 KB) - added by narmo@… 13 years ago.
sample files

Download all attachments as: .zip

Change History (9)

comment:1 Changed 13 years ago by narmo@…

* Bug 489 has been marked as a duplicate of this bug. *

comment:2 Changed 13 years ago by narmo@…

* Bug 490 has been marked as a duplicate of this bug. *

comment:3 Changed 13 years ago by narmo@…

* Bug 491 has been marked as a duplicate of this bug. *

comment:4 Changed 13 years ago by diego@…

  • Owner changed from alex@… to diego@…

Please provide a sample file to reproduce the problem.

comment:5 Changed 13 years ago by diego@…

  • Status changed from new to assigned

Note: I have no problems playing MP3 audio on my K6-III+ with both 3DNow! and
3DNow!Ex.

Changed 13 years ago by narmo@…

sample files

comment:6 Changed 13 years ago by narmo@…

These files i made with this command:
mplayer -v -ao pcm:file=output.good.wav msg.mp3 > debug.good
I'm not sure if this is what you asked for.

comment:7 Changed 13 years ago by dominik@…

  • Cc dominik@… added

No, we need the mp3 file that's causing problems.

comment:8 Changed 13 years ago by diego@…

  • Resolution set to worksforme
  • Status changed from assigned to closed

Resolving as WORKSFORME. Reopen the bug if you can give us a file to reproduce
the problem with.

Note: See TracTickets for help on using tickets.