Opened 13 years ago

Closed 10 years ago

#492 closed defect (worksforme)

Fribidi breaks subtitles

Reported by: lordzanon@… Owned by: alex@…
Priority: normal Component: core
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

This problem was mentioned in some places in various configurations. The mine is
as follows: I have subtitles encoded in cp1250 and if I compile mplayer with
fribidi disabled, everything works like charm provided i have subfont-encoding
set. However, with fribidi enabled, only some of Polish-specific characters are
rendered properly, others are replaced by ż (z with dot).
I am running Fedora Core 5 under pl_PL.UTF-8 locale.

Change History (2)

comment:1 Changed 10 years ago by compn

did you try -subcp cp1250 ?

comment:2 Changed 10 years ago by lordzanon@…

  • Resolution set to worksforme
  • Status changed from new to closed

I'm not sure what I did since the original submission, but at the end of the day I got the subs working correctly. I have subcp=cp1250 set.

Note: See TracTickets for help on using tickets.