Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#498 closed defect (worksforme)

DVB build failure

Reported by: boagenator@… Owned by: nsabbi@…
Priority: normal Component: demuxer
Version: HEAD Severity: normal
Keywords: Cc: dominik@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

libmpdemux/dvb_defaults.h:73:3: warning: #warning No DVB-T country defined in
dvb_defaults.h, defaulting to UK. Ignore this if using Satellite or Cable.
In file included from mplayer.c:118:
libmpdemux/dvbin.h:70: error: field 'get_current' declared as a function
In file included from mplayer.c:184:
libmpdemux/demuxer.h:104: error: field 'get_current' declared as a function
mplayer.c: In function 'mp_property_tv_color':
mplayer.c:2076: warning: cast from pointer to integer of different size
mplayer.c:2078: warning: cast from pointer to integer of different size
mplayer.c:2081: warning: cast from pointer to integer of different size
mplayer.c:2086: warning: cast from pointer to integer of different size
mplayer.c: In function 'main':
mplayer.c:2739: warning: cast to pointer from integer of different size
mplayer.c:2775: warning: cast to pointer from integer of different size
mplayer.c:3464: warning: cast to pointer from integer of different size
mplayer.c:4790: warning: cast to pointer from integer of different size
make: * [mplayer.o] Error 1

I was told (when looking for assistance):

< kumquat> people who cast pointers to integers and back do not know how to write C

AMD64 system, trying to build from CVS. Previous snapshots/versions have worked
fine.

Change History (5)

comment:1 Changed 13 years ago by diego@…

  • Component changed from build system to demuxer
  • Owner changed from diego@… to nsabbi@…
  • Summary changed from Mplayer fails to build to MPlayer fails to build

comment:2 Changed 13 years ago by diego@…

  • Summary changed from MPlayer fails to build to DVB build failure

comment:3 Changed 13 years ago by dominik@…

Works for me (i.e. builds) on AMD64 running FC5 64bit. Please include more
details, i.e. full configure output and everything else as outlined in
http://www.mplayerhq.hu/DOCS/HTML/en/bugreports.html. NB: the pointer cast
warnings are irrelevant here, only "error:" lines matter.

comment:4 Changed 13 years ago by dominik@…

  • Cc dominik@… added

comment:5 Changed 12 years ago by reimar

  • Resolution set to worksforme
  • Status changed from new to closed

Works for me, too. Similar gentoo bug reports indicate some problems with
system headers.

Note: See TracTickets for help on using tickets.