Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#499 closed defect (invalid)

mp3 playback frozen when CPU frequency is changing

Reported by: rafalbilski@… Owned by: reimar
Priority: normal Component: core
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Video & Audio (DivX, DVD - vo xv ao alsa) errors (I don't care):

alsa-play: pcm in suspend mode. trying to resume
alsa-lib: pcm_hw.c:683:(snd_pcm_hw_resume) SNDRV_PCM_IOCTL_RESUME failed:
Function not implemented
alsa-play: write error: Function not implemented
alsa-play: trying to reset soundcard

Audio (mp3 - ao alsa) playback is frozen. No reaction on keys. Exit after Ctrl+C.

MPlayer dev-CVS-060518-19:14-3.4.6 (C) 2000-2006 MPlayer Team
CPU: VIA Nehemiah (Family: 6, Model: 9, Stepping: 8)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
Skompilowany dla procesora z rozszerzeniami: MMX MMX2 SSE

Change History (5)

comment:1 Changed 13 years ago by rafalbilski@…

aplay - same good behaviour as for mplayer with video & audio - "Reseting
soundcard".

And after Ctrl+C mplayer displays: interrupted in module audio_play.

comment:2 Changed 13 years ago by rafalbilski@…

  • Component changed from ao to core
  • Owner changed from alex@… to Reimar.Doeffinger@…

One line from mplayer.c need to be deleted to solve this problem:

--- mplayer.orig.c 2006-05-20 19:25:44.000000000 +0200
+++ mplayer.c 2006-05-20 19:26:45.000000000 +0200
@@ -3629,7 +3629,6 @@

if(playsize < ao_data.outburst &&

!sh_video) { buffer is full, do not block here!!!

usec_sleep(10000); Wait a tick before retry

  • continue;

}

if(playsize>MAX_OUTBURST) playsize=MAX_OUTBURST; we shouldn't exceed it!

comment:3 Changed 13 years ago by reimar

This is not correct, it will create problems with files that contain both audio
and video.
I actually don't think the problem is in MPlayer at all - the errors in the
Video & Audio case actually look to me like your audio driver are going into
suspend mode.
Things I would suggest to try:
1) updating ALSA drivers
2) Trying ALSA's OSS emulation via -ao oss.

comment:4 Changed 13 years ago by rafalbilski@…

it will create problems with files that contain both audio and video

None observed.

the errors in the Video & Audio case actually look to me like your audio

driver are going into suspend mode

Yes it is. It looks like this:
preempt_disable();
for_each_pci_device -> suspend();
things need to be done
for_each_pci_device -> resume();
preempt_enable();

1) updating ALSA drivers

I will try. I'm using alsa build into kernel 2.6.16.

comment:5 Changed 13 years ago by rafalbilski@…

  • Resolution set to invalid
  • Status changed from new to closed

It looks like MPlayer can't handle error from Alsa. But under normal conditions
such error will not occur. Sorry to bother You.

Note: See TracTickets for help on using tickets.