Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#500 closed defect (invalid)

mplayer compiled for 32 bit doesn't work on 64 bit

Reported by: palceksmuk@… Owned by: beastd
Priority: normal Component: vo
Version: unspecified Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I've got gentoo and I'm trying to figure out why all the 32 bit versions after
mplayer-1.0-pre7 crash on my system. If I compile mplayer (emerge) it works, but
because it's 64bit I can't use the win32codecs. So i've tried mplayer-bin (the
32bit binary package) and it crashes. Then I've tried compiling my own mplayer
in the 32bit chroot with --debug-enable and it still doesn't work. I've tried
using this gdb, but I don't know how to get something useful out of it. It seems
that the problem is with nomachine nx?

gdb ./mplayer
GNU gdb 6.4
Copyright 2005 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB. Type "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu"...Using host libthread_db
library "/lib/libthread_db.so.1".

(gdb) run /anime/ostalo/trenirane_ribe.wmv -v
Starting program: /var/chroot/opt/mplayer/mplayer-1.0.20060415/mplayer
/anime/ostalo/trenirane_ribe.wmv -v
/var/chroot/opt/mplayer/mplayer-1.0.20060415/mplayer:
/emul/linux/x86/usr/lib/libtheora.so.0: no version information available
(required by /var/chroot/opt/mplayer/mplayer-1.0.20060415/mplayer)
[Thread debugging using libthread_db enabled]
[New Thread 16384 (LWP 9849)]
Error while reading shared library symbols:
Cannot find new threads: generic error
MPlayer dev-CVS-060415-00:32-3.4.4 (C) 2000-2006 MPlayer Team
CPU: Advanced Micro Devices (Family: 15, Stepping: 0)
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE SSE2

get_path('codecs.conf') -> '/root/.mplayer/codecs.conf'
Reading /root/.mplayer/codecs.conf: Can't open '/root/.mplayer/codecs.conf': No
such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: Can't open
'/usr/local/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf.
CommandLine?: '/anime/ostalo/trenirane_ribe.wmv' '-v'
init_freetype
get_path('font/font.desc') -> '/root/.mplayer/font/font.desc'
font: can't open file: /root/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay?
Using Linux hardware RTC timing (1024Hz).
get_path('input.conf') -> '/root/.mplayer/input.conf'
Can't open input config file /root/.mplayer/input.conf: No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or
directory
Falling back on default (hardcoded) input config
get_path('trenirane_ribe.wmv.conf') -> '/root/.mplayer/trenirane_ribe.wmv.conf'
Playing /anime/ostalo/trenirane_ribe.wmv.
get_path('sub/') -> '/root/.mplayer/sub/'
[file] File size is 4078548 bytes
STREAM: [file] /anime/ostalo/trenirane_ribe.wmv
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
Checking for YUV4MPEG2
ASF file format detected.
stream type: guid_audio_stream
stream concealment: guid_audio_conceal_interleave
type: 28 bytes, stream: 8 bytes ID: 1
unk1: 0 unk2: 31CFCD8
FILEPOS=0xA6D
==> Found audio stream: 1
======= WAVE Format =======
Format Tag: 353 (0x161)
Channels: 2
Samplerate: 44100
avg byte/sec: 8005
Block align: 1487
bits/sample: 16
cbSize: 10
Unknown extra header dump: [0] [88] [0] [0] [f] [0] [79] [2e] [0] [0]
==========================================================================
ASF: audio scrambling: 1 x 1 x 1487
stream type: guid_video_stream
stream concealment: unknown guid 0057fb20-555b-cf11-a8fd00805f5c442b
type: 55 bytes, stream: 0 bytes ID: 2
unk1: 0 unk2: 0
FILEPOS=0xADF
==> Found video stream: 2
======= VIDEO Format ======

biSize 44
biWidth 320
biHeight 240
biPlanes 1
biBitCount 24
biCompression 861293911='WMV3'
biSizeImage 0

Unknown extra header dump: [4c] [89] [1a] [1]
===========================
ASF: packets: 566 flags: 2 max_packet_size: 7200 min_packet_size: 7200
max_bitrate: 584818 preroll: 4000

Title:
Author:
Copyright:
Comment:

============ ASF Stream group == START ===

stream count=[0x2][2]

stream id=[0x1][1]
max bitrate=[0x100c5][65733]
stream id=[0x2][2]
max bitrate=[0x7ebad][519085]

============ ASF Stream group == END ===
Found movie at 0xB6E - 0x3E3A2E
ASF: 1 audio and 1 video streams found
Auto-selected ASF video ID = 2
ASF: Searching for audio stream (id:-1).
Auto-selected ASF audio ID = 1
VIDEO: [WMV3] 320x240 24bpp 1000.000 fps 0.0 kbps ( 0.0 kbyte/s)
[V] filefmt:6 fourcc:0x33564D57 size:320x240 fps:1000.00 ftime:=0.0010
Clip info:

name:
author:
copyright:
comments:

get_path('sub/') -> '/root/.mplayer/sub/'
get_path('default.sub') -> '/root/.mplayer/default.sub'
File not found: '/root/.mplayer/default.sub'
Failed to open /root/.mplayer/default.sub
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
dec_audio: Allocating 192000 + 65536 = 257536 bytes for output buffer.
FFmpeg's libavcodec audio codec
INFO: libavcodec init OK!
AUDIO: 44100 Hz, 2 ch, s16le, 64.0 kbit/4.54% (ratio: 8005->176400)
Selected audio codec: [ffwmav2] afm: ffmpeg (DivX audio v2 (FFmpeg))
==========================================================================
X11 opening display: :0

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 16384 (LWP 9849)]
0xf74241f9 in NXTransPrepare () from /usr/NX/lib/libXcomp.so.1
(gdb) bt
#0 0xf74241f9 in NXTransPrepare () from /usr/NX/lib/libXcomp.so.1
#1 0xf78c0c4a in _XSelect () from /usr/NX/lib/libX11.so.6
#2 0xf78c0eb2 in _XSelect () from /usr/NX/lib/libX11.so.6
#3 0xf78c1314 in _XRead () from /usr/NX/lib/libX11.so.6
#4 0xf78c2691 in _XReply () from /usr/NX/lib/libX11.so.6
#5 0xf78aa198 in XInternAtom () from /usr/NX/lib/libX11.so.6
#6 0x080a7b94 in vo_init () at x11_common.c:355
#7 0x080ad7b9 in preinit (arg=0x8be58955 <Address 0x8be58955 out of bounds>)

at vo_xv.c:839

#8 0x080a3612 in init_best_video_out (vo_list=0x0) at video_out.c:307
#9 0x080781ca in main (argc=3, argv=0xffffc074) at mplayer.c:3210

the gentoo bugreport is here:
http://bugs.gentoo.org/show_bug.cgi?id=130724

Change History (2)

comment:1 Changed 13 years ago by palceksmuk@…

It seems that there is a problem with freenx, if I remove it mplayer-32bit works.

comment:2 Changed 13 years ago by dominik@…

  • Resolution set to invalid
  • Status changed from new to closed

It's probably a bug in FreeNX. Contact its developers, please.

Note: See TracTickets for help on using tickets.