Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#505 closed defect (invalid)

Create a way to control the mozilla plugin's playback via javascript

Reported by: dmartinez@… Owned by: reimar
Priority: normal Component: core
Version: unspecified Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I love the fact that the plugin exists, but it is missing most of the embedding
functionality you would expect in a complete solution.

A more complete API should provide the following:

  • Ability to determine the current plugin's status, with stati such as:

CONNECTING - Connecting to the target site

LOADING - Loading the stream from the URL

PLAYING - Video is currently playing

STOPPED - Video is stopped

  • Ability to determine the current video position from Javascript
  • Ability to determine the length of the video from javascript
  • Ability to determine the current mplayer volume.
  • Ability to set the mplayer volume from javascript

I don't mind whether this is done with javascript events or I have to poll to
get the information, as long as the calls are there and accessible from the
mplayer's JS interface.

These would bring it up to par with embeddable players in other platforms, and I
would be able to provide full Linux functionality on my JS enabled players.

Change History (1)

comment:1 Changed 13 years ago by reimar

  • Resolution set to invalid
  • Status changed from new to closed

This seems to be a bugreport about mplayerplug-in or so, which except using
MPlayer is in no way related to the MPlayer Project. IOW, this is the wrong
place.

Note: See TracTickets for help on using tickets.