Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#509 closed defect (invalid)

Off by one on read

Reported by: i_s_c_y@… Owned by: mans@…
Priority: normal Component: libavcodec
Version: unspecified Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

In libavcodec/h264.c line 7911, the loop condition is 'i<=buf_size' when it
should be 'i<buf_size'.

In the case where i == buf_size, an invalid read will be done on the last line
of the loop.

Change History (1)

comment:1 Changed 13 years ago by i_s_c_y@…

  • Resolution set to invalid
  • Status changed from new to closed

Never mind about this. The problem is something else.

Note: See TracTickets for help on using tickets.