Opened 14 years ago

Closed 13 years ago

Last modified 13 years ago

#51 closed defect (fixed)

hwac3 big endian AC3 not supported , alsa / aureon 5.1 sky (SPDIF)

Reported by: ilkka@… Owned by: alex@…
Priority: normal Component: ao
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Hi

I came up with a problem with hardware ac3 passthrue (hwac3) with alsa 1.0.5.
In my previous mplayer version this was working (i think it was 0.93 version)

problem:
[format] Sample format big endian AC3 not yet supported
Couldn't find matching filter / ao format!
-- and no sound

some maybe usefull logs ran with "mplayer dvd://4
-ao alsa:mmap:noblock:device=mplayer -ac hwac3 -v"
*

MPlayer dev-CVS-040803-23:30-3.3.3 (C) 2000-2004 MPlayer Team
CPU: Advanced Micro Devices Athlon MP/XP Thoroughbred 2000 MHz (Family: 6,
Stepping: 1)

==========================================================================
Forced audio codec: hwac3
Opening audio decoder: [hwac3] AC3/DTS pass-through SP/DIF
dec_audio: Allocating 8192 bytes for input buffer.
dec_audio: Allocating 16384 + 65536 = 81920 bytes for output buffer.
No accelerated IMDCT transform found
hwac3: switched to AC3, 448000 bps, 48000 Hz
AUDIO: 48000 Hz, 2 ch, 16 bit (0x400), ratio: 56000->192000 (448.0 kbit)
Selected audio codec: [hwac3] afm:hwac3 (AC3 through SPDIF)
==========================================================================
==========================================================================
Checking audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/8bit...
[libaf] Adding filter dummy
[dummy] Was reinitialized, rate=48000Hz, nch = 2, format = 0x00000020 and bps = 2
AF_pre: af format: 2 bps, 2 ch, 48000 hz, big endian AC3
AF_pre: 48000Hz 2ch AC3
alsa-init: requested format: 48000 Hz, 2 channels, AC3
alsa-init: compiled for ALSA-1.0.5
alsa-spdif-init: playing AC3, 2 channels
alsa-init: soundcard set to iec958:AES0=0x2,AES1=0x82,AES2=0x0,AES3=0x2
alsa-init: pcm opend in nonblock-mode
alsa-init: mmap set
alsa-init: chunksize set to 512
alsa-init: fragcount=16
alsa-init: got buffersize=32768
alsa-init: bits per sample (bps)=16, bits per frame (bpf)=32, chunk_bytes=2048
alsa: 48000 Hz/2 channels/4 bpf/32768 bytes buffer/Signed 16 bit Little Endian
AO: [alsa] 48000Hz 2ch AC3 (1 bps)
AO: Description: ALSA-0.9.x-1.x audio output
AO: Author: Alex Beregszaszi, Zsolt Barat <joy@…>
AO: Comment: under developement
Building audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/8bit...
[dummy] Was reinitialized, rate=48000Hz, nch = 2, format = 0x00000020 and bps = 2
[libaf] Adding filter format
[format] Sample format big endian AC3 not yet supported
Couldn't find matching filter / ao format!
Starting playback...
alsa-space: free space = 32768, prepared --

*
alsa=1.0.5
kernel=Linux alyssa 2.6.5-gentoo #6 SMP Sat Jun 12 16:23:35 EEST 2004 i686 AMD
Athlon(tm) MP 2400+ AuthenticAMD GNU/Linux
soundcard =Terratec Aureon Sky 5.1

/etc/asound.conf
pcm.mplayer {

type plug
slave {

pcm "hw:1,1"
format S32_LE

}

}

Change History (5)

comment:1 Changed 14 years ago by ilkka@…

  • Summary changed from hwac3 bin endian AC3 not supported , alsa (SPDIF) to hwac3 bin endian AC3 not supported , alsa (SPDIF)

note:
using -ac a52
Sound works

comment:2 Changed 14 years ago by ilkka@…

  • Summary changed from hwac3 bin endian AC3 not supported , alsa (SPDIF) to hwac3 big endian AC3 not supported , alsa / aureon 5.1 sky (SPDIF)

Aparently this bug includes way too few information. Letme refrase this whole thing.

system hw:
-Dual AMD Athlon MP 2400+
-Aureon 5.1 sky (snd_ice1724)
-sound output only using spdif to amplifier (no analog output)
-Gentoo

system sw:

  • uname -a: "2.6.8-gentoo-r1 #5 SMP Fri Aug 20 19:56:04 EEST 2004 i686 AMD

Athlon(tm) MP 2400+ AuthenticAMD GNU/Linux"

  • alsa-lib 1.0.5
  • MPlayer dev-CVS-040822-15:01-3.3.3

using dolby-canyon.vob as source file
(http://www.stud.ntnu.no/~tlan/surround/dolby-canyon.vob)

previous (working) sw:

  • 2.6.3 kernel
  • alsa lib same that came with the kernel
  • mplayer 0.93

(With this config and same hardware i had this working already:

www.razorwings.net/digital/2.html)

/etc/asound.conf
pcm.mplayer {

type plug
slave {

pcm "hw:1,1"
format S32_LE

}

}


using a52 output (works, i get sound)

MPlayer dev-CVS-040822-15:01-3.3.3 (C) 2000-2004 MPlayer Team

CPU: Advanced Micro Devices Athlon MP/XP Thoroughbred 2001 MHz (Family: 6,
Stepping: 1)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE

Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or directory
Reading config file /root/.mplayer/config
Reading /root/.mplayer/codecs.conf: Can't open '/root/.mplayer/codecs.conf': No
such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: Can't open
'/usr/local/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf.
CommandLine?: '-v' '-ao' 'alsa:device=mplayer' '-ac' 'a52'
'/home/ipo/dolby-canyon.vob'
init_freetype
get_path('font/font.desc') -> '/root/.mplayer/font/font.desc'
font: can't open file: /root/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay?
Failed to open /dev/rtc: No such file or directory (it should be readable by the
user.)
Using nanosleep() timing
get_path('input.conf') -> '/root/.mplayer/input.conf'
Can't open input config file /root/.mplayer/input.conf: No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or
directory
Falling back on default (hardcoded) input config
get_path('dolby-canyon.vob.conf') -> '/root/.mplayer/dolby-canyon.vob.conf'

Playing /home/ipo/dolby-canyon.vob.
[file] File size is 31272960 bytes
STREAM: [file] /home/ipo/dolby-canyon.vob
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
Checking for YUV4MPEG2
DEMUXER: freeing demuxer at 0x85a8168
ASF_check: not ASF guid!
DEMUXER: freeing demuxer at 0x85a8168
Checking for Nullsoft Streaming Video
DEMUXER: freeing demuxer at 0x85a8168
Checking for NuppelVideo?
DEMUXER: freeing demuxer at 0x85a8168
Checking for REAL
DEMUXER: freeing demuxer at 0x85a8168
Checking for SMJPEG
DEMUXER: freeing demuxer at 0x85a8168
DEMUXER: freeing demuxer at 0x85a89d0
DEMUXER: freeing demuxer at 0x85a89d0
Searching demuxer type for filename /home/ipo/dolby-canyon.vob ext: .vob
Trying demuxer 2 based on filename extension
system stream synced at 0xD (0)!
==> Found video stream: 0
MPEG-PS file format detected.
==> Found audio stream: 128
Searching for sequence header... OK!
VIDEO: MPEG2 720x480 (aspect 2) 29.970 fps 6000.0 kbps (750.0 kbyte/s)
[V] filefmt:2 fourcc:0x10000002 size:720x480 fps:29.97 ftime:=0.0334
get_path('sub/') -> '/root/.mplayer/sub/'
get_path('default.sub') -> '/root/.mplayer/default.sub'
==========================================================================
Forced audio codec: a52
Opening audio decoder: [liba52] AC3 decoding with liba52
dec_audio: Allocating 3840 bytes for input buffer.
dec_audio: Allocating 6144 + 65536 = 71680 bytes for output buffer.
Using SSE optimized IMDCT transform
AC3: 5.1 (3f+2r+lfe) 48000 Hz 448.0 kbit/s
A52 flags before a52_frame: 0x2A
A52 flags after a52_frame: 0xA
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, 16 bit (0x10), ratio: 56000->192000 (448.0 kbit)
Selected audio codec: [a52] afm:liba52 (AC3-liba52)
==========================================================================
X11 opening display: :0.0
vo: X11 color mask: FFFFFF (R:FF0000 G:FF00 B:FF)
vo: X11 running at 1600x1200 with depth 24 and 32 bpp (":0.0" => local display)
[x11] Detected wm supports layers.
[x11] Detected wm supports NetWM.
[x11] Detected wm supports FULLSCREEN state.
[x11] Current fstype setting honours LAYER FULLSCREEN X atoms
Disabling DPMS
DPMSDisable stat: 1
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 720 x 480 (preferred csp: Mpeg PES)
Trying filter chain: vo
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
SwScale? params: -1 x -1 (-1=no scaling)
Trying filter chain: scale vo
The selected video_out device is incompatible with this codec.
VDecoder init failed :(
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
Selected video codec: [mpeg12] vfm:libmpeg2 (MPEG 1 or 2 (libmpeg2))
==========================================================================
Checking audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
[libaf] Adding filter dummy
[dummy] Was reinitialized, rate=48000Hz, nch = 2, format = 0x00000001 and bps = 2
AF_pre: af format: 2 bps, 2 ch, 48000 hz, little endian signed int
AF_pre: 48000Hz 2ch Signed 16-bit (Little-Endian)
alsa-init: requested format: 48000 Hz, 2 channels, Signed 16-bit (Little-Endian)
alsa-init: compiled for ALSA-1.0.5
alsa-init: soundcard set to mplayer
alsa-init: pcm opend in block-mode
alsa-init: chunksize set to 1024
alsa-init: fragcount=8
alsa-init: got buffersize=32768
alsa: 48000 Hz/2 channels/4 bpf/32768 bytes buffer/Signed 16 bit Little Endian
AO: [alsa] 48000Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
AO: Description: ALSA-0.9.x-1.x audio output
AO: Author: Alex Beregszaszi, Zsolt Barat <joy@…>
AO: Comment: under developement
Building audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
[dummy] Was reinitialized, rate=48000Hz, nch = 2, format = 0x00000001 and bps = 2
[dummy] Was reinitialized, rate=48000Hz, nch = 2, format = 0x00000001 and bps = 2
Starting playback...
alsa-space: free space = 32768, prepared --
VDec: vo config request - 720 x 480 (preferred csp: Planar YV12)
Trying filter chain: vo
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO Config (720x480->720x540,flags=0,'MPlayer',0x32315659)
VO: [xv] 720x480 => 720x540 Planar YV12
VO: Description: X11/Xv
VO: Author: Gerd Knorr <kraxel@…> and others


Using -ac hwac3, no go:

MPlayer dev-CVS-040822-15:01-3.3.3 (C) 2000-2004 MPlayer Team

CPU: Advanced Micro Devices Athlon MP/XP Thoroughbred 2001 MHz (Family: 6,
Stepping: 1)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE

Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or directory
Reading config file /root/.mplayer/config
Reading /root/.mplayer/codecs.conf: Can't open '/root/.mplayer/codecs.conf': No
such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: Can't open
'/usr/local/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf.
CommandLine?: '-v' '-ao' 'alsa:device=mplayer' '-ac' 'hwac3'
'/home/ipo/dolby-canyon.vob'
init_freetype
get_path('font/font.desc') -> '/root/.mplayer/font/font.desc'
font: can't open file: /root/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay?
Failed to open /dev/rtc: No such file or directory (it should be readable by the
user.)
Using nanosleep() timing
get_path('input.conf') -> '/root/.mplayer/input.conf'
Can't open input config file /root/.mplayer/input.conf: No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or
directory
Falling back on default (hardcoded) input config
get_path('dolby-canyon.vob.conf') -> '/root/.mplayer/dolby-canyon.vob.conf'

Playing /home/ipo/dolby-canyon.vob.
[file] File size is 31272960 bytes
STREAM: [file] /home/ipo/dolby-canyon.vob
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
Checking for YUV4MPEG2
DEMUXER: freeing demuxer at 0x85a8168
ASF_check: not ASF guid!
DEMUXER: freeing demuxer at 0x85a8168
Checking for Nullsoft Streaming Video
DEMUXER: freeing demuxer at 0x85a8168
Checking for NuppelVideo?
DEMUXER: freeing demuxer at 0x85a8168
Checking for REAL
DEMUXER: freeing demuxer at 0x85a8168
Checking for SMJPEG
DEMUXER: freeing demuxer at 0x85a8168
DEMUXER: freeing demuxer at 0x85a89d0
DEMUXER: freeing demuxer at 0x85a89d0
Searching demuxer type for filename /home/ipo/dolby-canyon.vob ext: .vob
Trying demuxer 2 based on filename extension
system stream synced at 0xD (0)!
==> Found video stream: 0
MPEG-PS file format detected.
==> Found audio stream: 128
Searching for sequence header... OK!
VIDEO: MPEG2 720x480 (aspect 2) 29.970 fps 6000.0 kbps (750.0 kbyte/s)
[V] filefmt:2 fourcc:0x10000002 size:720x480 fps:29.97 ftime:=0.0334
get_path('sub/') -> '/root/.mplayer/sub/'
get_path('default.sub') -> '/root/.mplayer/default.sub'
==========================================================================
Forced audio codec: hwac3
Opening audio decoder: [hwac3] AC3/DTS pass-through SP/DIF
dec_audio: Allocating 8192 bytes for input buffer.
dec_audio: Allocating 16384 + 65536 = 81920 bytes for output buffer.
No accelerated IMDCT transform found
hwac3: switched to AC3, 448000 bps, 48000 Hz
AUDIO: 48000 Hz, 2 ch, 16 bit (0x400), ratio: 56000->192000 (448.0 kbit)
Selected audio codec: [hwac3] afm:hwac3 (AC3 through SPDIF)
==========================================================================
X11 opening display: :0.0
vo: X11 color mask: FFFFFF (R:FF0000 G:FF00 B:FF)
vo: X11 running at 1600x1200 with depth 24 and 32 bpp (":0.0" => local display)
[x11] Detected wm supports layers.
[x11] Detected wm supports NetWM.
[x11] Detected wm supports FULLSCREEN state.
[x11] Current fstype setting honours LAYER FULLSCREEN X atoms
Disabling DPMS
DPMSDisable stat: 1
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 720 x 480 (preferred csp: Mpeg PES)
Trying filter chain: vo
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
SwScale? params: -1 x -1 (-1=no scaling)
Trying filter chain: scale vo
The selected video_out device is incompatible with this codec.
VDecoder init failed :(
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
Selected video codec: [mpeg12] vfm:libmpeg2 (MPEG 1 or 2 (libmpeg2))
==========================================================================
Checking audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/8bit...
[libaf] Adding filter dummy
[dummy] Was reinitialized, rate=48000Hz, nch = 2, format = 0x00000020 and bps = 2
AF_pre: af format: 2 bps, 2 ch, 48000 hz, big endian AC3
AF_pre: 48000Hz 2ch AC3
alsa-init: requested format: 48000 Hz, 2 channels, AC3
alsa-init: compiled for ALSA-1.0.5
alsa-spdif-init: playing AC3, 2 channels
alsa-init: soundcard set to iec958:AES0=0x2,AES1=0x82,AES2=0x0,AES3=0x2
alsa-init: pcm opend in block-mode
alsa-init: chunksize set to 1024
alsa-init: fragcount=16
alsa-init: got buffersize=65536
alsa: 48000 Hz/2 channels/4 bpf/65536 bytes buffer/Signed 16 bit Little Endian
AO: [alsa] 48000Hz 2ch AC3 (1 bps)
AO: Description: ALSA-0.9.x-1.x audio output
AO: Author: Alex Beregszaszi, Zsolt Barat <joy@…>
AO: Comment: under developement
Building audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/8bit...
[dummy] Was reinitialized, rate=48000Hz, nch = 2, format = 0x00000020 and bps = 2
[libaf] Adding filter format
[format] Sample format big endian AC3 not yet supported
Couldn't find matching filter / ao format!
Starting playback...
alsa-space: free space = 65536, prepared --
VDec: vo config request - 720 x 480 (preferred csp: Planar YV12)
Trying filter chain: vo
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO Config (720x480->720x540,flags=0,'MPlayer',0x32315659)
VO: [xv] 720x480 => 720x540 Planar YV12
VO: Description: X11/Xv
VO: Author: Gerd Knorr <kraxel@…> and others

comment:3 Changed 14 years ago by reimar

What did you want it to do if I may ask?? -ac hwac3 will cause MPlayer to try to
use S/PDIF output, which seems to fail with your card/config.
With current CVS setting a device for hwac3 will work, but unless you have a
hardware ac3 decoder plugged into your soundcard that won't be what you want.
Anyway, why do you use the "plug" type instead of letting MPlayer do conversions?

comment:4 Changed 13 years ago by dominik@…

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in current CVS, then? Closing.

comment:5 Changed 13 years ago by reimar

Hard to tell if it is fixed, as I don't know what exactly the user wanted...
But it probably is fixed in CVS...

Note: See TracTickets for help on using tickets.