Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#510 closed defect (fixed)

Crash on h264 content

Reported by: i_s_c_y@… Owned by: mans@…
Priority: normal Component: libavcodec
Version: unspecified Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

When playing some piece of content on windows using ffmpeg compiled with mingw,
I was sometimes getting a crash while opening the media. The error reported by
windows was: [...] the memory could not be 'read' at [...]. By using libduma,
I've been able to see that it was due to a misaligned buffer.

If 'h264_split' from libavcodec/h264.c returns an odd number, a read error will
be later encountered when the control will reach
'decode_picture_parameter_set()' called by 'try_decode_frame()' when opening the
media.

Attachments (1)

patch (648 bytes) - added by i_s_c_y@… 13 years ago.
Patch

Download all attachments as: .zip

Change History (7)

Changed 13 years ago by i_s_c_y@…

Patch

comment:1 Changed 13 years ago by i_s_c_y@…

Using this patch, the problem went away and libduma did not report any more
error when opening the media.

comment:2 Changed 13 years ago by mans@…

Can you provide us with a sample file that triggers this problem?

comment:3 Changed 13 years ago by i_s_c_y@…

Yes. Do you have any repository where I could upload it?

comment:4 Changed 13 years ago by mans@…

Use anonymous FTP to ftp.mplayerhq.hu, dir /MPlayer/incoming

comment:5 Changed 13 years ago by i_s_c_y@…

The file is available. The name is singulair.mpg

comment:6 Changed 13 years ago by mans@…

  • Resolution set to fixed
  • Status changed from new to closed

Fixed differently. It is now clean in valgrind.

Note: See TracTickets for help on using tickets.