Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#511 closed defect (fixed)

Audio stream numbering in GUI-menu off by one

Reported by: da_fox@… Owned by: reimar
Priority: normal Component: GUI
Version: 1.0pre8 Severity: minor
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

First off, I have had this problem for a long time now (as long as I use
mplayer, almost 2 years now), and also the mail report below is from September
2004, so this is a rather long standing bug...
I have (or at least tried to) searched the support mailing list for bugs, and
found at least one report of the exact same problem (link:
http://lists.mplayerhq.hu/pipermail/mplayer-users/2004-September/048009.html).
The bug is a bug in selecting an audio track from the gmplayer right-click menu,
but since the description from the mailing list is pretty good I'll copy&paste
it here:
quote:

The problem is that the first stream in the menu ("Track 1") doesn't
select the first stream in the file (stream 0), it selects the second stream
(stream 1). Thus there is no way to select stream 0 from the menu, and
selecting the last stream in the menu ("Track 2" in this case) makes it play
no audio at all.

As said on the list, it seems like an off-by-one error and should be easy to fix.

Change History (1)

comment:1 Changed 13 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

Should be fixed in SVN since a few weeks or so.

Note: See TracTickets for help on using tickets.