Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#518 closed defect (fixed)

OSX - MacIntel - SVN - MPlayer can't find headers

Reported by: purportex@… Owned by: reimar
Priority: normal Component: core
Version: unspecified Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

$ svn checkout svn://svn.mplayerhq.hu/mplayer/trunk/

...

$ cd trunk ; ./configure --prefix=/usr --mandir=/usr/share/man
--language=list=en,cs,ru

...

Config files successfully generated by ./configure !

Install prefix: /usr
Data directory: /usr/share/mplayer
Config direct.: /usr/etc/mplayer

Byte order: little-endian
Optimizing for: pentium-m mmx mmxext sse sse2 mtrr

Languages:

Messages/GUI: en
Manual pages: en

Enabled optional drivers:

Input: ftp network tv mpdvdkit2 vcd
Codecs: qtx libavcodec real dshow/dmo win32 faad2 libmpeg2 liba52 mp3lib

tremor(internal)

Audio output: mpegpes(file) macosx
Video output: md5sum pnm mpegpes(file) opengl xv x11 xover tga macosx quartz
Audio filters:

Disabled optional drivers:

Input: vstream tv-v4l2 tv-v4l tv-bsdbt848 live555 cdda dvdnav dvdread dvb smb
Codecs: opendivx x264 xvid libdv amr_wb amr_nb xanim faac musepack libdts

libtheora speex twolame toolame libmad liblzo gif

Audio output: sgi sun alsa openal jack polyp esd arts oss dxr2 nas dsound

win32 sdl

Video output: xvidix winvidix cvidix bl zr zr2 dxr3 dxr2 directx sdl vesa

gif89a jpeg png fbdev svga caca aa ggi xmga mga dga xvmc directfb tdfx_vid s3fb
tdfxfb 3dfx

Audio filters: ladspa

...

$ make
./version.sh cc -dumpversion
cc -c -I../libvo -I../../libvo -I/usr/X11R6/include -fno-PIC -O4
-march=pentium-m -mtune=pentium-m -pipe -ffast-math -fomit-frame-pointer
-mdynamic-no-pic -falign-loops=16 -DSYS_DARWIN -DCONFIG_DARWIN -arch i386
-isysroot /Developer/SDKs/MacOSX10.4u.sdk -D_LARGEFILE_SOURCE
-D_FILE_OFFSET_BITS=64 -I. -I/usr/X11R6/include -I./libavutil
-I./libavcodec -o mplayer.o mplayer.c
mplayer.c:5:19: error: stdio.h: No such file or directory
mplayer.c:6:20: error: stdlib.h: No such file or directory
In file included from mplayer.c:7:
config.h:176:23: error: sys/types.h: No such file or directory
In file included from mplayer.c:7:
config.h:177: error: parse error before 'ftello'
config.h:177: error: parse error before '*' token
config.h:177: warning: data definition has no type or storage class
mplayer.c:13:20: error: string.h: No such file or directory
mplayer.c:14:20: error: unistd.h: No such file or directory
mplayer.c:19:23: error: sys/ioctl.h: No such file or directory
mplayer.c:20:22: error: sys/wait.h: No such file or directory
mplayer.c:30:22: error: sys/time.h: No such file or directory
mplayer.c:31:22: error: sys/stat.h: No such file or directory
mplayer.c:33:20: error: signal.h: No such file or directory
mplayer.c:34:18: error: time.h: No such file or directory
mplayer.c:35:19: error: fcntl.h: No such file or directory
mplayer.c:36:20: error: limits.h: No such file or directory
mplayer.c:38:19: error: errno.h: No such file or directory

...folowing more bugs...

$ sudo updatedb ; locate stdio.h
/usr/include/glib-2.0/glib/gstdio.h
/usr/include/stdio.h

$ locate stdlib.h
/System/Library/Frameworks/Kernel?.framework/Versions/A/Headers/libsa/stdlib.h
/usr/include/stdlib.h

$ uname -a
Darwin MacBookPro?.local 8.6.1 Darwin Kernel Version 8.6.1: Tue Mar 7 16:55:45
PST 2006; root:xnu-792.9.22.obj~1/RELEASE_I386 i386 i386

Change History (5)

comment:1 Changed 13 years ago by stranche@…

maybe a REALLY bumb question (sorry in advance if it's the case ), but do you
have Xcode installed ?

comment:2 Changed 13 years ago by stranche@…

I mean the latest version of Xcode

comment:3 Changed 13 years ago by purportex@…

(In reply to comment #2)

I mean the latest version of Xcode

Yes, I already have

comment:4 Changed 13 years ago by stranche@…

I just tryed to get and compile SVN on my Macbook Pro and can't reproduce this
problem, the compile process starts ok.
however I do have troubles as described in bug #514.

On a second hand, the Intel core CPU are not correctly recognized, I posted the
report given by the Tools/cpuinfo utility there.

comment:5 Changed 13 years ago by nicolas.plourde@…

  • Resolution set to fixed
  • Status changed from new to closed

cant reproduce

Note: See TracTickets for help on using tickets.