Opened 13 years ago

Closed 12 years ago

#519 closed defect (remind)

Invalid read in mpeg audio decoder

Reported by: i_s_c_y@… Owned by: mans@…
Priority: normal Component: libavcodec
Version: unspecified Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I got this while having a file repeating for a while. By using libduma, I've
been able to see that an invalid read was done.

It most likely leads to a crash.

The problem is when doing: "code = get_vlc2(...);" in mpegaudiodec.c:1653
It's possible to receive a code that is outside of the huffman table. In that
case, an invalid read can be performed.

Attachments (1)

patch_audio (663 bytes) - added by i_s_c_y@… 13 years ago.
Patch

Download all attachments as: .zip

Change History (4)

Changed 13 years ago by i_s_c_y@…

Patch

comment:1 Changed 13 years ago by i_s_c_y@…

By using this patch, the problem goes away.

comment:2 Changed 13 years ago by mans@…

Is this still a problem? There have been major changes to the mpeg audio decoder.

comment:3 Changed 12 years ago by compn

  • Resolution set to remind
  • Status changed from new to closed

closing all ffmpeg bugs
please use ffmpeg roundup tracker for ffmpeg bugs now

Note: See TracTickets for help on using tickets.