Opened 15 years ago

Closed 14 years ago

Last modified 14 years ago

#52 closed defect (fixed)

libmpeg2 is broken (video playback "skip" back and forth)

Reported by: shacharr@… Owned by: r_togni@…
Priority: normal Component: vd
Version: HEAD Severity: major
Keywords: Cc: shacharr@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Lately (in 2004/8/2) libmpeg2 was updated to version 0.4.0. From CVS logs and
diffs, it seems that there was an attempt to migrate all mplayer specific
patches to the new version, but as of time being, it seems that there were
changes that were not correctly migrated, or that the libmpeg2 API changed while
libmpcodecs/vd_libmpeg2.c wasn't changed accordingly. As a result, when trying
to playback an MPEG2 video clip (I use simple MPEG-PS, with frame size of
480x576, which is scaled to 768x576), the video doesn't playback right, but
rather skips back and forth in the frames. Using ffmpeg instead (adding -vfm
ffmpeg to the command line), or rolling back libmpeg2 to the version of
2004/8/1 solved the problem, which means that it is a direct result of the
latest change in libmpeg2, and that the problem is libmpeg2 specific.
It is interesting to note, that I can recall seeing similar problems with
libmpeg2 long ago in the past, and they were fix after some time. Sadly I can't
remmeber the time that these problems were showing up in the CVS.
I am willing to produce an mplayer -v log if anyone finds this important for the
debug process (although as of time being, it requires me some work, since I
down-graded my libmpeg2 , so that MPEG2 playback will work for me).
Additionally, mplayer crashes with SIG11 when trying to exit (in uninit_vd ). I
will try to supply full gdb output for this later today. I will be happy to
supply if needed the file I have been testing on, although IMHO it will be
reproducable on most MPEG2 files. I have tried running mplayer in all 3
framedropping modes, with no apparent change.

Change History (5)

comment:1 Changed 15 years ago by mikachu@…

I would also like to note that it doesn't only skip back and forth for me, the
quality is also noticably degraded, comparable to 300kbit/s mpeg4 or something.

comment:2 Changed 14 years ago by r_togni@…

Should be fixed in cvs from 27/8

Please test and report, so we can close this bug.

comment:3 Changed 14 years ago by shacharr@…

The original bug had been fixed in the CVS. I send another small patch to the
mailing list, to fix some rare problems which might cause segmantation faults
under rare conditions.

comment:4 Changed 14 years ago by r_togni@…

  • Resolution set to fixed
  • Status changed from new to closed

ok, so bug closed

comment:5 Changed 14 years ago by diego@…

  • Owner changed from shacharr@… to r_togni@…

Mass reassign all vd bugs to Roberto, the new component owner.

Note: See TracTickets for help on using tickets.