Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#525 closed defect (wontfix)

CPU strings are incorrect in configure on MacIntel

Reported by: stranche@… Owned by: diego@…
Priority: normal Component: build system
Version: 1.0pre8 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

(extracted from bug #514)

On a Macbook pro the CPU is viewed like this by configure :

Checking for CPU vendor ... GenuineIntel? (6:14:8)
Checking for CPU type ... Genuine Intel(R) CPU T2600 @ 2.16GHz
Checking for GCC & CPU optimization abilities ... pentium-m
Checking for kernel support of mmx ... yes
Checking for kernel support of mmxext ... yes
Checking for kernel support of sse ... yes
Checking for kernel support of sse2 ... yes
Checking for mtrr support ... yes

should be named properly "Intel Core Duo 2.16GHz"

I attach here the infos from a Macbook 1,8GHz and a MacBook? Pro 2,16GHz

Attachments (2)

macbook18.txt (961 bytes) - added by stranche@… 13 years ago.
infos from macbook 1,8GHz
macbookpro216.txt (965 bytes) - added by stranche@… 13 years ago.
infos from macbook pro 2,16GHz

Download all attachments as: .zip

Change History (5)

Changed 13 years ago by stranche@…

infos from macbook 1,8GHz

comment:1 Changed 13 years ago by stranche@…

Changed 13 years ago by stranche@…

infos from macbook pro 2,16GHz

comment:2 Changed 13 years ago by stranche@…

comment:3 Changed 13 years ago by zuxy.meng@…

  • Resolution set to wontfix
  • Status changed from new to closed

TOOLS/cpuinfo returns the built-in name string of the CPU which may differ
from its trade name. Nevertheless, it won't interfere with configure's ability
to set optimization flags properly since only the family/model/stepping
triplets are used.

Note: See TracTickets for help on using tickets.