Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#526 closed defect (invalid)

mencoder crashes - wmv not playable only with 1.0pre8 !!!

Reported by: ruebe@… Owned by: reynaldo@…
Priority: normal Component: af
Version: 1.0pre8 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I cutted a wmv-file with asfbin and now wanted to encode it into mpeg2 via
mencoder. First I made a little test-file and then used the following command
with mencoder:
mencoder "E:\OTR Videos\test.wmv" -oac lavc -ovc lavc -of mpeg -mpegopts
format=xsvcd -vf scale=576:480,harddup -srate 44100 -af lavcresample=44100
-lavcopts
vcodec=mpeg2video:mbd=2:keyint=15:vrc_buf_size=917:vrc_minrate=600:vbitrate=2500:vrc_maxrate=2500:acodec=mp2:abitrate=224
-ofps 25 -o "E:\OTR Videos\Swimmingpool.mpg"
The mpeg-file was well written but only a note that the file/device mpegopts
couldn't have been opened appeared at the end. Bute the mpeg was playable. So I
updated mplayer & mencoder. After updating the command doesn't work at all!
mencoder crashes and mplayer is no longer able to play the source-wmv-file.
Mplayer writes now:
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders

MPlayer interrupted by signal 11 in module: init_audio_codec

  • MPlayer crashed by bad usage of CPU/FPU/RAM. Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
  • MPlayer crashed. This shouldn't happen. It can be a bug in the MPlayer code _or_ in your drivers _or_ in your gcc version. If you think it's MPlayer's fault, please read DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and won't help unless you provide this information when reporting a possible bug.

Dr. Watson from my Win2000-Operating System wrote the following into a logfile:
Anwendungsausnahme aufgetreten:

Anwendung: (pid=1028)
Wann: 27.06.2006 @ 18:45:47.957
Ausnahmenummer: c0000005 (Zugriffsverletzung)

*----> Systeminformationen <----*

Computername: RUEBE
Benutzername: R
Prozessoranzahl: 1
Prozessortyp: x86 Family 6 Model 3 Stepping 1
Windows 2000-Version: 5.0
Aktuelles Build: 2195
Service Pack: 4
Aktueller Typ: Uniprocessor Free
Firma: * (doesnt't need to be here)
Besitzer: * (doesnt't need to be here)

*----> Taskliste <----*

0 Idle.exe
8 System.exe

136 SMSS.exe
164 CSRSS.exe
184 WINLOGON.exe
212 SERVICES.exe
224 LSASS.exe
408 svchost.exe
436 spoolsv.exe
464 cvpnd.exe
484 svchost.exe
548 mstask.exe
612 stisvc.exe
656 WinMgmt?.exe
784 explorer.exe
768 SmartKbd?.exe
916 Ir.exe
940 Spamihilator.ex.exe
864 MediaCtr?.exe
948 osd.exe
836 msimn.exe

1080 Icq.exe

932 firefox.exe

1308 CMD.exe
1236 notepad.exe
1232 WINZIP32.exe
1328 mmc.exe
1028 mencoder.exe
1404 DRWTSN32.exe

0 _Total.exe

(00400000 - 00CD6000)
(77880000 - 77901000)
(79350000 - 793B2000)
(77E70000 - 77F36000)
(77D20000 - 77D91000)
(78000000 - 78045000)
(77A40000 - 77B37000)
(77F40000 - 77F7C000)
(77E00000 - 77E65000)
(77540000 - 77571000)
(74FA0000 - 74FB4000)
(74F90000 - 74F98000)

Statusabbild für Threadkennung 0x550

eax=0124d878 ebx=00000080 ecx=00000080 edx=0124d858 esi=00000200 edi=00000000
eip=0075abf8 esp=002278ec ebp=00227908 iopl=0 nv up ei ng nz na pe cy
cs=001b ss=0023 ds=0023 es=0023 fs=0038 gs=0000 efl=00000283

Funktion: <nosymbols>

0075abde dee2 fsubp st(2),st
0075abe0 d95a04 fstp dword ptr [edx+0x4]

ds:01cc773e=????????

0075abe3 83c208 add edx,0x8
0075abe6 d95804 fstp dword ptr [eax+0x4]

ds:01cc775e=????????

0075abe9 83c008 add eax,0x8
0075abec 39f3 cmp ebx,esi
0075abee eb50 jmp 00768540
0075abf0 d94004 fld dword ptr [eax+0x4]

ds:01cc775e=????????

0075abf3 8b7dec mov edi,[ebp+0xec]

ss:00ca17ee=00000000

0075abf6 d900 fld dword ptr [eax]

ds:0124d878=c0cbede1
FEHLER ->0075abf8 d904cf fld dword ptr [edi+ecx*8]
ds:00000080=????????

0075abfb d944cf04 fld dword ptr [edi+ecx*8+0x4]

ds:00a79f67=65006465

0075abff 01d9 add ecx,ebx
0075ac01 d9c1 fld st(1)
0075ac03 d8cb fmul st,st(3)
0075ac05 d9ca fxch st(2)
0075ac07 d8cc fmul st,st(4)
0075ac09 d9cb fxch st(3)
0075ac0b d8c9 fmul st,st(1)
0075ac0d d9c9 fxch st(1)
0075ac0f decc fmulp st(4),st
0075ac11 dec2 faddp st(2),st

*----> Stack Back Trace <----*

FramePtr? ReturnAd? Param#1 Param#2 Param#3 Param#4 Function Name
00227908 0075925F 0124D780 0124D850 00000000 00000000 !<nosymbols>
00227948 0067A5C5 0124D770 00227A70 01249770 0124D850 !<nosymbols>
0022FB08 0067B022 0000007D 0000007D 012434A8 0002B110 !<nosymbols>
0022FB48 0058808E 01242FA0 01203510 0022FBA8 011FBA08 !<nosymbols>
0022FB78 004B2625 01242FA0 01203510 0022FBA8 011FBA08 !<nosymbols>
0022FBC8 004B27EA 011F7848 01203510 00000001 0003EE00 !<nosymbols>
0022FBF8 00471B16 011F7848 00000000 0003EE00 0002EE00 !<nosymbols>
0022FC38 00471E73 011F7848 00000004 009C9030 009CFCB1 !<nosymbols>
0022FC78 004720BA 011F7848 00000000 00000000 00000002 !<nosymbols>
0022FCB8 0040236F 011F7848 0022FCA4 00000000 00000006 !<nosymbols>
0022FF78 00401236 00000016 003F3878 003F2A18 00B85000 !<nosymbols>
0022FFB0 00401288 00000001 00000009 0022FFF0 77E787F5 !<nosymbols>
0022FFC0 77E787F5 00790074 004F005C 7FFDF000 C0000005 !<nosymbols>
0022FFF0 00000000 00401270 00000000 000000C8 00000100
kernel32DosDateTimeToFileTime

*----> Raw Stack Dump <----*
002278ec 80 00 00 00 20 00 00 00 - 00 00 00 00 04 00 00 00 .... ...........
002278fc 00 04 00 00 50 d8 24 01 - 50 d8 24 01 48 79 22 00 ....P.$.P.$.Hy".
0022790c 5f 92 75 00 80 d7 24 01 - 50 d8 24 01 00 00 00 00 _.u...$.P.$.....
0022791c 00 00 00 00 c0 70 26 01 - 90 60 26 01 10 91 26 01 .....p&..`&...&.
0022792c 00 10 00 00 00 08 00 00 - 00 02 00 00 00 04 00 00 ................
0022793c 00 04 00 00 00 08 00 00 - 10 33 24 01 08 fb 22 00 .........3$...".
0022794c c5 a5 67 00 70 d7 24 01 - 70 7a 22 00 70 97 24 01 ..g.p.$.pz".p.$.
0022795c 50 d8 24 01 00 00 00 00 - 00 00 00 00 00 00 00 00 P.$.............
0022796c 00 00 00 00 4a 96 b6 43 - 00 00 00 00 00 00 00 00 ....J..C........
0022797c 00 00 00 00 00 00 00 00 - 00 00 00 00 00 00 00 00 ................
0022798c 60 77 24 01 68 77 24 01 - 00 00 00 00 10 73 24 01 `w$.hw$......s$.
0022799c 70 97 24 01 00 00 00 00 - 00 00 00 00 00 00 00 00 p.$.............
002279ac 0b 00 00 00 0b 00 00 00 - 05 00 00 00 0b 00 00 00 ................
002279bc 00 08 00 00 70 e2 27 01 - a2 bb 1f 01 02 00 00 00 ....p.'.........
002279cc 00 00 00 00 00 08 00 00 - 00 08 00 00 00 00 00 00 ................
002279dc 00 00 00 00 00 00 00 00 - 00 00 00 00 00 00 00 00 ................
002279ec 00 00 00 00 e0 39 8a 3c - 68 87 24 01 00 00 00 00 .....9.<h.$.....
002279fc 00 00 00 00 80 1a 28 01 - 10 1e 28 01 f8 95 24 01 ......(...(...$.
00227a0c 9c 92 24 01 00 00 00 00 - 90 6e 27 01 60 77 24 01 ..$......n'.`w$.
00227a1c 9e 33 24 01 1c 00 00 00 - 00 00 00 00 00 00 00 00 .3$.............

So I think it boils down to two bugs:
1.) mplayer has a problem in module init_audio_codec.
2.) mencoder should print this message instead of simply crashing.

By the way: Is mplayer & mencoder 1.0pre7 still anywhere available? I think I
used this version and would like to finish my work. Seemed to go ahead there.

Change History (4)

comment:1 Changed 13 years ago by reynaldo@…

  • Status changed from new to assigned

(In reply to comment #0)

Is there a chance you post a piece/all of your file for me to look at?
maybe you can upload it to our server too.

comment:2 Changed 13 years ago by ruebe@…

I uploaded the wmv-file to your FTP-Server in /mplayer/incoming. Unfortunately I
wanted to rename it after upload which wasn't possible so it's just test.wmv

comment:3 Changed 13 years ago by reynaldo@…

Hum, at last on Linux I was unable to reproduce your problem. file on
incoming encodes and plays just fine.

0.- read the bug reporting instructions.
1.- please dont cut mplayer's output.
1.5.- please give the complete error message corresponding to:

The mpeg-file was well written but only a note that the file/device mpegopts
couldn't have been opened appeared at the end

2.- please check with current svn.

Best regards

comment:4 Changed 13 years ago by reynaldo@…

  • Resolution set to invalid
  • Status changed from assigned to closed

(In reply to comment #3)

Hum, at last on Linux I was unable to reproduce your problem. file on
incoming encodes and plays just fine.

Im going to archive this bug as invalid, the reporter has stoped responding
and i cant reproduce it.

Note: See TracTickets for help on using tickets.