Opened 13 years ago

Last modified 9 years ago

#528 closed defect (worksforme)

Mplayer loaded IBM Thinkpad HDAPS sensor as Joystick renders keyboard key unusable if the laptop is tilted

Reported by: kagesenshi.87@… Owned by: reimar
Priority: normal Component: core
Version: unspecified Severity: normal
Keywords: Cc: compn
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

gmplayer ai_no_sono_~touch_my_heart\!~.avi
MPlayer dev-CVS-060417-03:18-rpm.livna.org-4.1.0 (C) 2000-2006 MPlayer Team
CPU: Intel Pentium M Dothan (Family: 6, Stepping: 6)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1

####################################################################
# No joystick is connected to the laptop yet it loads the device
####################################################################
Opening joystick device /dev/input/js0
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support.
You will not be able to use your remote control.
[GUI] Adding video filter: pp
Playing ai_no_sono_~touch_my_heart!~.avi.
MPEG-PS file format detected.
VIDEO: MPEG1 352x240 (aspect 12) 29.970 fps 1150.0 kbps (143.8 kbyte/s)
SUB: Could not determine file format
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 44100 Hz, 2 ch, s16le, 224.0 kbit/15.87% (ratio: 28000->176400)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
[gl] using extended formats. Use -vo gl:nomanyfmts if playback fails.
xscreensaver_disable: Could not find XScreenSaver window.
Opening video filter: [pp]
Opening video filter: [scale]
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 352 x 240 (preferred colorspace: Mpeg PES)
[PP] Using external postprocessing filter, max q = 6.
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
Try adding the scale filter, e.g. -vf spp,scale instead of -vf spp.
VDecoder init failed :(
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
Selected video codec: [mpeg12] vfm: libmpeg2 (MPEG-1 or 2 (libmpeg2))
==========================================================================
alsa-init: using device default
alsa: 48000 Hz/2 channels/4 bpf/65536 bytes buffer/Signed 16 bit Little Endian
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
VDec: vo config request - 352 x 240 (preferred colorspace: Planar YV12)
[PP] Using external postprocessing filter, max q = 6.
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
SwScaler?: using unscaled Planar YV12 -> BGRA special converter
VO: [gl] 352x240 => 352x264 BGRA
libGL warning: 3D driver claims to not support visual 0x4b
libGL warning: 3D driver claims to not support visual 0x23
libGL warning: 3D driver claims to not support visual 0x25
libGL warning: 3D driver claims to not support visual 0x27
libGL warning: 3D driver claims to not support visual 0x29
libGL warning: 3D driver claims to not support visual 0x2b
libGL warning: 3D driver claims to not support visual 0x2d
libGL warning: 3D driver claims to not support visual 0x2f
libGL warning: 3D driver claims to not support visual 0x31

##########################################################################
# this starts appear when the laptop is tilted
##########################################################################

No bind found for key 'JOY_RIGHT'-JOY_DOWN

############################################################################
# starting from here, the keyboard keys started to show problems
############################################################################
No bind found for key 'JOY_RIGHT'-JOY_DOWN-JOY_LEFT
No bind found for key 'JOY_RIGHT'-UP % 4 0
No bind found for key 'JOY_RIGHT'-UP % 4 0
No bind found for key 'JOY_RIGHT'-LEFT 4 0
No bind found for key 'JOY_RIGHT'-RIGHT 0
No bind found for key 'JOY_RIGHT'-LEFT 4 0
alsa-uninit: pcm closed-0.004 ct: 0.041 623/623 2% 17% 3.9% 4 0

Exiting... (Quit)

Frequency of occurence

Most of the time

Change History (4)

comment:1 Changed 13 years ago by reimar

  • Resolution set to invalid
  • Status changed from new to closed

To me this looks like it works as expected. MPlayer is busy processing joystick
requests so it can't react to the keyboard.
You can use the -nojoystick option to disable joystick support or get rid of
/dev/input/js0 (whatever device creates that, I don't think it's MPlayer's fault
to just believe the kernel it actually is a joystick).

comment:2 Changed 13 years ago by kagesenshi.87@…

  • Resolution invalid deleted
  • Status changed from closed to reopened

After a minor tilt, (especially when playing long videos) the keyboard keys are
rendered useless / unbinded from the command it supposed to do. Which to me
seems like a bug.

Even if HDAPS is accepted as joystick, the tilt should not unbind the keyboard
keys. The keys should remain useable after the tilt.

##########################################################################
# this starts appear when the laptop is tilted
##########################################################################

No bind found for key 'JOY_RIGHT'-JOY_DOWN << this happen when i do minor tilt

############################################################################
# starting from here, the keyboard keys started to show problems
############################################################################

as for below this, i actually pressing the keyboard up,down,left,right buttons.

As you can see, it no longer got any bind associated with it. (Keyboard

shortcuts became unuseable). Mplayer had to be restarted if want to use the
keyboard keys.

No bind found for key 'JOY_RIGHT'-UP % 4 0
No bind found for key 'JOY_RIGHT'-UP % 4 0
No bind found for key 'JOY_RIGHT'-LEFT 4 0
No bind found for key 'JOY_RIGHT'-RIGHT 0
No bind found for key 'JOY_RIGHT'-LEFT 4 0
alsa-uninit: pcm closed-0.004 ct: 0.041 623/623 2% 17% 3.9% 4 0

Expected behaviour
HDAPS can be used as joystick (some ppl may want to play with it) but it should
not render the keyboard keys unusable. I dont know if this happens if a real
joystick is put into test.

comment:3 Changed 13 years ago by kagesenshi.87@…

i gooogled and found this person having the same problem

http://appaji.livejournal.com/tag/alsa

comment:4 Changed 9 years ago by compn

  • Resolution set to worksforme
  • Status changed from reopened to closed, patriotact@gmail.com

so did -nojoystick work?
you can also set keys to ignore in input.conf
JOY_RIGHT ignore
etc.

Note: See TracTickets for help on using tickets.