Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#529 closed defect (fixed)

MPlayer (SVN checkout 2006.07.08) was unable to play OGG files.

Reported by: liaohaohui@… Owned by: reimar
Priority: normal Component: streaming
Version: 1.0pre8 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I tried to watch the OGG files from GNOME conference 2006
(http://stream.fluendo.com/archive/6uadec/) and KDE talks
(http://ktown.kde.org/akademy/). So I have installed libao-0.8.6.tar.gz,
libogg-1.1.3.tar.gz, libvorbis-1.1.2.tar.gz, libtheora-1.0alpha7.tar.bz2 ,
flac-1.1.2.tar.gz and speex-1.1.12.tar.gz. I then compiled
MPlayer-SVN-trunk-2006.07.08 (svn checkout) using gcc-3.4.6 (under Redhat 9).
But mplayer was unable to play any of the OGG (video) files found in the above
video sites.

I suspect that this may be related to the bug shown in
http://bugzilla.mplayerhq.hu/show_bug.cgi?id=426

Attachments (2)

ogg_seek.diff (1.9 KB) - added by reimar 13 years ago.
ogg seeking fix for -demuxer lavf
ogg_seek2.diff (3.1 KB) - added by reimar 13 years ago.
Another version that should avoid infinite hangs in all cases.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 13 years ago by reimar

Most samples e.g.
http://stream.fluendo.com/archive/6uadec/Federico_Mena_Quintero_-_GTK_Sharp_Mono_Tutorial.ogg
http://ktown.kde.org/akademy/Scott_And_Christian_GStreamer_video.ogg

play fine for me, both with and without -demuxer lavf. Seeking is broken though.
Please read bugreports.html and at least add a mplayer -v log for one of the
non-working samples (except
http://ktown.kde.org/akademy/Leon_Shiman_MAS_in_KDE_video.ogg, at least for my
definition that file is simply broken. I found a way to play it but it's not
very good yet).

comment:2 Changed 13 years ago by liaohaohui@…

  1. My sincere appologies to the developers! My mplayer was previously build with gcc-3.2.2 (the old compiler on my Redhat 9). Well, there seems to be some problems with gcc-3.2.2 compiler that it will not play


http://stream.fluendo.com/archive/6uadec/Federico_Mena_Quintero_-_GTK_Sharp_Mono_Tutorial.ogg

properly. This is of course my fault. But it works with
-demuxer lavf. After recompiling mplayer with gcc-3.4.6,
using mplayer -v I get

MPlayer 1.0pre8-3.4.6 (C) 2000-2006 MPlayer Team
CPU: AMD Duron(tm) processor (Family: 6, Model: 7, Stepping: 1)
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE

it gave the following output. It worked!

VO: [xv] 400x288 => 400x288 Planar YV12
Selected video codec: [theora] vfm: theora (Theora (free, reworked VP3))
==========================================================================
AO: [oss] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
Ogg : bad packet in stream 1
Ogg : bad packet in stream 0
A:4800.6 V:4800.6 A-V: 0.005 ct: 0.476 97/ 97 13% 3% 1.7% 1 0
Invalid frame duration value (4800.640/4795.680 => -4.960). Defaulting to 0.080 sec.
A:4810.2 V:4805.6 A-V: 4.565 ct: 0.972 160/160 8% 1% 1.7% 1 0
Invalid frame duration value (4805.680/4800.720 => -4.960). Defaulting to 0.080 sec.
A:4811.5 V:4806.2 A-V: 5.215 ct: 1.028 168/168 6% 1% 1.4% 1 0

  1. But for


http://stream.fluendo.com/archive/6uadec/Stefan_Kost_And_Thomas_Wabner_-_Advanced_Unit_Testing.ogg

with or without -demuxer lavf does make a difference. Without -demuxer
lavf, I had a still picture; with it, I have a moving picture.

  1. I observed that when playing mplayer without -demuxer lavf

Federico_Mena_Quintero_-_GTK_Sharp_Mono_Tutorial.ogg

the following error will be generated (as shown above):

[theora @ 0x869bc28]Missing extradata!
Could not open codec.
Ogg : bad packet in stream 1
Ogg : bad packet in stream 0

But with -demuxer lavf, no error will be generated. But there
was seeking problem which cause my who system to crash due to
all memory being consume.

In order to seek the video, I have to resolve to use xine. But
mplayer is still the best player around for the following reason:
I watched a tv series with 100s of opening song, I can always
skip it by mplayer -ss 100 *rmvb but it's impossible to deal with
using any other video player.

comment:3 Changed 13 years ago by reimar

  • Owner changed from r_togni@… to Reimar.Doeffinger@…

Yes, unfortunately the gcc series until 3.4 was practically unusable :-(, which
is one of the reasons why 2.95 is still supported. We weren't aware of that
particular problem though, otherwise we might have considered giving it the same
treatment as 2.96 ;-)
Concerning 2) I have only downloaded 1MB of it so far, so can't say if it will
work with the full video, but so far it works both with and without -demuxer
lavf for me. But I know the problem, the container says that the frame duration
of the first frame is 350 seconds, and MPlayer will thus display it for that
long. No idea where exactly the problem is (except that the ogg format is a
broken mess, and our code for it even more so).
Concerning 3)

[theora @ 0x869bc28]Missing extradata!

is a message from the ffmpeg theora decoder - it only works with -demuxer lavf.
But that's not a problem if you compiled MPlayer against libtheora, it will
fallback to that one.
I have a patch for the seeking problems with -demuxer lavf that should get
applied soon (I'll also attach it so you can test).

Changed 13 years ago by reimar

ogg seeking fix for -demuxer lavf

comment:4 Changed 13 years ago by reimar

Changed 13 years ago by reimar

Another version that should avoid infinite hangs in all cases.

comment:5 Changed 13 years ago by reimar

  • attachments.isobsolete changed from 0 to 1

comment:6 Changed 13 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

I fixed seeking with -demuxer lavf (I hope), and the problem with our native
demuxer is gone for me. No idea why though...
Please reopen if you still have issues.

Note: See TracTickets for help on using tickets.