Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#53 closed defect (fixed)

RTC timing in mplayer cause mplayer to pause

Reported by: davon@… Owned by: alex@…
Priority: normal Component: core
Version: unspecified Severity: normal
Keywords: Cc: diego@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I patched mplayer to use /dev/rtc on FreeBSD-4.10. There is a RTC driver which
supposedly works. However when I run mplayer using the rtc device the screen
comes up and it doesn't go any further after filling the cache. Now and then
it might play like a second. but then it just freezes.
When you ctrl-c you get a message that it left sleep_rtc using the -nortc of
course makes it work like it usually does. I've been tinkering with this
problem since 1.0.3 with no luck.

Attachments (1)

bsdrtc.diff (3.2 KB) - added by reimar 14 years ago.
RTC on BSD

Download all attachments as: .zip

Change History (5)

comment:1 Changed 14 years ago by reimar

I patched mplayer to use /dev/rtc on FreeBSD-4.10. There is a RTC driver which
supposedly works. However when I run mplayer using the rtc device the screen
comes up and it doesn't go any further after filling the cache. Now and then
it might play like a second. but then it just freezes.

Are you aware that MPlayer needs the rtc to run at 1024Hz? I wouldn't be
surprised if FreeBSDs rtc implementation won't do that...
Have a look at mplayer.c, line 1095, there you can tweak the rtc frequency used...

comment:2 Changed 14 years ago by diego@…

  • Cc diego@… added

Could you please post your patch? Also, have a look at the FreeBSD ports, they
also enable RTC in their MPlayer version.

Changed 14 years ago by reimar

RTC on BSD

comment:3 Changed 14 years ago by reimar

Does RTC on FreeBSD work with this patch?

comment:4 Changed 14 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

RTC should work now on FreeBSD out of the box.

Note: See TracTickets for help on using tickets.