Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#533 closed defect (wontfix)

A movies converted by smartmovie can't be played in MPlayer

Reported by: xarion@… Owned by: r_togni@…
Priority: normal Component: demuxer
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Smartmovie is a program which convert a movies that can be played on phone. This
program convert movies to Xvid. It use a non-standard codec xv.dll. I send you
this codec on server.
The log with errors:

[mpeg4 @ 0x90e3a8]Error, header damaged or not MPEG4 header (f_code=0)
[mpeg4 @ 0x90e3a8]header damaged
Error while decoding frame!
[mpeg4 @ 0x90e3a8]Error, header damaged or not MPEG4 header (f_code=0)
[mpeg4 @ 0x90e3a8]header damaged
Error while decoding frame!
[mpeg4 @ 0x90e3a8]Error, header damaged or not MPEG4 header (f_code=0)
[mpeg4 @ 0x90e3a8]header damaged
Error while decoding frame!
[mpeg4 @ 0x90e3a8]Error, header damaged or not MPEG4 header (f_code=0)
[mpeg4 @ 0x90e3a8]header damaged
Error while decoding frame!
[mpeg4 @ 0x90e3a8]Error, header damaged or not MPEG4 header (f_code=0)
[mpeg4 @ 0x90e3a8]header damaged
Error while decoding frame!
[mpeg4 @ 0x90e3a8]Error, header damaged or not MPEG4 header (f_code=0)
[mpeg4 @ 0x90e3a8]header damaged
Error while decoding frame!
[mpeg4 @ 0x90e3a8]Error, header damaged or not MPEG4 header (f_code=0)
[mpeg4 @ 0x90e3a8]header damaged
Error while decoding frame!
[mpeg4 @ 0x90e3a8]Error, header damaged or not MPEG4 header (f_code=0)
[mpeg4 @ 0x90e3a8]header damaged
Error while decoding frame!
[mpeg4 @ 0x90e3a8]Error, header damaged or not MPEG4 header (f_code=0)
[mpeg4 @ 0x90e3a8]header damaged
Error while decoding frame!
[mpeg4 @ 0x90e3a8]Error, header damaged or not MPEG4 header (f_code=0)
[mpeg4 @ 0x90e3a8]header damaged
Error while decoding frame!
[mpeg4 @ 0x90e3a8]Error, header damaged or not MPEG4 header (f_code=0)
[mpeg4 @ 0x90e3a8]header damaged
Error while decoding frame!
[mpeg4 @ 0x90e3a8]Error, header damaged or not MPEG4 header (f_code=0)
[mpeg4 @ 0x90e3a8]header damaged
Error while decoding frame!
[mpeg4 @ 0x90e3a8]Error, header damaged or not MPEG4 header (f_code=0)
[mpeg4 @ 0x90e3a8]header damaged
Error while decoding frame!
[mpeg4 @ 0x90e3a8]Error, header damaged or not MPEG4 header (f_code=0)
[mpeg4 @ 0x90e3a8]header damaged
Error while decoding frame!
[mpeg4 @ 0x90e3a8]Error, header damaged or not MPEG4 header (f_code=0)
[mpeg4 @ 0x90e3a8]header damaged
Error while decoding frame!
[mpeg4 @ 0x90e3a8]Error, header damaged or not MPEG4 header (f_code=0)
[mpeg4 @ 0x90e3a8]header damaged
Error while decoding frame!
[mpeg4 @ 0x90e3a8]hmm, seems the headers are not complete, trying to guess time_
increment_bits
[mpeg4 @ 0x90e3a8]my guess is 9 bits ;)
[mpeg4 @ 0x90e3a8]Error, header damaged or not MPEG4 header (qscale=0)
[mpeg4 @ 0x90e3a8]header damaged
Error while decoding frame!
[mpeg4 @ 0x90e3a8]hmm, seems the headers are not complete, trying to guess time_
increment_bits
[mpeg4 @ 0x90e3a8]my guess is 2 bits ;)
[mpeg4 @ 0x90e3a8]hmm, seems the headers are not complete, trying to guess time_
increment_bits
[mpeg4 @ 0x90e3a8]my guess is 3 bits ;)
[mpeg4 @ 0x90e3a8]looks like this file was encoded with (divx4/(old)xvid/opendiv
x) -> forcing low_delay flag
[mpeg4 @ 0x90e3a8]low_delay flag incorrectly, clearing it
[mpeg4 @ 0x90e3a8]looks like this file was encoded with (divx4/(old)xvid/opendiv
x) -> forcing low_delay flag
[mpeg4 @ 0x90e3a8]hmm, seems the headers are not complete, trying to guess time_
increment_bits
[mpeg4 @ 0x90e3a8]my guess is 1 bits ;)
[mpeg4 @ 0x90e3a8]warning: first frame is no keyframe
[mpeg4 @ 0x90e3a8]ac-tex damaged at 9 1
[mpeg4 @ 0x90e3a8]Error at MB: 29
[mpeg4 @ 0x90e3a8]concealing 247 DC, 247 AC, 247 MV errors
[mpeg4 @ 0x90e3a8]low_delay flag incorrectly, clearing it
[mpeg4 @ 0x90e3a8]hmm, seems the headers are not complete, trying to guess time_
increment_bits
[mpeg4 @ 0x90e3a8]my guess is 2 bits ;)
[mpeg4 @ 0x90e3a8]hmm, seems the headers are not complete, trying to guess time_
increment_bits
[mpeg4 @ 0x90e3a8]my guess is 4 bits ;)
[mpeg4 @ 0x90e3a8]hmm, seems the headers are not complete, trying to guess time_
increment_bits
[mpeg4 @ 0x90e3a8]my guess is 3 bits ;)
[mpeg4 @ 0x90e3a8]Error, header damaged or not MPEG4 header (f_code=0)
[mpeg4 @ 0x90e3a8]header damaged
Error while decoding frame!
[mpeg4 @ 0x90e3a8]hmm, seems the headers are not complete, trying to guess time_
increment_bits
[mpeg4 @ 0x90e3a8]my guess is 2 bits ;)
[mpeg4 @ 0x90e3a8]hmm, seems the headers are not complete, trying to guess time_
increment_bits
[mpeg4 @ 0x90e3a8]my guess is 1 bits ;)
[mpeg4 @ 0x90e3a8]hmm, seems the headers are not complete, trying to guess time_
increment_bits
[mpeg4 @ 0x90e3a8]my guess is 4 bits ;)
[mpeg4 @ 0x90e3a8]Error, header damaged or not MPEG4 header (f_code=0)
[mpeg4 @ 0x90e3a8]header damaged
Error while decoding frame!
[mpeg4 @ 0x90e3a8]Error, header damaged or not MPEG4 header (f_code=0)
[mpeg4 @ 0x90e3a8]header damaged
Error while decoding frame!
[mpeg4 @ 0x90e3a8]Error, header damaged or not MPEG4 header (f_code=0)
[mpeg4 @ 0x90e3a8]header damaged
Error while decoding frame!
[mpeg4 @ 0x90e3a8]hmm, seems the headers are not complete, trying to guess time_
increment_bits
[mpeg4 @ 0x90e3a8]my guess is 8 bits ;)
[mpeg4 @ 0x90e3a8]ac-tex damaged at 8 0
[mpeg4 @ 0x90e3a8]Error at MB: 8
[mpeg4 @ 0x90e3a8]concealing 247 DC, 247 AC, 247 MV errors

Change History (7)

comment:1 Changed 13 years ago by reimar

  • Severity changed from normal to enhancement

A sample file would be much more useful than the dll. And since it's obviously
yet another new, proprietary, useless codec I wouldn't expect much progress soon...

comment:2 Changed 13 years ago by xarion@…

Ok. I'm sending a file compressed with codec xv.dll. This filename is Whisper of
Heart pl 1.avi. This will be on server in a while. Sorry if you don't understand
everything what I write. My english isn't the best :P

comment:3 Changed 13 years ago by reimar

  • Component changed from ve to demuxer
  • op_sys changed from Cygwin to All
  • Severity changed from enhancement to normal
  • Version changed from 1.0pre8 to HEAD

File can be played both with -forceidx and -demuxer lavf. Looks somewhat like a
broken ODML index. No idea if this is a broken file or a bug in MPlayer...

comment:4 Changed 13 years ago by xarion@…

This file isn't broken. Windows Media Player can play this movie because WMP is
using xv.dll codec. This isn't a bug in mplayer. MPlayer is not using this codec
and I don't know how add this codec to mplayer.

comment:5 Changed 13 years ago by reimar

The problem is _not_ with the codec, the only problem is the demuxer. It
obviously works with WMP, since WMP does not support ODML at all (and the
problem is probably a broken ODML index).
You don't need to add this codec to mplayer, just use
mplayer -forceidx "Whisper of Heart pl 1.avi"
or
mplayer -demuxer lavf "Whisper of Heart pl 1.avi"
to play it.

comment:6 Changed 13 years ago by xarion@…

Thanks for your help. It's working :)

comment:7 Changed 12 years ago by reimar

  • Resolution set to wontfix
  • Status changed from new to closed

A suitable workaround was found, thus closing.

Note: See TracTickets for help on using tickets.