Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#538 closed defect (fixed)

mp3 that cannot be played properly by mplayer.

Reported by: liaohaohui@… Owned by: r_togni@…
Priority: normal Component: streaming
Version: 1.0pre8 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I have an mp3 file that can be played properly by madplay (from madlib) and
ffplay (from ffmpeg) but not mplayer.

Change History (5)

comment:1 Changed 13 years ago by liaohaohui@…

The file is too large (more than 1M), I have uploaded it to
ftp://mplayerhq.hu/MPlayer/incoming directory (don't know whether it will be
deleted).

comment:2 Changed 13 years ago by liaohaohui@…

Sorry to miss out the name of the uploaded mp3, it was ljsyztq.mp3 (I uploaded
it to ftp://mplayerhq.hu/MPlayer/incoming).

comment:3 Changed 13 years ago by reimar

what exactly means "cannot be played properly"?? It seems to work fine for me.
Can you also test on a computer without 3Dnow? Or one with SSE?

comment:4 Changed 13 years ago by liaohaohui@…

  • Resolution set to fixed
  • Status changed from new to closed

My fault. I believed this is a bug for the gcc-3.2.2 compiler I have.
My MPlayer was previously compiled with gcc-3.2.2 and it has problem
playing the ljsyztq.mp3 I submitted --- it plays but the sound is awful.

I fear this is due to the problem with compiler before gcc-3.4 being
barely useable as pointed out in http://bugzilla.mplayerhq.hu/show_bug.cgi?id=529

Maybe a warning in the ./configure against any gcc less than 3.4
would solve faulty bugs being submitted.

Just to point out another problem with gcc-3.2.2: Even though yafray
render can be compiled with it, the renderer will display a blank
scene. However, yafray renders correctly when compiled with gcc-3.4
and 4.1.

I am very sorry. But at least we learn that it's gcc's fault.

comment:5 Changed 13 years ago by liaohaohui@…

I try MPlayer today and discovered that the cause of the problem with the
ljsyztq.mp3 is not because of gcc BUT because of the encoding problem.
As ljsyztq.mp3 has non-european encoding TAGs. When it is played,
it will generate the [' on the xterm, but since [' decreases the speed
of playing the song, so I will always have problem listening to the song.

This is not the bug of gcc-3.2.2 nor MPlayer, but because terminal
encoding problem.

Now I can really conclude that the problem has been solved!

Note: See TracTickets for help on using tickets.