Opened 14 years ago

Last modified 10 years ago

#548 closed defect (invalid)

No video (just audio) in WinXP if a dock-like app is running

Reported by: sousa.jff@… Owned by: r_togni@…
Priority: normal Component: demuxer
Version: 1.0pre8 Severity: normal
Keywords: Cc: compn
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Windows XP Home (no SP)
P4 2.8Mhz
ATI Mobility Radeon 9000 64MB (Radeon Omega Drivers 2.6.75a)
DirectX 9.0c
Mplayer 1.0pre8-3.4.2 and MPUI 1.2-pre2 build 35 (though same as occured with a
different GUI)

Guess this is a Windows specific

There seems to be some issues with Stardock ObjectDock? 1.3 (and maybe other
dock-like apps). If it's closed when I launch Mplayer (MPUI) the video will
always display nice. If however they are running, it'll have no image (only
audio). I've found a similar situation in Media Player Classic but only in full
screen.

I also mailed Martin Fiedler and he suggested it could be ObjectDock? applying
some alpha blending that caused the issue (not a techie so it's all greek to
me... have no idea on what is problematic component so here goes anything...
sorry if it was a really dumb pick... hoping to get lucky and pick the right one).

Would be nice to have it fixed by the final 1.0 :)

Change History (4)

comment:1 Changed 14 years ago by reimar

Please give the full mplayer output when adding the -v option to the commandline.
Also try -vo gl and -vo directx:noaccel

comment:2 Changed 14 years ago by sousa.jff@…

That solved it. I just added those as aditional comands in MPUI preferences (I
really need the GUI for a media player since I'm not familiar at all with the
comand interface of Mplayer).

But on the other hand video suffered a major quality loss so I guess I won't be
using those commands... Is there any other way?

comment:3 Changed 14 years ago by reimar

Please try them seperately.
Does adding only
-vo gl
help?
Does adding only
-vo directx:noaccel
help?
Some more:
Does adding only
-nocolorkey
help?
Does adding only
-colorkey 0
help?

comment:4 Changed 10 years ago by compn

  • Resolution set to invalid
  • Status changed from new to closed, patriotact@gmail.com

probably try -vo direct3d too

Note: See TracTickets for help on using tickets.