Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#556 closed defect (duplicate)

subtitles are wrongly displayed

Reported by: superandrzej@… Owned by: beastd
Priority: normal Component: vo
Version: 1.0pre8 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

In 1.0pre8 subtitles are wrongly displayed.
I use cp1250 encoded subtitles and have cp1250 encoded font in ~/.mplayer/font
but Mplayer 1.0pre8 displays it wrongly e.g.:
"¿cis¿ej czo¿ówce" instead of "¶cis³e¶ czo³ówce" => "¶" and "³" are replaced
with "¿"
"ekscytuj¿ce" instead of "ekscytuj±ce" => "±" is replaced with "¿"
"¿¿ó³todziób" instead of "¿ó³todziób" => additional "¿"
"obj¿¿" instead of "obj±³" => "±" and "³" are replaced with "¿"

there are no such problems with 1.0pre7try2

Change History (3)

comment:1 Changed 13 years ago by reimar

You need a font that supports UTF-8. There should be script in one of these
bugzilla bugs that can fix your font, or just use an appropriate ttf font.

comment:2 Changed 13 years ago by superandrzej@…

Why would I need UTF-8 font if subtitles are encoded in cp1250?

Are you saying that now setting font in ~/.mplayer/font is no longer valid?

comment:3 Changed 13 years ago by reimar

  • Resolution set to duplicate
  • Status changed from new to closed

Everything necessary should be explained in bug #199

* This bug has been marked as a duplicate of 199 *

Note: See TracTickets for help on using tickets.