Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#557 closed defect (worksforme)

demuxer.c:941: error: 'MSGTR_DemuxerInfoChanged' undeclared

Reported by: mplayer@… Owned by: diego@…
Priority: normal Component: build system
Version: unspecified Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I was able to checkout the full SVN tree fine, configure, make and install
mplayer. mplayer ran from the command line in a ssh terminal, but I was remotely
logged in via SSH so could not verify audio/video performance.
Then I messed up and did a chmod +R 700 above the mplayer directory. Not wanting
to figure out which files should have +x turned on and which should not, I wiped
out the directory and did a new svn checkout.

./configure works fine, but when I tried a "make install" next (thinking it
would do a make, then make install automatically) I got part way though:
(snip)
cc -c -I../libvo -I../../libvo -fno-PIC -O4 -march=k8 -mtune=k8 -pipe
-ffast-math -fomit-frame-pointer -D_REENTRANT -D_LARGEFILE_SOURCE
-D_FILE_OFFSET_BITS=64 -I/usr/include -I/usr/src/DVB/ost/include
-I/usr/include/dxr2 -I/usr/include/kde/artsc -pthread -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include -I/usr/local/include/cdda -I/usr/include/freetype2
-I.. -I../stream -I../loader -I../libavutil -I../libavcodec -I../libavformat -o
demuxer.o demuxer.c
demuxer.c: In function 'demux_info_add':
demuxer.c:941: error: 'MSGTR_DemuxerInfoChanged' undeclared (first use in this
function)
demuxer.c:941: error: (Each undeclared identifier is reported only once
demuxer.c:941: error: for each function it appears in.)
make[1]: * [demuxer.o] Error 1
make[1]: Leaving directory `/usr/src/mplayer/libmpdemux'
make:
* [libmpdemux/libmpdemux.a] Error 2

and it will not continue. Very strange since it had just worked, so I tried a
make clean, and make again with the same results.

Debian Etch 2.6.17 compiled for Athlon64, updated everything to testing on 8/14/06.
AMD Athlon64 3200+ processor.
Video: nVidia 7600 using TV out. nVidia binary driver not installed yet, as I've
not figured out how to do it for a 2.6.17 kernel yet (which I need for the ivtv
driver).
Sound: cs46xx Cirrus Logic CS 4614/22/24 [CrystalClear? SoundFusion? Audio A

#uname -a
Linux mythtv 2.6.17-ck1 #1 Mon Aug 14 01:22:13 PDT 2006 i686 GNU/Linux

# ls -l /lib/libc[.-]*
-rwxr-xr-x 1 root root 1177116 2006-06-08 00:24 /lib/libc-2.3.6.so
lrwxrwxrwx 1 root root 13 2006-08-11 23:32 /lib/libc.so.6 -> libc-2.3.6.so

# gcc -v
Using built-in specs.
Target: i486-linux-gnu
Configured with: ../src/configure -v
--enable-languages=c,c++,java,fortran,objc,obj-c++,ada,treelang --prefix=/usr
--enable-shared --with-system-zlib --libexecdir=/usr/lib
--without-included-gettext --enable-threads=posix --enable-nls
--program-suffix=-4.1 --enable-cxa_atexit --enable-clocale=gnu
--enable-libstdcxx-debug --enable-java-awt=gtk --enable-gtk-cairo
--with-java-home=/usr/lib/jvm/java-1.4.2-gcj-4.1-1.4.2.0/jre --enable-mpfr
--with-tune=i686 --enable-checking=release i486-linux-gnu
Thread model: posix
gcc version 4.1.2 20060613 (prerelease) (Debian 4.1.1-5)
# ld -v
GNU ld version 2.17 Debian GNU/Linux

# as --version
GNU assembler 2.17 Debian GNU/Linux
Copyright 2005 Free Software Foundation, Inc.
This program is free software; you may redistribute it under the terms of
the GNU General Public License. This program has absolutely no warranty.
This assembler was configured for a target of `i486-linux-gnu'.

# cat /proc/cpuinfo
processor : 0
vendor_id : AuthenticAMD
cpu family : 15
model : 47
model name : AMD Athlon(tm) 64 Processor 3200+
stepping : 2
cpu MHz : 2010.206
cache size : 512 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush mmx fxsr sse sse2 syscall nx mmxext fxsr_opt lm 3dnowext 3dnow
up pni lahf_lm ts fid vid ttp tm stc
bogomips : 4023.36

config.h: http://www.barraquatic.com/temp/config.h
config.mak: http://www.barraquatic.com/temp/config.mak

Change History (2)

comment:1 Changed 13 years ago by diego@…

  • Resolution set to worksforme
  • Status changed from new to closed

Unreproducible, I get no such compilation error. Please just try

./configure
make
make install

from a fresh Subversion checkout, your problem should go away.

comment:2 Changed 13 years ago by reimar

Sorry, that was my fault, I didn't commit the two files at the same time, so SVN
was broken for ca. 10 seconds. IOW: you were really, really unlucky *g* make
distclean, svn up and try again.

Note: See TracTickets for help on using tickets.