Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#566 closed defect (invalid)

vo paramater outdir cannot specify absolute paths on windows

Reported by: benadler@… Owned by: beastd
Priority: normal Component: vo
Version: 1.0rc1 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

On windows, a command like "mplayer -vo jpeg:outdir=c:\test:quality=100..."
results in the following error:

jpeg: Parsing suboptions.
Could not parse arguments at the position indicated below:
outdir=c:\

(the pointer is right under the backslash)

Error opening/initializing the selected video_out (-vo) device.

I guess this is because mplayer thinks the colon from c:\ is supposed to split
parameters, but here, its my only hope of specifying an absolute outdir on windows.

Change History (4)

comment:1 Changed 13 years ago by reimar

try -vo jpeg:outdir="c:\test" instead.

comment:2 Changed 13 years ago by benadler@…

(In reply to comment #1)

try -vo jpeg:outdir="c:\test" instead.

This doesn't work, the quuotes are simply ignored. I tried single and double
quotes, or using a backslash right before the colon. Nothing helps.

comment:3 Changed 13 years ago by benadler@…

  • Version changed from 1.0pre8 to 1.0rc1

This bug is still present in 1.0rc1-3.4.2. If you could please tell me where the
options are parsed in the code, I'd like to try and fix this!

comment:4 Changed 13 years ago by reimar

  • Resolution set to invalid
  • Status changed from new to closed

Read the documentation on your shell more closely. You must make sure it does
not eat the " (same for \ btw), e.g. by doing
-vo jpeg:outdir=\"c:\\test\"
or
-vo jpeg:outdir='"c:\test"'

Note: See TracTickets for help on using tickets.