Opened 15 years ago

Closed 13 years ago

Last modified 13 years ago

#57 closed defect (worksforme)

Very slow start for an OGM file named as .avi

Reported by: mothership.connection@… Owned by: moritz@…
Priority: normal Component: demuxer
Version: unspecified Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description


Trying demuxer 3 based on filename extension

msg:Trying demuxer 3 based on filename extension

cache_stream_seek: WARNING! Can't seek to 0xB5CDB15C !

msg:cache_stream_seek: WARNING! Can't seek to 0xB5CDB15C !

ds_fill_buffer: EOF reached (stream: video)

msg:ds_fill_buffer: EOF reached (stream: video)

AVI: Missing video stream!? Contact the author, it may be a bug :(


Hi!

I'm having problems playing an OGM file which is named as video.avi. It seems
that mplayer starts to play the file as an avi file. Mplayer starts reading
the file but can't find the video stream so it will search the entire file for
it (the larger the file, the longer the search). After searching through the
whole file, playback starts.

thanks

Change History (5)

comment:1 Changed 15 years ago by reimar

You should never! truncate the log messages, and they should be the -v logs!
Anyway if the file is named .avi I usually wouldn't consider it a bug if MPlayer
tries to play it as avi...

comment:2 Changed 15 years ago by mothership.connection@…

I guess you can think in many ways about it being a bug per se..

However, based on experience from p2p networks for example, people do have a
lot of ogg media files named as .avi.

Anyway, do you think there will be a solution to this, mplayer not finding the
stream correctly?

thanks

comment:3 Changed 15 years ago by reimar

You can still use -demuxer 18 to force detection as ogg.

comment:4 Changed 14 years ago by dominik@…

Check with latest CVS. I can't reproduce it now, but the largest file I could
find is about 200MB in size and it opens very quickly whether as .avi or as .ogm.

comment:5 Changed 13 years ago by diego@…

  • Resolution set to worksforme
  • Status changed from new to closed

Since the problem seems to have gone away I resolve this as WORKSFORME.

Note: See TracTickets for help on using tickets.