Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#578 closed defect (fixed)

Support for Flash 8/9 video files

Reported by: sarbalap+mplayerbugs@… Owned by: mans@…
Priority: normal Component: libavformat
Version: unspecified Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Hello,

First off, sorry for any mistakes or lack of information in the following bug
report. Please, request any additional information you need and I will try to
give you as much details as possible.

I have met this situation with MPlayer 1.0pre8 under Slackware-current, and a
friend of mine did an additional test some days ago from an SVN build, with
the same results, so I think this bug/feature-lack is still present and that's
why I decided to report the bug. I'm filling this under FFmpeg because, after
reading the Wikipedia and searching in Google, I found this thread in the
ffmpeg-devel mailing list archives in which the situation is discussed:

http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/2006-March/009115.html

When you try to play an Flash 8/9 .flv file with MPlayer, the video is not
played and the following information is printed on screen:

Playing <file name>
libavformat file format detected.
[flv @ <some hex number>]Unsupported video codec (4)
< ... previous line repeated thousands of times ... >

MPlayer interrupted by signal 2 in module: demux_open

By using a tool like metacafe-dl (disclaimer: I'm the author;
http://www.arrakis.es/~rggi3/metacafe-dl/ ) you can download videos in this
format from metacafe.com, so you can get a virtually unlimited number of
testing samples and see the situation for yourself.

My MPlayer version:

MPlayer 1.0pre8-3.4.6 (C) 2000-2006 MPlayer Team
CPU: Mobile AMD Sempron(tm) Processor 3000+ (Family: 15, Model: 28, Stepping:
0)
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE SSE2

Thanks in advance. Keep up the good work. MPlayer and FFmpeg rock! Best
regards,

-Ricardo Garcia

Change History (2)

comment:1 Changed 13 years ago by mans@…

  • Resolution set to fixed
  • Status changed from new to closed

Flash 8 uses the VP6 video codec. This is supported in ffmpeg since Sep 9 2006.

comment:2 Changed 13 years ago by sarbalap+mplayerbugs@…

Wow, this is great news! I can't wait to try the SVN version myself. You guys
seriosly rule. My most sincere thanks and congratulations. And sorry for being
9 days late :).

Greetings and best regards.

Note: See TracTickets for help on using tickets.