Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#58 closed defect (wontfix)

alsa driver does not compile

Reported by: uhlar@… Owned by: alex@…
Priority: normal Component: ao
Version: 1.0pre5 Severity: normal
Keywords: Cc: diego@…, sebastian.manzano@…, semicide@…, dimaki@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

the merged alsa driver in 1.0pre5 does not support alsa0.9, at least not
0.9+0beta12-3 installed with debian 3.0-Woody.

The compile error:

ao_alsa.c: In function `init':
ao_alsa.c:595: warning: passing arg 3 of `snd_pcm_hw_params_set_rate_near' makes
integer from pointer without a cast
ao_alsa.c:633: warning: passing arg 3 of
`snd_pcm_hw_params_set_period_size_near' makes integer from pointer without a cast
ao_alsa.c:642: warning: passing arg 3 of `snd_pcm_hw_params_set_periods_near'
makes integer from pointer without a cast
ao_alsa.c:662: too many arguments to function `snd_pcm_hw_params_get_buffer_size'

It seems that those 4 functions changed between alsa 0.9 and 1.0.

alsa 0.9:

unsigned int snd_pcm_hw_params_set_rate_near(snd_pcm_t *pcm, snd_pcm_hw_params_t
*params, unsigned int val, int *dir);
snd_pcm_uframes_t snd_pcm_hw_params_set_period_size_near(snd_pcm_t *pcm,
snd_pcm_hw_params_t *params, snd_pcm_uframes_t val, int *dir);
unsigned int snd_pcm_hw_params_set_periods_near(snd_pcm_t *pcm,
snd_pcm_hw_params_t *params, unsigned int val, int *dir);
snd_pcm_sframes_t snd_pcm_hw_params_get_buffer_size(const snd_pcm_hw_params_t
*params);

alsa1.0:

int snd_pcm_hw_params_set_rate_near(snd_pcm_t *pcm, snd_pcm_hw_params_t *params,
unsigned int *val, int *dir);
int snd_pcm_hw_params_set_period_size_near(snd_pcm_t *pcm, snd_pcm_hw_params_t
*params, snd_pcm_uframes_t *val, int *dir);
int snd_pcm_hw_params_set_periods_near(snd_pcm_t *pcm, snd_pcm_hw_params_t
*params, unsigned int *val, int *dir);
int snd_pcm_hw_params_get_buffer_size(const snd_pcm_hw_params_t *params,
snd_pcm_uframes_t *val);

There probably will be more differencies

Change History (9)

comment:1 Changed 15 years ago by reimar

This changed somewhere inbetween 0.9.0rc3 and 0.9.7. I guess you'll have to
upgrade or find out at which version exactly it changed, then we could #ifdef
the right part...

comment:3 Changed 15 years ago by reimar

  • Cc sebastian.manzano@… added

comment:4 Changed 15 years ago by reimar

* Bug 107 has been marked as a duplicate of this bug. *

comment:5 Changed 15 years ago by reimar

As an update: I think everyone is too busy to implement support for old alsa
0.9rc versions, so I advice everyone who experiences this problem to upgrade
alsa libs.

comment:6 Changed 15 years ago by diego@…

  • Cc diego@… added
  • Resolution set to wontfix
  • Status changed from new to closed

I agree that probably nobody will get around to fix this unless you come up with
a patch yourself. Marking WONTFIX for lack of time and interest.

comment:7 Changed 15 years ago by reimar

  • Cc semicide@… added

comment:8 Changed 15 years ago by reimar

* Bug 189 has been marked as a duplicate of this bug. *

comment:9 Changed 15 years ago by reimar

  • Cc dimaki@… added

* Bug 200 has been marked as a duplicate of this bug. *

Note: See TracTickets for help on using tickets.