Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#580 closed defect (fixed)

mplayer crash with segfault

Reported by: jigglypuff@… Owned by: r_togni@…
Priority: normal Component: demuxer
Version: unspecified Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I managed to crash mplayer with a real media file I found on the internet. It is
a segfault. I don't know if it is the fault of mplayer, my audio drivers, or the
codecs.

I crashed it with both mplayer1.0pre8 and svn 2006-09-23 (today). It is
interesting to note that when pre8 crashes, it says something about video
stream, but when latest svn crashes, it says something about audio. This
behavior is consistent with this file.

I created a tar.gz named, brandon-bug-20060923.tar.gz, and have uploaded it to
ftp://upload.mplayerhq.hu/MPlayer/incoming/. This file contains the real media
file that mplayer crashes on, and two gdb traces. One for latest svn mplayer,
and one for 1.0pre8 mplayer. To me, the crashes seemed so different that I felt
that I should include both of them.

I am not an expert. I have been using computers for years, i regularly fix them.
I have used linux as my primary OS for several months. I am not a dummy; I can
follow clear and concise directions, but not an expert either. I would be happy
to help resolve this bug, if my further participation is necessary. Honestly, I
hope it isn't, though.

My system details:
I am running debian sarge, kernel 2.6.8, with all the latest updates. Stock
kernel. mplayer compiled by hand every time. I use mplayer command line, no gui
installed. My codecs are the latest from mplayer website (20060611).

uname -r
Linux ALPHA 2.6.8-2-686 #1 Tue Aug 16 13:22:48 UTC 2005 i686 GNU/Linux

ls -l /lib/libc[.-]*
-rwxr-xr-x 1 root root 1244752 2006-04-19 07:11 /lib/libc-2.3.2.so
lrwxrwxrwx 1 root root 13 2006-09-02 04:25 /lib/libc.so.6 -> libc-2.3.2.so

gcc version 3.3.5
GNU ld version 2.15
GNU assembler 2.15

Intel Celeron D 2.93GHz:
processor : 0
vendor_id : GenuineIntel?
cpu family : 15
model : 4
model name : Intel(R) Celeron(R) CPU 2.93GHz
stepping : 1
cpu MHz : 2934.199
cache size : 256 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 5
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36
clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe pni monitor ds_cpl cid
bogomips : 5799.93

Video Card is a PNY Nvidia FX5500 8x AGP 128MB RAM.
Here is the output of lspci -vv (with USB etc deleted)

0000:01:00.0 VGA compatible controller: nVidia Corporation: Unknown device 0326
(rev a1) (prog-if 00 [VGA])

Control: I/O+ Mem+ BusMaster?+ SpecCycle?- MemWINV- VGASnoop- ParErr?- Stepping-

SERR- FastB2B-

Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr?- DEVSEL=medium >TAbort- <TAbort-

<MAbort- >SERR- <PERR-

Latency: 248 (1250ns min, 250ns max)
Interrupt: pin A routed to IRQ 201
Region 0: Memory at f4000000 (32-bit, non-prefetchable) [size=16M]
Region 1: Memory at e8000000 (32-bit, prefetchable) [size=128M]
Capabilities: <available only to root>

Attachments (1)

gdbtrace.tar.gz (21.6 KB) - added by jigglypuff@… 13 years ago.
Bug traces for svn and 1.0pre8

Download all attachments as: .zip

Change History (8)

comment:1 Changed 13 years ago by jigglypuff@…

  • Summary changed from mplayer crash to mplayer crash with segfault

Changed 13 years ago by jigglypuff@…

Bug traces for svn and 1.0pre8

comment:2 Changed 13 years ago by jigglypuff@…

No reason I can't include this attachment for the rest of us.

Here is a link to the offending real media file. Only download if you are over
18 and not offended by any videos.
http://www.amateurspankings.com/kayes_birthday_spanking_free_spanking_clip_sampleb.rm

I'd really like to know if this crash is specific to me and my architecture, or
if any of you can get it to crash with this file.

comment:3 Changed 13 years ago by jigglypuff@…

Oh yeah. Using proprietary nvidia driver. 1.0.7174

comment:4 Changed 13 years ago by reimar

It doesn't crash anymore, instead it hangs in the binary decoder... :-(

comment:5 Changed 12 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

Fixed for me in latest SVN.

comment:6 Changed 12 years ago by jigglypuff@…

Just updated to rev 19976 (date 9-24-2006, today), and the bug seems to be
fixed. I guess it was mplayer.

So, Reimar Döffinger, are you a mplayer developer? Did you fix this bug? Or did
someone else come along and fix it without saying anything? I doubt it is a
coincidence.

comment:7 Changed 12 years ago by reimar

I fixed it with help from Roberto (as svn log can tell you, too ;-) ).

Note: See TracTickets for help on using tickets.