Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#585 closed defect (invalid)

Mplayer read file date as keyboard input

Reported by: nian.wu@… Owned by: nicolas.plourde@…
Priority: normal Component: MPlayer OS X
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Attachment file testcase_list include two command to run mplayer; runtest.sh
will read testcase_list and run test cases.
When run first test case, mplayer open media file and play. Then mplayer read
contents of testcase_list as its keyboard input, and quickly exit.

Attachments (3)

testcase_listing (75 bytes) - added by nian.wu@… 13 years ago.
test case listing
runtest.sh (137 bytes) - added by nian.wu@… 13 years ago.
script to run test
temp.log (2.8 KB) - added by nian.wu@… 13 years ago.
log file

Download all attachments as: .zip

Change History (7)

Changed 13 years ago by nian.wu@…

test case listing

comment:1 Changed 13 years ago by nian.wu@…

Changed 13 years ago by nian.wu@…

script to run test

comment:2 Changed 13 years ago by nian.wu@…

Changed 13 years ago by nian.wu@…

log file

comment:3 Changed 13 years ago by nian.wu@…

Because my lanaguage env. is Chinese, so this file includes some Chinese, maybe
it can not be displayed in your system. I think it do not has matter.

comment:4 Changed 13 years ago by nicolas.plourde@…

  • Resolution set to invalid
  • Status changed from new to closed

Im no sh expert but it looks like your script "runtest.sh" is not waiting for the first command to finish
and try to run the second one. MPlayer read input from the terminal while running so i guess the
second command is interpreted has key input.

try this instead

#!/bin/sh
OBJLIST=testcase_listing

. $OBJLIST

This work on OSX and linux

Note: See TracTickets for help on using tickets.