Opened 15 years ago

Closed 14 years ago

Last modified 14 years ago

#59 closed defect (fixed)

xvidix, svgalib_helper, ATI Mach64 driver

Reported by: dearbear@… Owned by: alex@…
Priority: normal Component: vo
Version: 1.0pre3 Severity: normal
Keywords: Cc: dominik@…, saschasommer@…, chris.coroner@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I have compiled the libdha with svgalib_helper support. I tried to use the
xvidix video out to watch movies, but if the svgalib_helper support is in the
libhda I have the next error:

[mach64] Found chip: Rage Mobility P/M AGP 2x
vidixlib: /usr/local/lib/mplayer/vidix/mach64_vid.so probed o'k
vidixlib: will use /usr/local/lib/mplayer/vidix/mach64_vid.so driver
vidixlib: Attempt to initialize driver at: 0x40ceee30
[mach64] version 1.0pre3-3.3.3
vidixlib: Can't init driver: Cannot allocate memory
vosub_vidix: Couldn't find working VIDIX driver

Linux kernel version: 2.6.0
Svgalib version: 1.9.19

Without the svgalib support I can use the mplayer to display my movies with
xvidix when I set the suid property of the executable.

Attachments (1)

lspci.txt (5.1 KB) - added by chris.coroner@… 14 years ago.
output of lspci -v -v -v

Download all attachments as: .zip

Change History (7)

comment:1 Changed 15 years ago by dominik@…

Confirmed. I've observed the same behaviour with gcc-3.2.2, kernel 2.4.27 and
your modified svgalib_helper
(http://www.mplayerhq.hu/~alex/svgalib_helper-1.9.17-mplayer.tar.bz2).

comment:2 Changed 15 years ago by dominik@…

  • Cc dominik@… added

comment:3 Changed 14 years ago by chris.coroner@…

  • Cc chris.coroner@… added

I have found the same behaviour. On the code it seems that one of the two mmap()
calls in vixInit() in vidix/drivers/mach64_vid.c fails. It would be nice to see
this bug fixed because I want to be able to use mplayer with vidix as a normal user.

comment:4 Changed 14 years ago by saschasommer@…

Can someone please post the lspci -v -v -v output?

Changed 14 years ago by chris.coroner@…

output of lspci -v -v -v

comment:5 Changed 14 years ago by chris.coroner@…

comment:6 Changed 14 years ago by saschasommer@…

  • Cc saschasommer@… added
  • Resolution set to fixed
  • Status changed from new to closed

should be fixed in cvs
Please test

Note: See TracTickets for help on using tickets.