Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#591 closed defect (invalid)

Unable to play the CapitalFM (London) radio stream

Reported by: don_scales@… Owned by: r_togni@…
Priority: normal Component: streaming
Version: 1.0pre8 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Capital FM used to work quite happily with MPlayer.
A short while ago, they improved? their internet
streaming and now their new url fails.
The streams work fine with Windows Media Player
but I would really like to get this working again
with MPLayer as I have invested a lot of time in
a Java wrapper for MPlayer.

Their main internet radio page is -
http://rope.icgo.fimc.net/staticweb/onair_players/onair_capitalfm/player/player.htm
The streams seem to be -
http://mediaweb.musicradio.com/playlist.asx?streamid=76
http://mediaweb.musicradio.com/playlist.asx?streamid=1
http://mediaweb.musicradio.com/playlist.asx?streamid=51

Any help is much appreciated.

Don

Change History (4)

comment:1 Changed 13 years ago by don_scales@…

This is the MPlayer o/p -
D:\MPlayer>mplayer http://mediaweb.musicradio.com/playlist.asx?streamid=51
MPlayer 1.0pre8-3.4.2 (C) 2000-2006 MPlayer Team
CPU: AMD Athlon(tm) XP 2800+ (Family: 6, Model: 10, Stepping: 0)
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 0 SSE2: 0
Compiled with runtime CPU detection.

Cannot load font: c:/windows/fonts/arial.ttf

Playing http://mediaweb.musicradio.com/playlist.asx?streamid=51.
STREAM_HTTP(1), URL: http://mediaweb.musicradio.com/playlist.asx?streamid=51
Resolving mediaweb.musicradio.com for AF_INET...
Connecting to server mediaweb.musicradio.com[81.20.48.48]: 80...
STREAM_ASF, URL: http://mediaweb.musicradio.com/playlist.asx?streamid=51
Resolving mediaweb.musicradio.com for AF_INET...
Connecting to server mediaweb.musicradio.com[81.20.48.48]: 80...
size_confirm mismatch!: 22611 28271
Error while parsing chunk header
Failed, exiting.
STREAM_HTTP(2), URL: http://mediaweb.musicradio.com/playlist.asx?streamid=51
Resolving mediaweb.musicradio.com for AF_INET...
Connecting to server mediaweb.musicradio.com[81.20.48.48]: 80...
Cache size set to 320 KBytes
Cache fill: 0.16% (526 bytes)

Exiting... (End of file)

comment:2 Changed 13 years ago by reimar

  • Resolution set to invalid
  • Status changed from new to closed

http://mediaweb.musicradio.com/playlist.asx?streamid=1

This is a playlist not a media file. -playlist sometimes helps, but usually it
is much simpler to just wget it and look inside.
This works for me: http://mediasrv-the.musicradio.com/CapitalRadio
Don't forget to set -bandwidth to something appropriate, you might get the wrong
stream otherwise.

comment:3 Changed 13 years ago by don_scales@…

Many thanks for such a quick solution and thanks
for pointing me at wget - this looks very useful.
Regards
Don

comment:4 Changed 13 years ago by reimar

Actually at least in this case even the -playlist options works correctly,
playing both the advertisement before and the stream itself (had forgotten to
remove some code I added during experimenting).
If you don't know it already this might make things easier (though I never tried
it myself): http://mplayerplug-in.sourceforge.net/

Note: See TracTickets for help on using tickets.