Opened 13 years ago

Last modified 9 years ago

#599 closed defect (invalid)

Problem of recognition of subtitles SSA and ASS

Reported by: vorontsovv@… Owned by: reimar
Priority: normal Component: core
Version: 1.0pre8 Severity: normal
Keywords: Cc: compn
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

The format of subtitles ASS is the same format as SSA simply it is its last
version which has replaced the name but is perfectly read by an old code for
format SSA.

A problem in that that in a file subreader.c in function sub_autodetect the
first 100 lines of a file of subtitles (a cycle " while (j <100) "), in case
of files ASS are analyzed only and SSA is searched "Dialogue" (all the line
long with the text of dialogue begin with it), but! In files of the specified
format this section can begin below 100 lines (because of that that section
with styles very long) therefore MPlayer does not distinguish a file!

Please for autorecognition of a format spend the analysis of all file of
subtitles or even 1000 lines!

Change History (1)

comment:1 Changed 9 years ago by compn

  • Resolution set to invalid
  • Status changed from new to closed, patriotact@gmail.com

if this is still a problem in svn, upload a sample ass file that is not detected properly and reopen this bug.

Note: See TracTickets for help on using tickets.