Opened 13 years ago

Closed 12 years ago

#604 closed defect (duplicate)

compilation error

Reported by: biterek@… Owned by: diego@…
Priority: normal Component: build system
Version: 1.0rc1 Severity: normal
Keywords: Cc: bjrtchsupp@…, corrado91@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Hi

If I compile /gcc-3.4.6,kernel-2.6.18/ without -fomit-frame-pointer flag I have
always error. In 1.0pre8 is OK.


cc -Wdeclaration-after-statement -fno-PIC -march=i486 -mtune=i686 -O2 -
mfpmath=sse -msse2 -mmmx -pipe -DG_DISABLE_ASSERT -D_REENTRANT -
D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/X11/include -I/usr/include/ -I/
usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -I/usr/include/freetype2 -I/usr/
X11R6/include -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/
include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/
glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/freetype2 -I/usr/X11R6/
include -I/usr/include/libpng12 -I. -I./libavutil -I./libavcodec -
DHAVE_AV_CONFIG_H -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_ISOC9X_SOURCE -
I.. -I.. -I../libavutil -Wdeclaration-after-statement -fno-PIC -march=i486 -
mtune=i686 -O2 -mfpmath=sse -msse2 -mmmx -pipe -DG_DISABLE_ASSERT -
D_REENTRANT -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/X11/include -I/
usr/include/ -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -I/usr/include/
freetype2 -I/usr/X11R6/include -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/
include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/
usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/freetype2 -I/
usr/X11R6/include -I/usr/include/libpng12 -c -o h264.o h264.c
h264.c: In function `decode_cabac_residual':
h264.c:6143: warning: passing arg 4 of `decode_significance_8x8_x86' discards
qualifiers from pointer target type
cabac.h: In function `get_cabac_noinline':
cabac.h:513: error: can't find a register in class `GENERAL_REGS' while
reloading `asm'
make[1]: * [h264.o] B³±d 1
make[1]: Opuszczenie katalogu `/tmp/MPlayer-1.0rc1/libavcodec'
make:
* [libavcodec/libavcodec.a] B³±d 2


B.P.

Change History (5)

comment:1 Changed 13 years ago by diego@…

  • Resolution set to invalid
  • Status changed from new to closed

That's a compiler bug.

comment:2 Changed 12 years ago by diego@…

  • Cc corrado91@… added

* Bug 785 has been marked as a duplicate of this bug. *

comment:3 Changed 12 years ago by diego@…

  • Cc bjrtchsupp@… added

* Bug 770 has been marked as a duplicate of this bug. *

comment:4 Changed 12 years ago by diego@…

  • Resolution invalid deleted
  • Status changed from closed to reopened

Reopen bug to mark as duplicate.

comment:5 Changed 12 years ago by diego@…

  • Resolution set to duplicate
  • Status changed from reopened to closed

* This bug has been marked as a duplicate of bug 87 *

Note: See TracTickets for help on using tickets.