Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#611 closed defect (fixed)

Subtitles in mp4

Reported by: mkubicki@… Owned by: reimar
Priority: normal Component: core
Version: 1.0rc1 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I've made a few mp4 video files using Nero Digital, (also using converter form
Nero 7 Ultra Edition). Those files can contain multiple sound tracks or
subtitles. If you use Nero video player: Nero Show Time, you can see and chose
soundtrack or subtitles. There seems to be no way to see them in mplayer. Here
is the log:

MPlayer 1.0rc1-3.4.6 (C) 2000-2006 MPlayer Team
CPU: AMD Athlon(tm) 64 Processor 3200+ (Family: 15, Model: 12, Stepping: 0)
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE SSE2
get_path('codecs.conf') -> '/home/kat/.mplayer/codecs.conf'
Reading /home/kat/.mplayer/codecs.conf: Can't
open '/home/kat/.mplayer/codecs.conf': No such file or directory
Reading /usr/etc/mplayer/codecs.conf: Can't
open '/usr/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf.
CommandLine?: '-v' '/mnt/cdrom/Fist of Fury.mp4'
init_freetype
get_path('font/font.desc') -> '/home/kat/.mplayer/font/font.desc'
font: can't open file: /home/kat/.mplayer/font/font.desc
font: can't open file: /usr/share/mplayer/font/font.desc
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay?
Using nanosleep() timing
get_path('input.conf') -> '/home/kat/.mplayer/input.conf'
Parsing input config file /home/kat/.mplayer/input.conf
Input config file /home/kat/.mplayer/input.conf parsed: 59 binds
get_path('Fist of Fury.mp4.conf') -> '/home/kat/.mplayer/Fist of Fury.mp4.conf'

Playing /mnt/cdrom/Fist of Fury.mp4.
get_path('sub/') -> '/home/kat/.mplayer/sub/'
[file] File size is 821434271 bytes
STREAM: [file] /mnt/cdrom/Fist of Fury.mp4
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
Checking for YUV4MPEG2
ASF_check: not ASF guid!
Checking for NuppelVideo?
Checking for REAL
Checking for SMJPEG
SUB: opened iconv descriptor.
SUB: opened iconv descriptor.
SUB: closed iconv descriptor.
Searching demuxer type for filename /mnt/cdrom/Fist of Fury.mp4 ext: .mp4
Trying demuxer 7 based on filename extension
Checking for MOV
ISO: File Type Major Brand: ISO/IEC 14496-1 (MPEG-4 system) v1
ISO: File Type Minor Version: 0
ISO: File Type Compatible Brand #0: mp41
ISO: File Type Compatible Brand #1: isom
ISO: File Type Compatible Brand #2: ndss
MOV: Movie DATA found!
MOV: Movie header found!
Quicktime/MOV file format detected.
MOV: Movie header (100 bytes): tscale=1000 dur=6134000
MOV: unknown chunk: iods 31


MOV: Track #0:
MOV: Track header!
tkhd len=84 ver=0 flags=0x0 id=1 dur=1 lay=0 vol=0
MOV: unknown chunk: tref 20
MOV: Media stream!
MOV: Media header!
MOV: Handler header: /odsm ()
MOV: unknown handler class: 0x0 ()
MOV: Media info!
MOV: Generic header!
MOV: unknown chunk: dinf 28
MOV: Sample info!
MOV: Description list! (cnt:1)
MOV: desc #0: mp4s (41 bytes)
MOV: Sample duration table! (1 blocks)
MOV: Sample->Chunk mapping table! (1 blocks) (ver:0,flags:0)
MOV: Sample size table! (entries=1 ss=28) (ver:0,flags:0)
MOV: Chunk offset table! (1 chunks)
MOV track #0: 1 chunks, 0 samples
pts=1 scale=1000 time=0.001
Generic track - not completely understood! (id: 0)


MOV: Track #1:
MOV: Track header!
tkhd len=84 ver=0 flags=0x0 id=2 dur=1 lay=0 vol=0
MOV: Media stream!
MOV: Media header!
MOV: Handler header: /sdsm ()
MOV: unknown handler class: 0x0 ()
MOV: Media info!
MOV: Generic header!
MOV: unknown chunk: dinf 28
MOV: Sample info!
MOV: Description list! (cnt:1)
MOV: desc #0: mp4s (51 bytes)
MOV: Sample duration table! (1 blocks)
MOV: Sample->Chunk mapping table! (1 blocks) (ver:0,flags:0)
MOV: Sample size table! (entries=1 ss=30) (ver:0,flags:0)
MOV: Chunk offset table! (1 chunks)
MOV track #1: 1 chunks, 0 samples
pts=1 scale=1000 time=0.001
Generic track - not completely understood! (id: 1)


MOV: Track #2:
MOV: Track header!
tkhd len=84 ver=0 flags=0x0 id=3 dur=6134000 lay=0 vol=0
MOV: Media stream!
MOV: Media header!
MOV: Handler header: /vide () PEG4 video
MOV: unknown handler class: 0x0 ()
MOV: Media info!
MOV: Video header!
MOV: unknown chunk: dinf 28
MOV: Sample info!
MOV: Description list! (cnt:1)
MOV: desc #0: mp4v (175 bytes)
MOV: Sample duration table! (1 blocks)
MOV: Sample->Chunk mapping table! (53899 blocks) (ver:0,flags:0)
MOV: Sample size table! (entries=153350 ss=0) (ver:0,flags:0)
MOV: Chunk offset table! (118838 chunks)
MOV: Syncing samples (keyframes) table! (1267 entries) (ver:0,flags:0)
MOV: unknown chunk: ctts 1192040
MOV track #2: 118838 chunks, 153350 samples
pts=153350000 scale=25000 time=6134.000
==> Found video stream: 2
MOV: Found MPEG4 movie Elementary Stream Descriptor atom (105)!
ESDS MPEG4 version: 0 flags: 0x000000
ESDS MPEG4 ES Descriptor (89Bytes):

-> ESId: 0
-> streamPriority: 0

ESDS MPEG4 Decoder Config Descriptor (77Bytes):

-> objectTypeId: 32
-> streamType: 0x11
-> bufferSizeDB: 0x018580
-> maxBitrate: 2815.488kbit/s
-> avgBitrate: 997.695kbit/s

ESDS MPEG4 Decoder Specific Descriptor (60Bytes)
ESDS MPEG4 Sync Layer Config Descriptor (1Bytes)

-> predefined: 2

Image size: 720 x 304 (0 bpp)
Display size: 720 x 304
Fourcc: mp4v Codec:


MOV: Track #3:
MOV: Track header!
tkhd len=84 ver=0 flags=0x0 id=4 dur=6133968 lay=0 vol=256
MOV: Media stream!
MOV: Media header!
MOV: Handler header: /soun () ero Digital Audio 2-ch Chine
MOV: unknown handler class: 0x0 ()
MOV: Media info!
MOV: Sound header!
MOV: unknown chunk: dinf 28
MOV: Sample info!
MOV: Description list! (cnt:1)
MOV: desc #0: mp4a (67 bytes)
MOV: Sample duration table! (1 blocks)
MOV: Sample->Chunk mapping table! (78381 blocks) (ver:0,flags:0)
MOV: Sample size table! (entries=264168 ss=0) (ver:0,flags:0)
MOV: Chunk offset table! (119077 chunks)
MOV track #3: 119077 chunks, 264168 samples
pts=270508032 scale=44100 time=6133.969
==> Found audio stream: 3
Audio bits: 16 chans: 2 rate: 44100
MOV: Found MPEG4 audio Elementary Stream Descriptor atom (47)!
ESDS MPEG4 version: 0 flags: 0x000000
ESDS MPEG4 ES Descriptor (31Bytes):

-> ESId: 0
-> streamPriority: 0

ESDS MPEG4 Decoder Config Descriptor (19Bytes):

-> objectTypeId: 64
-> streamType: 0x15
-> bufferSizeDB: 0x00013D
-> maxBitrate: 97.696kbit/s
-> avgBitrate: 63.602kbit/s

ESDS MPEG4 Decoder Specific Descriptor (2Bytes)
ESDS MPEG4 Sync Layer Config Descriptor (1Bytes)

-> predefined: 2

Fourcc: mp4a


MOV: Track #4:
MOV: Track header!
tkhd len=84 ver=0 flags=0x0 id=5 dur=6101040 lay=0 vol=0
MOV: Media stream!
MOV: Media header!
MOV: Handler header: /subp () nglish
MOV: unknown handler class: 0x0 ()
MOV: Media info!
MOV: Generic header!
MOV: unknown chunk: dinf 28
MOV: Sample info!
MOV: Description list! (cnt:1)
MOV: desc #0: mp4s (109 bytes)
MOV: Sample duration table! (649 blocks)
MOV: Sample->Chunk mapping table! (1 blocks) (ver:0,flags:0)
MOV: Sample size table! (entries=653 ss=0) (ver:0,flags:0)
MOV: Chunk offset table! (653 chunks)
MOV track #4: 653 chunks, 653 samples
pts=549093601 scale=90000 time=6101.040
Generic track - not completely understood! (id: 4)


Quicktime Clip Info:
MOV: longest streams: A: #3 (264168 samples) V: #2 (153350 samples)
VIDEO: [mp4v] 720x304 0bpp 25.000 fps 0.0 kbps ( 0.0 kbyte/s)
[V] filefmt:7 fourcc:0x7634706D size:720x304 fps:25.00 ftime:=0.0400
get_path('sub/') -> '/home/kat/.mplayer/sub/'
[VO_SDL] Using driver: x11.
X11 opening display: :0.0
vo: X11 color mask: FFFFFF (R:FF0000 G:FF00 B:FF)
vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)
[x11] Detected wm supports NetWM.
[x11] Detected wm supports FULLSCREEN state.
[x11] Detected wm supports ABOVE state.
[x11] Detected wm supports BELOW state.
[x11] Detected wm supports STAYS_ON_TOP state.
[x11] Current fstype setting honours FULLSCREEN STAYS_ON_TOP ABOVE BELOW X
atoms
SDL: deactivating XScreensaver/DPMS
SDL: X11 Resolution 1024x768
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
INFO: libavcodec init OK!
Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
==========================================================================
==========================================================================
Opening audio decoder: [faad] AAC (MPEG2/4 Advanced Audio Coding)
dec_audio: Allocating 4608 bytes for input buffer.
dec_audio: Allocating 49152 + 65536 = 114688 bytes for output buffer.
FAAD: Decoder init done (0Bytes)!
FAAD: Negotiated samplerate: 44100Hz channels: 2
FAAD: got 63kbit/s bitrate from MP4 header!
AUDIO: 44100 Hz, 2 ch, s16le, 63.6 kbit/4.51% (ratio: 7950->176400)
Selected audio codec: [faad] afm: faad (FAAD AAC (MPEG-2/MPEG-4 Audio) decoder)
==========================================================================
Building audio filter chain for 44100Hz/2ch/s16le -> 0Hz/0ch/??...
[libaf] Adding filter dummy
[dummy] Was reinitialized: 44100Hz/2ch/s16le
[dummy] Was reinitialized: 44100Hz/2ch/s16le
alsa-init: requested format: 44100 Hz, 2 channels, 9
alsa-init: using ALSA 1.0.11
alsa-init: setup for 1/2 channel(s)
alsa-init: using device default
alsa-init: pcm opend in blocking mode
alsa-init: chunksize set to 1024
alsa-init: fragcount=8
alsa-init: got buffersize=32768
alsa-init: got period size 1024
alsa: 48000 Hz/2 channels/4 bpf/32768 bytes buffer/Signed 16 bit Little Endian
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
AO: Description: ALSA-0.9.x-1.x audio output
AO: Author: Alex Beregszaszi, Zsolt Barat <joy@…>
AO: Comment: under developement
Building audio filter chain for 44100Hz/2ch/s16le -> 48000Hz/2ch/s16le...
[dummy] Was reinitialized: 44100Hz/2ch/s16le
[libaf] Adding filter lavcresample
[dummy] Was reinitialized: 48000Hz/2ch/s16le
[dummy] Was reinitialized: 48000Hz/2ch/s16le
Starting playback...
[libaf] Reallocating memory in module lavcresample, old len = 0, new len =
32768
[ffmpeg] aspect_ratio: 2.368421
VDec: vo config request - 720 x 304 (preferred colorspace: Planar YV12)
Trying filter chain: vo
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 2.37:1 - prescaling to correct movie aspect.
VO Config (720x304->720x304,flags=1,'MPlayer',0x32315659)
VO: [sdl] 720x304 => 720x304 Planar YV12 [fs]
VO: Description: SDL YUV/RGB/BGR renderer (SDL v1.1.7+ only!)
VO: Author: Ryan C. Gordon <icculus@…>, Felix Buenemann
<atmosfear@…>
SDL: Using 0x32315659 (Planar YV12) image format
SDL: using hardware-surface
SDL: setting zoomed fullscreen without modeswitching
[VO_SDL] Info - please use -vm or -zoom to switch to the best resolution.
* [vo] Allocating (slices) mp_image_t, 720x304x12bpp YUV planar, 328320 bytes

Attachments (3)

movsubstest.diff (1.6 KB) - added by reimar 13 years ago.
hack for testing
movsubstest.2.diff (1.7 KB) - added by reimar 13 years ago.
fixed sync
subs1.jpg (112.9 KB) - added by mkubicki@… 13 years ago.
mp4 subtitles

Download all attachments as: .zip

Change History (25)

comment:1 Changed 13 years ago by reimar

Please upload a sample file to ftp://upload.mplayerhq.hu/MPlayer/incoming.

comment:2 Changed 13 years ago by reimar

* Bug 612 has been marked as a duplicate of this bug. *

comment:3 Changed 13 years ago by compn

i tried unsupported-embedded-subs-2.mp4 in quicktime 7.1 but i dont know how to
load the subtitles.

comment:4 Changed 13 years ago by mkubicki@…

(In reply to comment #3)

i tried unsupported-embedded-subs-2.mp4 in quicktime 7.1 but i dont know how to
load the subtitles.

The thing is that you need Nero Show Time to see them. If there are multiple
subtitles (multi lang.) you can chose between them. I have no idea how to
display them in quicktime player. But if they are in mp4 files I've thought
would be nice to see them in mplayer :)

comment:6 Changed 13 years ago by compn

can we also call this bug 'subtitles in mov' too?

i found a captions (subtitles) file that works in quicktime.
http://www.pbs.org/wgbh/nova/elegant/media2/nova_eu_3012c01_caps.mov

which would be nice to be supported in mplayer too :)

uploaded to /incoming/nova_eu_3012c01_caps.mov-captions-subtitles-in-quicktime.
mov

comment:7 Changed 13 years ago by reimar

This should be a separate bug. The Nero subtitles are bitmap subtitles,
your .mov sample uses text subtitles.

Changed 13 years ago by reimar

hack for testing

comment:8 Changed 13 years ago by reimar

Here is a quick hack for the text subtitles (not the Nero ones). Hard to say if
it works right (besides the sync being off), since there are only made-up
samples so far it seems.

Changed 13 years ago by reimar

fixed sync

comment:9 Changed 13 years ago by reimar

This patch should fix the desync mostly (to the same level as mkv).

comment:10 Changed 13 years ago by reimar

  • attachments.isobsolete changed from 0 to 1

comment:11 Changed 13 years ago by reimar

I forgot, concerning the original bug: can you show us how the subtitles are
supposed to look like? E.g. by providing screenshots?

Changed 13 years ago by mkubicki@…

mp4 subtitles

comment:12 Changed 13 years ago by mkubicki@…

comment:13 Changed 13 years ago by reimar

This adds support for both formats, though it is incomplete (e.g. palette
support missing).
http://lists.mplayerhq.hu/pipermail/mplayer-dev-eng/2006-November/047350.html

comment:14 Changed 13 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

Applied. Still has some issues, but no idea if they will ever be fixed, this
kind of files is still really rare.

comment:15 Changed 13 years ago by reimar

Palette issue fixed as well in SVN r20995, I think they now look really right.

comment:16 Changed 13 years ago by mkubicki@…

(In reply to comment #14)

Palette issue fixed as well in SVN r20995, I think they now look really right.

I've got SVN ver. from 18.11.2006, but I can't see any subtitles...

comment:17 Changed 13 years ago by reimar

You must select them of course, e.g. with -sid 2. Unfortunately subtitle
switching via 'j' key does not work yet.

comment:18 Changed 13 years ago by mkubicki@…

(In reply to comment #16)

You must select them of course, e.g. with -sid 2. Unfortunately subtitle
switching via 'j' key does not work yet.

I've got another mp4 file and mplayer can't find subtitles. It is impossible to
select subt. with any options. Unfortunately the file is too big to upload.

comment:19 Changed 13 years ago by reimar

Then please give a full mplayer -v log at least.

comment:20 Changed 12 years ago by mkubicki@…

(In reply to comment #18)

kat@slack11:~$ mplayer -v /mnt/cdrom/Fist\ of\ Fury.mp4
MPlayer dev-SVN-r21037-3.4.6 (C) 2000-2006 MPlayer Team
CPU: AMD Athlon(tm) 64 Processor 3200+ (Family: 15, Model: 12, Stepping: 0)
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE SSE2
get_path('codecs.conf') -> '/home/kat/.mplayer/codecs.conf'
Reading /home/kat/.mplayer/codecs.conf: Can't open
'/home/kat/.mplayer/codecs.conf': No such file or directory
Reading /usr/etc/mplayer/codecs.conf: Can't open '/usr/etc/mplayer/codecs.conf':
No such file or directory
Using built-in default codecs.conf.
CommandLine?: '-v' '/mnt/cdrom/Fist of Fury.mp4'
init_freetype
get_path('font/font.desc') -> '/home/kat/.mplayer/font/font.desc'
font: can't open file: /home/kat/.mplayer/font/font.desc
font: can't open file: /usr/share/mplayer/font/font.desc
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay?
get_path('fonts') -> '/home/kat/.mplayer/fonts'
Using nanosleep() timing
get_path('input.conf') -> '/home/kat/.mplayer/input.conf'
Parsing input config file /home/kat/.mplayer/input.conf
Input config file /home/kat/.mplayer/input.conf parsed: 59 binds
get_path('Fist of Fury.mp4.conf') -> '/home/kat/.mplayer/Fist of Fury.mp4.conf'

Playing /mnt/cdrom/Fist of Fury.mp4.
get_path('sub/') -> '/home/kat/.mplayer/sub/'
[file] File size is 821434271 bytes
STREAM: [file] /mnt/cdrom/Fist of Fury.mp4
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
Checking for YUV4MPEG2
ASF_check: not ASF guid!
Checking for NuppelVideo?
Checking for REAL
Checking for SMJPEG
SUB: opened iconv descriptor.
SUB: opened iconv descriptor.
SUB: closed iconv descriptor.
Searching demuxer type for filename /mnt/cdrom/Fist of Fury.mp4 ext: .mp4
Trying demuxer 7 based on filename extension
Checking for MOV
ISO: File Type Major Brand: ISO/IEC 14496-1 (MPEG-4 system) v1
ISO: File Type Minor Version: 0
ISO: File Type Compatible Brand #0: mp41
ISO: File Type Compatible Brand #1: isom
ISO: File Type Compatible Brand #2: ndss
MOV: Movie DATA found!
MOV: Movie header found!
Quicktime/MOV file format detected.
MOV: Movie header (100 bytes): tscale=1000 dur=6134000
MOV: unknown chunk: iods 31


MOV: Track #0:
MOV: Track header!
tkhd len=84 ver=0 flags=0x0 id=1 dur=1 lay=0 vol=0
MOV: unknown chunk: tref 20
MOV: Media stream!
MOV: Media header!
MOV: Handler header: /odsm ()
MOV: unknown handler class: 0x0 ()
MOV: Media info!
MOV: Generic header!
MOV: unknown chunk: dinf 28
MOV: Sample info!
MOV: Description list! (cnt:1)
MOV: desc #0: mp4s (41 bytes)
MOV: Sample duration table! (1 blocks)
MOV: Sample->Chunk mapping table! (1 blocks) (ver:0,flags:0)
MOV: Sample size table! (entries=1 ss=28) (ver:0,flags:0)
MOV: Chunk offset table! (1 chunks)
MOV track #0: 1 chunks, 0 samples
pts=1 scale=1000 time=0.001


MOV: Track #1:
MOV: Track header!
tkhd len=84 ver=0 flags=0x0 id=2 dur=1 lay=0 vol=0
MOV: Media stream!
MOV: Media header!
MOV: Handler header: /sdsm ()
MOV: unknown handler class: 0x0 ()
MOV: Media info!
MOV: Generic header!
MOV: unknown chunk: dinf 28
MOV: Sample info!
MOV: Description list! (cnt:1)
MOV: desc #0: mp4s (51 bytes)
MOV: Sample duration table! (1 blocks)
MOV: Sample->Chunk mapping table! (1 blocks) (ver:0,flags:0)
MOV: Sample size table! (entries=1 ss=30) (ver:0,flags:0)
MOV: Chunk offset table! (1 chunks)
MOV track #1: 1 chunks, 0 samples
pts=1 scale=1000 time=0.001


MOV: Track #2:
MOV: Track header!
tkhd len=84 ver=0 flags=0x0 id=3 dur=6134000 lay=0 vol=0
MOV: Media stream!
MOV: Media header!
MOV: Handler header: /vide () PEG4 video
MOV: unknown handler class: 0x0 ()
MOV: Media info!
MOV: Video header!
MOV: unknown chunk: dinf 28
MOV: Sample info!
MOV: Description list! (cnt:1)
MOV: desc #0: mp4v (175 bytes)
MOV: Sample duration table! (1 blocks)
MOV: Sample->Chunk mapping table! (53899 blocks) (ver:0,flags:0)
MOV: Sample size table! (entries=153350 ss=0) (ver:0,flags:0)
MOV: Chunk offset table! (118838 chunks)
MOV: Syncing samples (keyframes) table! (1267 entries) (ver:0,flags:0)
MOV: unknown chunk: ctts 1192040
MOV track #2: 118838 chunks, 153350 samples
pts=153350000 scale=25000 time=6134.000
==> Found video stream: 2
MOV: Found MPEG4 movie Elementary Stream Descriptor atom (105)!
ESDS MPEG4 version: 0 flags: 0x000000
ESDS MPEG4 ES Descriptor (89Bytes):

-> ESId: 0
-> streamPriority: 0

ESDS MPEG4 Decoder Config Descriptor (77Bytes):

-> objectTypeId: 32
-> streamType: 0x11
-> bufferSizeDB: 0x018580
-> maxBitrate: 2815.488kbit/s
-> avgBitrate: 997.695kbit/s

ESDS MPEG4 Decoder Specific Descriptor (60Bytes)
ESDS MPEG4 Sync Layer Config Descriptor (1Bytes)

-> predefined: 2

Image size: 720 x 304 (0 bpp)
Display size: 720 x 304
Fourcc: mp4v Codec:


MOV: Track #3:
MOV: Track header!
tkhd len=84 ver=0 flags=0x0 id=4 dur=6133968 lay=0 vol=256
MOV: Media stream!
MOV: Media header!
MOV: Handler header: /soun () ero Digital Audio 2-ch Chine
MOV: unknown handler class: 0x0 ()
MOV: Media info!
MOV: Sound header!
MOV: unknown chunk: dinf 28
MOV: Sample info!
MOV: Description list! (cnt:1)
MOV: desc #0: mp4a (67 bytes)
MOV: Sample duration table! (1 blocks)
MOV: Sample->Chunk mapping table! (78381 blocks) (ver:0,flags:0)
MOV: Sample size table! (entries=264168 ss=0) (ver:0,flags:0)
MOV: Chunk offset table! (119077 chunks)
MOV track #3: 119077 chunks, 264168 samples
pts=270508032 scale=44100 time=6133.969
==> Found audio stream: 3
Audio bits: 16 chans: 2 rate: 44100
MOV: Found MPEG4 audio Elementary Stream Descriptor atom (47)!
ESDS MPEG4 version: 0 flags: 0x000000
ESDS MPEG4 ES Descriptor (31Bytes):

-> ESId: 0
-> streamPriority: 0

ESDS MPEG4 Decoder Config Descriptor (19Bytes):

-> objectTypeId: 64
-> streamType: 0x15
-> bufferSizeDB: 0x00013D
-> maxBitrate: 97.696kbit/s
-> avgBitrate: 63.602kbit/s

ESDS MPEG4 Decoder Specific Descriptor (2Bytes)
ESDS MPEG4 Sync Layer Config Descriptor (1Bytes)

-> predefined: 2

Fourcc: mp4a


MOV: Track #4:
MOV: Track header!
tkhd len=84 ver=0 flags=0x0 id=5 dur=6101040 lay=0 vol=0
MOV: Media stream!
MOV: Media header!
MOV: Handler header: /subp () nglish
MOV: unknown handler class: 0x0 ()
MOV: Media info!
MOV: Generic header!
MOV: unknown chunk: dinf 28
MOV: Sample info!
MOV: Description list! (cnt:1)
MOV: desc #0: mp4s (109 bytes)
MOV: Sample duration table! (649 blocks)
MOV: Sample->Chunk mapping table! (1 blocks) (ver:0,flags:0)
MOV: Sample size table! (entries=653 ss=0) (ver:0,flags:0)
MOV: Chunk offset table! (653 chunks)
MOV track #4: 653 chunks, 653 samples
pts=549093601 scale=90000 time=6101.040


Quicktime Clip Info:
MOV: longest streams: A: #3 (264168 samples) V: #2 (153350 samples)
VIDEO: [mp4v] 720x304 0bpp 25.000 fps 0.0 kbps ( 0.0 kbyte/s)
[V] filefmt:7 fourcc:0x7634706D size:720x304 fps:25.00 ftime:=0.0400
get_path('sub/') -> '/home/kat/.mplayer/sub/'
[VO_SDL] Using driver: x11.
X11 opening display: :0.0
vo: X11 color mask: FFFFFF (R:FF0000 G:FF00 B:FF)
vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)
[x11] Detected wm supports NetWM.
[x11] Detected wm supports FULLSCREEN state.
[x11] Detected wm supports ABOVE state.
[x11] Detected wm supports BELOW state.
[x11] Detected wm supports STAYS_ON_TOP state.
[x11] Current fstype setting honours FULLSCREEN STAYS_ON_TOP ABOVE BELOW X atoms
SDL: deactivating XScreensaver/DPMS
SDL: X11 Resolution 1024x768
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
INFO: libavcodec init OK!
Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
==========================================================================
==========================================================================
Opening audio decoder: [faad] AAC (MPEG2/4 Advanced Audio Coding)
dec_audio: Allocating 4608 bytes for input buffer.
dec_audio: Allocating 49152 + 65536 = 114688 bytes for output buffer.
FAAD: Decoder init done (0Bytes)!
FAAD: Negotiated samplerate: 44100Hz channels: 2
FAAD: got 63kbit/s bitrate from MP4 header!
AUDIO: 44100 Hz, 2 ch, s16le, 63.6 kbit/4.51% (ratio: 7950->176400)
Selected audio codec: [faad] afm: faad (FAAD AAC (MPEG-2/MPEG-4 Audio) decoder)
==========================================================================
Building audio filter chain for 44100Hz/2ch/s16le -> 0Hz/0ch/??...
[libaf] Adding filter dummy
[dummy] Was reinitialized: 44100Hz/2ch/s16le
[dummy] Was reinitialized: 44100Hz/2ch/s16le
alsa-init: requested format: 44100 Hz, 2 channels, 9
alsa-init: using ALSA 1.0.11
alsa-init: setup for 1/2 channel(s)
alsa-init: using device default
alsa-init: pcm opened in blocking mode
alsa-init: chunksize set to 1024
alsa-init: fragcount=8
alsa-init: got buffersize=32768
alsa-init: got period size 1024
alsa: 48000 Hz/2 channels/4 bpf/32768 bytes buffer/Signed 16 bit Little Endian
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
AO: Description: ALSA-0.9.x-1.x audio output
AO: Author: Alex Beregszaszi, Zsolt Barat <joy@…>
AO: Comment: under developement
Building audio filter chain for 44100Hz/2ch/s16le -> 48000Hz/2ch/s16le...
[dummy] Was reinitialized: 44100Hz/2ch/s16le
[libaf] Adding filter lavcresample
[dummy] Was reinitialized: 48000Hz/2ch/s16le
[dummy] Was reinitialized: 48000Hz/2ch/s16le
Starting playback...
[libaf] Reallocating memory in module lavcresample, old len = 0, new len = 32768
[ffmpeg] aspect_ratio: 2.368421
VDec: vo config request - 720 x 304 (preferred colorspace: Planar YV12)
Trying filter chain: vo
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 2.37:1 - prescaling to correct movie aspect.
VO Config (720x304->720x304,flags=1,'MPlayer',0x32315659)
VO: [sdl] 720x304 => 720x304 Planar YV12 [fs]
VO: Description: SDL YUV/RGB/BGR renderer (SDL v1.1.7+ only!)
VO: Author: Ryan C. Gordon <icculus@…>, Felix Buenemann
<atmosfear@…>
SDL: Using 0x32315659 (Planar YV12) image format
SDL: using hardware-surface
SDL: setting zoomed fullscreen without modeswitching
[VO_SDL] Info - please use -vm or -zoom to switch to the best resolution.
* [vo] Allocating (slices) mp_image_t, 720x304x12bpp YUV planar, 328320 bytes
Uninit audio filters...-0.013 ct: 0.021 25/ 25 11% 0% 1.2% 0 0
[libaf] Removing filter lavcresample
[libaf] Removing filter dummy
Uninit audio: faad
FAAD: Closing decoder!
Uninit video: ffmpeg
SDL: activating XScreensaver/DPMS
alsa-uninit: pcm closed
vo: uninit ...

Exiting... (Quit)

comment:21 Changed 12 years ago by reimar

I don't see anything wrong with that. Of course you must use -sid 4 with this
file, since the fourth stream is the subtitle stream, did you do that? (With
latest SVN you can also use the 'j' key to switch between subtitles and switch
them on/off).

comment:22 Changed 12 years ago by mkubicki@…

I've had to press "j" twice to see them.
Thanks a lot.

Note: See TracTickets for help on using tickets.