Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#616 closed defect (invalid)

error using libx264

Reported by: heirpixel@… Owned by: dominik@…
Priority: important Component: RPMs
Version: 1.0pre8 Severity: blocker
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Distro: Fedora Core VI
Kernel: 2.6.18-1.2798.fc6
Proc: Intel P4-HT 3.00

When trying to run mplayer, << [root@localhost mplayer]# mplayer >>
I get back the following error:
<< mplayer: error while loading shared libraries: /usr/lib/libx264.so.54: cannot
restore segment prot after reloc: Permission denied >>

x264 was automatically installed as a dependency via Yum.

Change History (3)

comment:1 Changed 13 years ago by dominik@…

  • Component changed from ve to RPMs
  • Owner changed from r_togni@… to dominik@…

Which repository did you use? greysector.net?

comment:2 Changed 13 years ago by heirpixel@…

I use rpm.livna.org repo.

comment:3 Changed 13 years ago by dominik@…

  • Resolution set to invalid
  • Status changed from new to closed

Looks like selinux issue. Try

chcon system_u:object_r:textrel_shlib_t /usr/lib/libx264.so.54

However, this is not MPlayer bug, but either a bug in x264 or missing policy bit
in Fedora's selinux. See also http://bugzilla.livna.org/show_bug.cgi?id=1243

Please report this to x264 authors.

Note: See TracTickets for help on using tickets.