Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#62 closed defect (wontfix)

MPlayer 1.0pre5 doesnt compile with new live.com

Reported by: a.l.m.buxey@… Owned by: moritz@…
Priority: normal Component: demuxer
Version: 1.0pre5 Severity: major
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

newest live.com (live.2004.08.13.tar.gz) breaks the compilation of
MPlayer. I traced this to the new API of live.com - and a trivial fix to
MPlayer source code stop this.

Change line 410 of libmpdemux/demux_rtp.cpp to read

env->reclaim(); delete scheduler;

alternatively, to keep compatability with older live.com (do you want to??)
you can always do a fancier thing, define at the top of the code

#if (LIVEMEDIA_LIBRARY_VERSION_INT < 1089936000)
#define RECLAIM_ENV(env) delete (env)
#else
#define RECLAIM_ENV(env) (env)->reclaim()
#endif

and then live 415 (its now increased ;-) ) becomes:

RECLAIM_ENV(p_sys->env); delete scheduler;

hope this helps

Change History (1)

comment:1 Changed 15 years ago by r_togni@…

  • Resolution set to wontfix
  • Status changed from new to closed

It's a known problem, something was changed in live.com shortly after pre5 release.
CVS is fixed to compile with latest live.com (cvs won't work with old live.com),
but pre5 fails.
Your fix is correct, but won't help because pre5 is already released and won't
be affected by new commits.

The problem will be fixed in pre6.

For pre5 you have to get an older version of live.com (but their site only
offers the latest version, that's why we didn't bother to make current cvs
compile with old versions) or patch it manually so that it compiles with current
live.com

Note: See TracTickets for help on using tickets.