Opened 13 years ago

Last modified 9 years ago

#626 closed defect (worksforme)

mencoder: error writing file on a UNC path

Reported by: mplayerhq@… Owned by: beastd
Priority: normal Component: vo
Version: 1.0rc1 Severity: normal
Keywords: Cc: compn
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

When specifying the -o option with a UNC file path, the encoder stops with the
message:

[...]
Writing header...

10.54.88.11\test\outputFile.flv: Error writing file.

Exiting...

Command line used:
mencoder.exe "
10.54.88.11\test\input.mpg" -endpos 120.000 -sws 2 -vf
scale=480:272:0:0:0.00:0.50,harddup -ofps 25 -of lavf -lavfopts
i_certify_that_my_video_stream_does_not_use_b_frames:format=flv -ovc lavc
-lavcopts
vcodec=flv:vbitrate=350:vqmin=2:vqmax=31:mbd=1:subq=8:keyint=250:aspect=16/9 -af
resample=22050:0:0 -oac mp3lame -lameopts
vbr=2:q=6:aq=2:highpassfreq=-1:lowpassfreq=-1:mode=3 -o
"
10.54.88.11\test\output.flv"

Change History (2)

comment:1 Changed 13 years ago by mplayerhq@…

ffmpeg SVN-r6830 does not have this bug.

comment:2 Changed 9 years ago by compn

  • Resolution set to worksforme
  • Status changed from new to closed, patriotact@gmail.com

E:\>mencoder LudicrousDiversion77.avi -oac mp3lame -lameopts cbr:br=128 -lavcopts vcodec=flv -of lavf -ovc lavc -frames 3 -ss 5 -vf harddup -o "
10.0.0.2\e$\out.flv"
MEncoder Sherpya-SVN-r32492-4.2.5 (C) 2000-2010 MPlayer Team
160 audio & 353 video codecs
success: format: 0 data: 0x0 - 0xaa26e58
AVI file format detected.
[aviheader] Video stream found, -vid 0
[aviheader] Audio stream found, -aid 1
VIDEO: [divx] 480x384 24bpp 30.000 fps 711.6 kbps (86.9 kbyte/s)
[V] filefmt:3 fourcc:0x78766964 size:480x384 fps:30.000 ftime:=0.0333
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 44100 Hz, 2 ch, s16le, 128.0 kbit/9.07% (ratio: 16000->176400)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
MUXER_LAVF *
REMEMBER: MEncoder's libavformat muxing is presently broken and can generate
INCORRECT files in the presence of B-frames. Moreover, due to bugs MPlayer
will play these INCORRECT files as if nothing were wrong!
*
OK, exit.
Opening video filter: [expand osd=1]
Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
Opening video filter: [harddup]
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
==========================================================================
MP3 audio selected.
Movie-Aspect is 1.25:1 - prescaling to correct movie aspect.
videocodec: libavcodec (480x384 fourcc=31564c46 [FLV1])
Fontconfig error: Cannot load default config file
Fontconfig failed to select a font. Trying without fontconfig...
Fontconfig failed to select a font. Trying without fontconfig...
VIDEO CODEC ID: 22
AUDIO CODEC ID: 15001, TAG: 0
Writing header...
[flv @ 0102c758]Codec for stream 0 does not use global headers but container format requires global

headers

[flv @ 0102c758]Codec for stream 1 does not use global headers but container format requires global

headers

Pos: 0.1s 3f ( 0%) 0.00fps Trem: 0min 6mb A-V:0.007 [0:0]

Flushing video frames.
Writing index...

Video stream: 1324.160 kbit/s (165519 B/s) size: 16552 bytes 0.100 secs 3 frames

Audio stream: 127.910 kbit/s (15988 B/s) size: 1253 bytes 0.078 secs

works 4 me.

Note: See TracTickets for help on using tickets.