Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#627 closed defect (fixed)

MPlayer will not build under Solaris

Reported by: lostpassword@… Owned by: diego@…
Priority: normal Component: build system
Version: 1.0rc1 Severity: blocker
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Hi,

I would like to report that I am unable to build Mplayer 1.0rc1 under Solaris
Express (Solaris 11)

Some info:
==========

bash-3.00$ uname -a
SunOS solaris.schlossadler.net 5.11 snv_48 i86pc i386 i86pc

bash-3.00$ gcc --version
gcc (GCC) 3.4.3 (csl-sol210-3_4-20050802)
Copyright (C) 2004 Free Software Foundation, Inc.

=================

1st problem:
============

./configure script will not finish, it dies when trying to look for
DirectFB?

error as follows:
Checking for Samba support (libsmbclient) ... yes
Checking for 3dfx ... no
Checking for tdfxfb ... no
Checking for s3fb ... no
Checking for tdfxvid ... no
Checking for tga ... yes
Checking for DirectFB ... ./configure: syntax error at line 3756:
`_dfb_version=$' unexpected

There is no --disable-directfb option, the only way to circumvent this error is
to hack up the configure script and completely remove the check for DirectFB.

Then there are other errors buring the build (not related to DirectFB).

ranlib libass.a
gmake[1]: Leaving directory
`/export/home/alex/www_downloaded/mpl/MPlayer-1.0rc1/libass'
gcc -Wdeclaration-after-statement -fno-PIC -O4 -march=prescott -mtune=prescott
-pipe -ffast-math -fomit-frame-pointer -D_LARGEFILE_SOURCE
-D_FILE_OFFSET_BITS=64 -I/usr/include -I/usr/sfw/include/freetype2
-I/usr/sfw/include -I. -I./libavutil -I./libavcodec -o mplayer mplayer.o
m_property.o mp_msg.o asxparser.o codec-cfg.o cpudetect.o edl.o find_sub.o
m_config.o m_option.o m_struct.o parser-cfg.o playtree.o playtreeparser.o
spudec.o sub_cc.o subreader.o vobsub.o unrarlib.o mixer.o parser-mpcmd.o
subopt-helper.o libvo/libvo.a libao2/libao2.a input/libinput.a
libmpcodecs/libmpcodecs.a libaf/libaf.a libmpdemux/libmpdemux.a stream/stream.a
libswscale/libswscale.a osdep/libosdep.a -Llibmpdvdkit2 -lmpdvdkit
libavformat/libavformat.a libavcodec/libavcodec.a libavutil/libavutil.a
libpostproc/libpostproc.a -ltheora -logg -lpng -lz -lz -ljpeg
-lspeex -ltermcap -lsocket -lnsl -lcdio_paranoia -lcdio_cdda -lcdio
-lsmbclient -lposix4 -lkstat -lm libfaad2/libfaad2.a
mp3lib/libMP3.a liba52/liba52.a libmpeg2/libmpeg2.a tremor/libvorbisidec.a
libass/libass.a -lfontconfig -L/usr/sfw/lib -R/usr/sfw/lib -lfreetype -lz -lGL

-lXext -lX11 -lsocket -lnsl -lsocket -lnsl -L/usr/lib -lesd

-laudiofile -lm -lresolv -lnsl -lsocket
Undefined first referenced

symbol in file

read_toc stream/stream.a(stream_cddb.o)
ld: fatal: Symbol referencing errors. No output written to mplayer
collect2: ld returned 1 exit status
gmake: * [mplayer] Error 1

I am available to test any suggested fixes if you dont have access to a suitable
solaris machine.

Alex.

Change History (13)

comment:1 Changed 13 years ago by diego@…

  • Priority changed from very important to normal
  • Status changed from new to assigned
  • Summary changed from Mplayer will not build under Solaris to MPlayer will not build under Solaris

(In reply to comment #0)

1st problem:
============

./configure script will not finish, it dies when trying to look for
DirectFB?

error as follows:
Checking for DirectFB ... ./configure: syntax error at line 3756:
`_dfb_version=$' unexpected

What is on that line?

There is no --disable-directfb option,

There is, look closer.

Undefined first referenced

symbol in file

read_toc stream/stream.a(stream_cddb.o)

--disable-cdparanoia

comment:2 Changed 13 years ago by reimar

I also should build with latest SVN, but cddb:// will still not work, because I
do not know if OpenBSD or FreeBSD-style toc-reading is needed in
stream/stream_cddb.c

comment:3 Changed 13 years ago by lostpassword@…

--disable-cdparanoia used, same error persists.

ranlib libass.a
gmake[1]: Leaving directory
`/export/home/alex/www_downloaded/mpl/MPlayer-1.0rc1/libass'
gcc -Wdeclaration-after-statement -fno-PIC -O4 -march=prescott -mtune=prescott
-pipe -ffast-math -fomit-frame-pointer -D_LARGEFILE_SOURCE
-D_FILE_OFFSET_BITS=64 -I/usr/include -I/usr/sfw/include/freetype2
-I/usr/sfw/include -I. -I./libavutil -I./libavcodec -o mplayer mplayer.o
m_property.o mp_msg.o asxparser.o codec-cfg.o cpudetect.o edl.o find_sub.o
m_config.o m_option.o m_struct.o parser-cfg.o playtree.o playtreeparser.o
spudec.o sub_cc.o subreader.o vobsub.o unrarlib.o mixer.o parser-mpcmd.o
subopt-helper.o libvo/libvo.a libao2/libao2.a input/libinput.a
libmpcodecs/libmpcodecs.a libaf/libaf.a libmpdemux/libmpdemux.a stream/stream.a
libswscale/libswscale.a osdep/libosdep.a -Llibmpdvdkit2 -lmpdvdkit
libavformat/libavformat.a libavcodec/libavcodec.a libavutil/libavutil.a
libpostproc/libpostproc.a -ltheora -logg -lpng -lz -lz -ljpeg
-lspeex -ltermcap -lsocket -lnsl -lcdio_paranoia -lcdio_cdda -lcdio
-lsmbclient -lposix4 -lkstat -lm libfaad2/libfaad2.a
mp3lib/libMP3.a liba52/liba52.a libmpeg2/libmpeg2.a tremor/libvorbisidec.a
libass/libass.a -lfontconfig -L/usr/sfw/lib -R/usr/sfw/lib -lfreetype -lz -lGL

-lXext -lX11 -lsocket -lnsl -lsocket -lnsl -L/usr/lib -lesd

-laudiofile -lm -lresolv -lnsl -lsocket
Undefined first referenced

symbol in file

read_toc stream/stream.a(stream_cddb.o)
ld: fatal: Symbol referencing errors. No output written to mplayer
collect2: ld returned 1 exit status
gmake: * [mplayer] Error 1

comment:4 Changed 13 years ago by lostpassword@…

bash-3.00$ ./configure --help |grep fb

--enable-fbdev build with FBDev render support [autodetect]
--enable-tdfxfb build with tdfxfb (Voodoo 3/banshee) support [disable]
--enable-s3fb build with s3fb (S3 ViRGE) support [disable]
--enable-directfb build with DirectFB support [autodetect]

Please confirm location of a working --disable-directfb option.

using it still results in

Checking for s3fb ... no
Checking for tdfxvid ... no
Checking for tga ... yes
Checking for DirectFB ... ./configure: syntax error at line 3756:
`_dfb_version=$' unexpected

Line 3756 contains:

_dfb_version=$(dfb_version $_dfb_major $_dfb_minor $_dfb_micro)

comment:5 Changed 13 years ago by diego@…

(In reply to comment #3)

--disable-cdparanoia used, same error persists.

Undefined first referenced

symbol in file

read_toc stream/stream.a(stream_cddb.o)

Then also --disable-libcdio.

comment:6 Changed 13 years ago by diego@…

  • Resolution set to fixed
  • Status changed from assigned to closed

(In reply to comment #4)

bash-3.00$ ./configure --help |grep fb

--enable-fbdev build with FBDev render support [autodetect]
--enable-tdfxfb build with tdfxfb (Voodoo 3/banshee) support [disable]
--enable-s3fb build with s3fb (S3 ViRGE) support [disable]
--enable-directfb build with DirectFB support [autodetect]

Please confirm location of a working --disable-directfb option.

RTFS.

Line 3756 contains:

_dfb_version=$(dfb_version $_dfb_major $_dfb_minor $_dfb_micro)

Your shell has problems with $() constructs. Solaris, *sigh*. Anyway, this
line is no longer present in Subversion HEAD, case closed.

comment:7 Changed 13 years ago by lostpassword@…

not all of us run linux, no need to be rude.
and no, the solution isnt BLATENTLY obvious for
the average user when coming across the problems I did.

What impact will --disable-libcdio --disable-cdparanoia have?
Does this mean audio/vcd's cannot be played?

thanks anyway.

comment:8 Changed 13 years ago by reimar

not all of us run linux, no need to be rude.

I see nothing that seems rude to me, and it sure was not meant to be.
Though you did mangle two bugs into one report and did not test latest SVN in
which both these problems aren't fixed, so it is quite naturally if a bit of
annoyance show through our replies. Please do not take this personally.
And if you have time, please test latest SVN, with libcdio, mplayer cdda://
should work, mplayer cddb:// probably will not, if somebody is ready to test a
patch please say so (this problems exists with at least both MacOSX and Solaris,
so testers for both are needed, I think it should be easily fixable for MacOSX,
but probably not for Solaris).

comment:9 Changed 13 years ago by diego@…

(In reply to comment #7)

not all of us run linux, no need to be rude.

That's no excuse for Solaris system tools to remain in the stone age.

And what I take as rude here is you not believing me when I told you about
--disable-directfb. You obviously hadn't tried the option. I happen to be the
maintainer of configure and know what I'm talking about.

What impact will --disable-libcdio --disable-cdparanoia have?
Does this mean audio/vcd's cannot be played?

audio CDs

comment:10 Changed 13 years ago by lostpassword@…

And what I take as rude here is you not believing me when I told you about
--disable-directfb. You obviously hadn't tried the option. I happen to be >the
maintainer of configure and know what I'm talking about.

I had tried it. Before posting here, as a guess, even though
./configure --help only lists a --enable-directfb option, I had
made a guess and tried it, but to no avail. There was no "disbelief"
in what you said, it was more that I wasnt convinced it was going to help,
because of things I had already tried, so if I have offended you in
some way, then I apologise.

Ok, well please tell me what tools in Solaris are "stone age",
I will be happy to relay it up to Sun Microsystems and the solaris
newsgroups.

comment:11 Changed 13 years ago by diego@…

(In reply to comment #10)

Ok, well please tell me what tools in Solaris are "stone age",
I will be happy to relay it up to Sun Microsystems and the solaris
newsgroups.

The default shell and the basic system tools. You have just seen an example.
The default shell on Solaris 11 cannot cope with $(). Browse the Subversion log
for configure, you will find more Solaris annoyances.

comment:12 Changed 13 years ago by lostpassword@…

(In reply to comment #11)

The default shell and the basic system tools. You have just seen an example.
The default shell on Solaris 11 cannot cope with $(). Browse the Subversion log
for configure, you will find more Solaris annoyances.

when you refer to the default shell, would you be referring to implementation
of /bin/sh on solaris?

comment:13 Changed 13 years ago by diego@…

(In reply to comment #12)

(In reply to comment #11)

The default shell and the basic system tools. You have just seen an example.
The default shell on Solaris 11 cannot cope with $(). Browse the Subversion
log for configure, you will find more Solaris annoyances.

when you refer to the default shell, would you be referring to implementation
of /bin/sh on solaris?

Yes, I mean that thing that interprets shell scripts by default. It is horrible.

Note: See TracTickets for help on using tickets.