Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#630 closed defect (invalid)

MPEG audio is garbage on all MPEG files

Reported by: bobby.weinmann@… Owned by: mans@…
Priority: normal Component: libavcodec
Version: unspecified Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Running the attached file with mplayer using the default ffmp2 audio codec reads
an incorrect frame size and produces garbage audio. This happens on any MPEG
video I've tried from the internet. The files work OK with smpeg and better
with libmad codec. This happens in mplayer 1.0rc1 and svn as of 11/08/06
(American date format there).

Attachments (3)

mplayer.log (49.3 KB) - added by bobby.weinmann@… 12 years ago.
mplayer output
mplayer-bug.txt (1.5 KB) - added by bobby.weinmann@… 12 years ago.
System information (gcc, uname, etc.)
julie_german_400_32_160.txt (722.4 KB) - added by bobby.weinmann@… 12 years ago.
sample file. Rename to .mpg

Download all attachments as: .zip

Change History (8)

Changed 12 years ago by bobby.weinmann@…

mplayer output

comment:1 Changed 12 years ago by bobby.weinmann@…

Changed 12 years ago by bobby.weinmann@…

System information (gcc, uname, etc.)

comment:2 Changed 12 years ago by bobby.weinmann@…

Changed 12 years ago by bobby.weinmann@…

sample file. Rename to .mpg

comment:3 Changed 12 years ago by bobby.weinmann@…

comment:4 Changed 12 years ago by compn

known problem, use -demuxer lavf to fix

comment:5 Changed 12 years ago by mans@…

  • Resolution set to invalid
  • Status changed from new to closed

Sample file plays perfectly fine with ffplay.

Note: See TracTickets for help on using tickets.