Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#642 closed defect (invalid)

some mjpeg playback broke after pre8

Reported by: compn Owned by: r_togni@…
Priority: normal Component: vd
Version: HEAD Severity: normal
Keywords: Cc: reimar, mennucc1@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

sample url works in mplayer pre 8 and ffplay svn

in svn mplayer it just displays black video.

it was broken somewhere between r19175 and r19865
( july 23 06 - september 16 06 )

i couldnt narrow it down any further.

Change History (5)

comment:1 Changed 13 years ago by reimar

  • Cc Reimar.Doeffinger@… added
  • Resolution set to invalid
  • Status changed from new to closed

The files specifies an all-black huffman table in the AVI header and the jpegs do not contain any huffman tables overriding it, so IMO the way MPlayer decodes this now is correct (and changing it will break Pegasus MJPEG).
You can fix the file by changing 0x44 at offset 0xac to 0x28 (e.g. with a hex editor) and notify whoever created these files that they are most likely broken (AFAICT the would also play all-black on a windows PC with the Pegasus MJPEG decoder installed).

comment:2 Changed 12 years ago by reimar

  • Cc mennucc1@… added

* Bug 735 has been marked as a duplicate of this bug. *

comment:3 Changed 12 years ago by reimar

Oh, and as in indication that this is really blender's fault:
The problem is in blender/avi/intern/avi.c, where the name "AviMJPEGUnknown" to me seems like a clear indication that they do not actually know what they are doing.
Maybe someone can contact them about that. If they need this for some reason they are invited to discuss this and a possible solution, either (preferably) on MPlayer-dev-eng, here or privately.

comment:4 Changed 12 years ago by reimar

A hack to fix from the MPlayer side is here: http://lists.mplayerhq.hu/pipermail/mplayer-dev-eng/2007-February/048994.html
If this is acceptable for inclusion remains to be seen, it is a hack though, not a proper solution.

comment:5 Changed 12 years ago by mennucc1@…

I (re)assigned Debian bug
http://bugs.debian.org/406024
to Blender ; so now they know about it....

IMHO, the only proper way of fixing this bug is to fix Blender :->

Note: See TracTickets for help on using tickets.