Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#646 closed defect (invalid)

Make error

Reported by: nobrob@… Owned by: diego@…
Priority: normal Component: build system
Version: unspecified Severity: blocker
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

MPlayer compiles with no explicitly enabled codecs, but when I chose a codec
that I need, for example xvid, it fails. This is not specific to xvid though,
any other codec will return an error related to itself (tested x264 and amr_wb).


$ gcc -v
Reading specs from /usr/lib/gcc/i386-redhat-linux/3.4.6/specs
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man
--infodir=/usr/share/info --enable-shared --enable-threads=posix
--disable-checking --with-system-zlib --enable-cxa_atexit
--disable-libunwind-exceptions --enable-java-awt=gtk --host=i386-redhat-linux
Thread model: posix
gcc version 3.4.6 20060404 (Red Hat 3.4.6-3)


$ uname -a
Linux .co.uk 2.6.9-42.0.2.ELsmp #1 SMP Wed Aug 23 00:17:26 CDT 2006 i686
i686 i386 GNU/Linux


$ ./configure --enable-xvid
Config files successfully generated by ./configure !

Install prefix: /usr/local
Data directory: /usr/local/share/mplayer
Config direct.: /usr/local/etc/mplayer

Byte order: little-endian
Optimizing for: prescott mmx mmxext sse sse2 cmov mtrr

Languages:

Messages/GUI: en
Manual pages: en

Enabled optional drivers:

Input: ftp network tv-v4l2 tv-v4l tv libdvdcss dvdread vcd dvb
Codecs: qtx xvid libavcodec real xanim win32 faad2 libmpeg2 liba52 mp3lib

tremor(internal) gif

Audio output: oss mpegpes(dvb)
Video output: xvidix cvidix md5sum gif89a pnm jpeg png mpegpes(dvb) opengl

dga xv x11 xover tga

Audio filters:

Disabled optional drivers:

Input: vstream pvr radio live555 cdda dvdnav smb
Codecs: x264 xvid3 libdv amr_wb amr_nb faac musepack libdts libtheora speex

twolame toolame libmad liblzo

Audio output: sun alsa openal jack polyp esd arts ivtv dxr2 nas sdl
Video output: winvidix bl zr zr2 ivtv dxr3 dxr2 sdl vesa fbdev svga caca aa

ggi xmga mga xvmc dfbmga directfb tdfx_vid s3fb tdfxfb 3dfx

Audio filters: ladspa


$ make
[...]
cc -c -I. -I.. -Inative -I../libmpdemux -I../stream -I../loader -I../libavutil
-I../libavcodec -Wdeclaration-after-statement -O4 -march=prescott
-mtune=prescott -pipe -ffast-math -fomit-frame-pointer -D_REENTRANT
-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE
-I/usr/X11R6/include -I/usr/include/freetype2 -D_GNU_SOURCE -o vd_xvid4.o
vd_xvid4.c
vd_xvid4.c:37:18: xvid.h: No such file or directory
vd_xvid4.c:77: error: syntax error before '*' token
vd_xvid4.c: In function `init':
vd_xvid4.c:98: error: `xvid_gbl_info_t' undeclared (first use in this function)
vd_xvid4.c:98: error: (Each undeclared identifier is reported only once
vd_xvid4.c:98: error: for each function it appears in.)
vd_xvid4.c:98: error: syntax error before "xvid_gbl_info"
vd_xvid4.c:99: error: `xvid_gbl_init_t' undeclared (first use in this function)
vd_xvid4.c:100: error: `xvid_dec_create_t' undeclared (first use in this function)
vd_xvid4.c:104: error: `xvid_gbl_info' undeclared (first use in this function)
vd_xvid4.c:105: error: `XVID_VERSION' undeclared (first use in this function)
vd_xvid4.c:107: error: `xvid_ini' undeclared (first use in this function)
vd_xvid4.c:110: error: `dec_p' undeclared (first use in this function)
vd_xvid4.c:118: error: `XVID_CSP_INTERNAL' undeclared (first use in this function)
vd_xvid4.c:118: error: `XVID_CSP_USER' undeclared (first use in this function)
vd_xvid4.c:121: error: `XVID_CSP_YUY2' undeclared (first use in this function)
vd_xvid4.c:124: error: `XVID_CSP_UYVY' undeclared (first use in this function)
vd_xvid4.c:133: error: `XVID_CSP_RGB555' undeclared (first use in this function)
vd_xvid4.c:136: error: `XVID_CSP_RGB565' undeclared (first use in this function)
vd_xvid4.c:139: error: `XVID_CSP_BGRA' undeclared (first use in this function)
vd_xvid4.c:142: error: `XVID_CSP_YVYU' undeclared (first use in this function)
vd_xvid4.c:151: error: `XVID_GBL_INFO' undeclared (first use in this function)
vd_xvid4.c:162: error: `XVID_GBL_INIT' undeclared (first use in this function)
vd_xvid4.c:172: error: `XVID_DEC_CREATE' undeclared (first use in this function)
vd_xvid4.c: In function `uninit':
vd_xvid4.c:206: error: `XVID_DEC_DESTROY' undeclared (first use in this function)
vd_xvid4.c: In function `decode':
vd_xvid4.c:216: error: `xvid_dec_frame_t' undeclared (first use in this function)
vd_xvid4.c:216: error: syntax error before "dec"
vd_xvid4.c:217: error: `xvid_dec_stats_t' undeclared (first use in this function)
vd_xvid4.c:226: error: `dec' undeclared (first use in this function)
vd_xvid4.c:227: error: `stats' undeclared (first use in this function)
vd_xvid4.c:228: error: `XVID_VERSION' undeclared (first use in this function)
vd_xvid4.c:237: error: `XVID_LOWDELAY' undeclared (first use in this function)
vd_xvid4.c:237: error: `XVID_FILMEFFECT' undeclared (first use in this function)
vd_xvid4.c:238: error: `XVID_DEBLOCKY' undeclared (first use in this function)
vd_xvid4.c:239: error: `XVID_DEBLOCKUV' undeclared (first use in this function)
vd_xvid4.c:240:30: missing binary operator before token "("
vd_xvid4.c:260: error: `XVID_CSP_INTERNAL' undeclared (first use in this function)
vd_xvid4.c:272: error: `XVID_DEC_DECODE' undeclared (first use in this function)
vd_xvid4.c:280: error: `XVID_TYPE_VOL' undeclared (first use in this function)
vd_xvid4.c:292: error: `XVID_TYPE_NOTHING' undeclared (first use in this function)
vd_xvid4.c: At top level:
vd_xvid4.c:321: error: syntax error before '*' token
vd_xvid4.c: In function `stats2aspect':
vd_xvid4.c:323: error: `stats' undeclared (first use in this function)
vd_xvid4.c:323: error: `XVID_TYPE_VOL' undeclared (first use in this function)
vd_xvid4.c:340: error: `XVID_PAR_11_VGA' undeclared (first use in this function)
vd_xvid4.c:343: error: `XVID_PAR_43_PAL' undeclared (first use in this function)
vd_xvid4.c:347: error: `XVID_PAR_43_NTSC' undeclared (first use in this function)
vd_xvid4.c:351: error: `XVID_PAR_169_PAL' undeclared (first use in this function)
vd_xvid4.c:355: error: `XVID_PAR_169_NTSC' undeclared (first use in this function)
vd_xvid4.c:359: error: `XVID_PAR_EXT' undeclared (first use in this function)
make[1]: * [vd_xvid4.o] Error 1
make[1]: Leaving directory `/home/robert/mplayer/libmpcodecs'
make:
* [libmpcodecs/libmpcodecs.a] Error 2


Any ideas?

Thanks.

Change History (1)

comment:1 Changed 13 years ago by diego@…

  • Resolution set to invalid
  • Status changed from new to closed

(In reply to comment #0)


$ make
[...]
vd_xvid4.c:37:18: xvid.h: No such file or directory


Any ideas?

xvid.h not found, you need to specify the (apparently nonstandard) include path.
This is not a bug in configure, you chose to force xvid ..

Note: See TracTickets for help on using tickets.