Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#651 closed defect (wontfix)

MPlayer can use OpenAL.org's framework pkg for Darwin/MacOSX

Reported by: sci-fi@… Owned by: reimar
Priority: normal Component: ao
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Hi,

A ready-to-install framework pkg of OpenAL for MacOSX has been available for
some time at http://www.openal.org/ .

Building from source for OSX entails using the tarball-provided XCode project
files, not a normal ./configure-make procedure, so this will result in the
framework scheme also.

Only a couple minor tweaks for MPlayer are needed to auto-detect this OpenAL
framework on MacOSX and compile/link with it. I'll submit a patch to this report.

Not sure of any benefits, but it seems to work (-ao openal) albeit the volume
level is quite low on my Dual G5 (its S/PDIF output can't be adjusted by OSX
itself). There might be a separate but associated controlling app to set the
OpenAL volume level(?).

I'm going to try finding out why the *ix-style libs won't build on OSX...

fwiw I think to get OpenGL working natively on MacOSX might need some similar
tweaks.

Thanks.

Attachments (1)

libao2_openal_for_darwin.patch (991 bytes) - added by sci-fi@… 13 years ago.
patch for configure & libao2/ao_openal.c to let MPlayer use OpenAL frameworks for Darwin/MacOSX

Download all attachments as: .zip

Change History (6)

Changed 13 years ago by sci-fi@…

patch for configure & libao2/ao_openal.c to let MPlayer use OpenAL frameworks for Darwin/MacOSX

comment:1 Changed 13 years ago by sci-fi@…

Here's a patch that applies to configure & libao2/ao_openal.c to let MPlayer
use OpenAL.org's framework installer pkg for Darwin/MacOSX.

comment:2 Changed 13 years ago by reimar

  • Resolution set to wontfix
  • Status changed from new to closed

I don't intend to add OS-specific hacks even before OpenAL is even useful (it
can at best do mono).
Making OpenGL work first of all needs a method to create a window and context,
since that is not part of the OpenGL spec.

comment:3 Changed 13 years ago by sci-fi@…

(In reply to comment #2)

I don't intend to add OS-specific hacks even before OpenAL is even useful (it
can at best do mono).

Was just trying to help.

I fetched OpenAL's latest svn and built the .xcodeproj found therein. Apple has
done quite a bit of work on it since the pkg/dmg was produced. For one, the
audio level seems normal now with mplayer -ao openal and this patch. So they
seem to be serious about wanting to support OpenAL (wondering if it'll be
officially included in Leopard).

With this patch perhaps you might then get _more_ people interested in testing
it. Since I haven't seen it hurt anything, why not put it into svn for others
to test, isn't that one way to get it tested?

But as seems to be often said around here: "whatever you say"... ;)

At least the patch has been recorded; it hopefully won't get lost as would be
likely the case on maillists & newsgroups.

Making OpenGL work first of all needs a method to create a window and context,
since that is not part of the OpenGL spec.

Isn't that a common thing when doing _anything_ with OpenGL no matter the
platform? My goodness you just state the obvious here. ;)

I'd think creating a window would be a function of the chosen GUI wrapper for
mplayer. As far as OSX is concerned, that would be something to work on in the
mplayerosx project, which already has 3 -vo choices it can support directly,
then we'd just add the code for it to do -vo opengl. First thing is to get
mplayer to build itself properly with Apple's OpenGL framework, that much I
should be able to help with. (I got -vo sdl working here, too, which we could
already start adding to mplayerosx.)

I'll open another separate bugreport for the opengl functions once/if I can get
it figured out. I was just commenting on how similar it might be just to get it
to compile with the frameworks, as OpenAL was here.

Thanks...

comment:4 Changed 13 years ago by reimar

Of course I am happy you are interested, I just wanted to make clear that
openal is not at a point where (IMO) complicating things with OS-specific stuff
will help, esp. since it is something I can't even test (and it breaks in case
someone installs OpenAL the "normal" way).
And testing is not what is needed for OpenAL, but a developer working on it.
Here on linux I've now been waiting for one year for an OpenAL update that
would make it work properly :-(. I really had higher hopes in it.
And MPlayerOSX is just the Gui, you can't add OpenGL support in that, the
window generation code as it currently is must be directly integrated into the
vo code.

comment:5 Changed 13 years ago by reimar

Actually got OpenAL mostly working on linux (though there still are not exactly
that many features implemented).
Also added a more compact and less system-specific configure check that should
also work for OSX (see "OpenAL on Mac OSX: video playing at 2x speed" -dev-eng
thread).

Note: See TracTickets for help on using tickets.